mlrV not playing samples!

  • hey everyone.

    i recently got my new monome gs 64 and was using it with mlrV. everything was working great. a few days ago i installed max for live to use the monome with ableton. now when i open up mlrV and try to use it the application recognizes the 64 (i know this because when i turn on dac the top right corner flashes to the tempo) but it will not play a sample. rather than playing the sample, when i push a button the first light in the row of the sample will light up and stay there not moving.

    on the other hand, regular mlr works fine...

    please help!

    max

  • I'm having the same problem, MLR works fine and MLRV just sits on the first slice not playing anything.

    I'm on 10.6.6, I've got max msp 5.17 and jaxk osx installed.

    weird, let me know if you figure out how to get it going, I'll give it a whirl too.

  • ah, I've reinstalled on a new laptop.

    Forgot to install xsample, follow the instructions in the MLRv folder under xsample(your os).

    going sweet now.
    dylan.

  • thanks so much man. fixed everything!

  • How do you install xsample just copu and paste files? Did that it still dosent blink or play any

  • Copy and paste.. that's what I did… except for the 'sample.help' file, because I don't see the 'Max5/Cycling '74/msp-help/' folder that they instruct us to put it in.

    I was presuming that this is because I have Max 5 Runtime instead of the full version of Max 5, but maybe I'm wrong.

    I'm still having issue even getting mlrV 2.0 to recognize my monome 64.

    I'm curious.. what is everyones settings within mlr 2.0?

    The only thing I've done is select 'monome64' from the 'Device' tab (actually, it was already set to 'monome64') … and then I select 'from MonomeSerial 1' in 'Device Input' … I've left everything else alone… The DSP defaulted to 'CoreAudio Built-in Output' which seems correct.

    MonomeSerial has been left to its default settings:

    Host Port: 8000
    Listen Port: 8080

    but I did change the Address Pattern Prefix: /mlrv

    Still no response… though my monome works fine with the Test app, as well as 64fingers.

    Any ideas?

  • Try reselect your quantize setting in the tempo patch… I saw someone else post this and everything starting working for me after I starting messing with the tempo.

  • Yup… Try turning Quanitze to 'none' .. then press any button on your monome and you should see the top right button light up (group 1) … assuming you have a sample loaded in group 1.

    After that it works great.. just keep your Quanitze set to none.

    A bit of a drawback for the less timely folks like myself.. but it's good practice until 2.1 :)

  • ^^^ if you are suffering this issue. go to the SETUP tab and select "INTERRUPT" in the DSP settings.

    you may need to change the quantise setting, but you should be able to reselect any of the provided quantise levels.

    just to be safe, check your CLOCKSOURCE is set to internal.

  • My device input says none and theres no options, anyone know why?

  • if you're using a monome, this shouldn't matter at all.
    if you're using a MIDI controller, hit the big 'refresh' button which will rescan your ports for connected devices.

  • Got it thanks!

  • Hi,
    I'm using a monome 128.
    mlrV: 2.3

    Newbie-question: why are the samples not being played?

    The monome seems to be working? The ligths are shining but the samples won't play. Using the runtime of Max 7. I also installed the fullversion. Find the Max Window, the monome 128 and the mlrV screen attached to this post.


    copied the xsample files as follows:
    'xsample.help' to:
    \Cycling '74\Max 7\resources\help\msp

    'xsample.mxe' to:
    \Cycling '74\Max 7\resources\externals\msp

    'xsample-objectmappings.txt' to
    \Cycling '74\Max 7\resources\init

    767 x 656 - 84K
    1038 x 722 - 119K
    3920 x 2204 - 1M
  • @vollkorn
    xsample only runs in 32-bit mode. cmd+i on max7 icon and select open in 32bit mode. might be that.

  • @sno
    many thanks for your reply!

    I'm using win8.
    I downloaded max7 32-bit and started all over.
    Same problem:

    "xgroove~: No such object"

    590 x 646 - 88K
  • i use mac os x, maybe it is best if someone on win8 gives you a hand… sorry.

  • i don't have my windows computer at hand so can't test directly, but you need to install the xsample~ externals. they are included in the mlrv download folder. i'm not sure how to install externals in max7 as the folder structure changed (at least on osx) but i'm certain you can find out where to put files with a google search: "how to install externals in max7"

  • GALAPAGOOSE: I LOVE YOU!!!!

    I copied the xsample folder into ~/Documents/Max 7/Library folder. Started mlrV and it worked. YESSSSSSSSSSSSSSSSSS!!!!

    For more informations check:
    https://cycling74.com/forums/topic/how-do-i-add-externals-in-max-7/

  • thanks for letting us know it worked!