Arduinome - lights going out

  • I disconnected my bibo boards from the shields so I could make some measurements for my enclosure. I'd not had it plugged in or used it for a while. When I reconnected the boards to the shields and plugged it back in I fired up Arduinome serial and monome_test with the lights/buttons toggled. I'm seeing lights go off without the buttons being pressed. I've uploaded a video here, sorry it's not a great camera.

    http://vimeo.com/18891745

    Tonight I'll test the diodes, in case they're the problem. Can anyone else suggest some potential causes, things to test?

    Thanks.

    Marto

  • I've tested all the diodes with a multi meter, they all seem to be working.
    Does anyone have any suggestions what to check next?

  • I'll take the faceplate off, check every join and retest.

  • So I've tried the following with one board:

    * Tested all the diodes.
    * Checked the Cables for continuity with a multimeter.
    * Reflashed the board (from a80h-001 to a40h-001).
    * Reflashed the firmware.
    * Reheated each solder joint on the unsped shield (with the chips removed).

    I'm still experiencing the same problem when testing. The video linked to in the first post of this thread exhibits the problem. This all worked at some point, but I didn't have it enclosed and people may have dropped/messed around with the arduinos/shields, not that anyone has admitted this as yet :)

    I was pointed to some other build problem post when talking in the IRC channel. One concerned the pins making a proper connection with the ribbon cable via the IDC connector.

    I took a spare pin, pushed it into the and marked the point at which I couldn't push it any further into the IDC connector then marked this with a sharpie.

    I have odd sets of IDC connectors (I ordered two from one supplier and two from another because I made a mistake when ordering parts), one seems a couple of millimetres shorter than required.

    I've tried one arduino/shield combination with both sets of ribbon cables, with the same result.

    At the moment I'm thinking of changing IDC connectors, and failing that ordering a set of replacement chips.

    Can anyone think of any other avenues of investigation I should go down before ordering a new set of chips?

    Cheers.

  • In addition to this I've:

    * Soldered a new unsped shield.
    * Tested it with two runs of the MAX7219CGN (+0953 and +0903)
    * Crimped new ribbon cables. (a chat on the #monome suggested this may be the cause)
    * uninstalled and reinstalled the FTDI driver

    I've tested this setup on both bibo boards and the same problem occurs.

    If it's any sort of hint, the start up sequence pauses as though sticking then restarts and completes a moment later.

    If anyone has any other ideas I'd be very grateful.

    Thanks

  • If it's any help here are some pics:

    Unspend shield:

    Back: http://img847.imageshack.us/i/shieldback.jpg/
    Front: http://img192.imageshack.us/i/shieldfront.jpg/

    Bibo board:

    Back: http://img194.imageshack.us/i/biboback.jpg/
    Front: http://img30.imageshack.us/i/bibofront.jpg/

  • Weirdness.

    With many thanks to rud and Ycros I've found out the problem only occurs with one column on the bibo board. I'll focus my debugging efforts here.

    Thanks again to the community for the help and support.

  • I've uploaded a video of the phantom button presses to vimo. I had to slow it down to .03x speed in order to see the button presses. It first happens at about 7 seconds in

    Video: http://vimeo.com/21870982

    When any of the LEDs are light in the 5th row (see pic below) this happens, and keeps going, the board looks like one of those 1970s disco floors.

    I've also taken a couple more shots of the boards. The first is of the front of the board with the row which seems to be causing the problems highlighted. The second image is of the back of the board, again I've highlighted the components associated with the row which causes the problem.

    Front: http://oi55.tinypic.com/dncdav.jpg
    Back: http://oi52.tinypic.com/beinw2.jpg

    I've held the board up to the light, I can't seen any broken tracks.

    I'm wondering if I should remove the associated pin header, clean the area and replace it, in case that's the problem. Since I've resoldered it previously, the same problem occurs with different arduinos, shields, ribbon cables etc.

    Regarding cleaning boards, someone told me I could simply use a cloth with some acetone to remove flux and stuff. Having read a couple of (other) forum posts on this subject I'm not sure about his, apparently it could melt some plastics.

    If anyone has any comments on the problem or my approach I'd be glad to hear them :)

    Thanks

  • Weird.

    First off I made a mistake, the image of the back of the board where I highlight which column is affected is wrong, on the reverse of the board it should be the 5th row rather than the fifth column.

    Anyway I checked all this out.
    As mentioned above, using multiple arduinos, shields, USB cables and both bibo boards I can reproduce the same problem. Every button lights up fine in the test patch until I light anything from the fifth column. If I only light the fifth column the problem doesn't occur, none of the other buttons register a press.

    I'm wondering if there's something wrong with the windows laptop I'm testing with. I have a linux laptop, I plan on running similar tests on.

  • Could be a header/ribbon cable issue IMHO...

    I'd have a look at the shield - in particular the pins highlighted.
    There could be a cold solder joint or two that would give you these issues...

    http://img64.imageshack.us/i/picture1iq.jpg/

    HTH

  • i am quite sure this is a problem with your RSET Resistor choice. Check the values of your LEDS and ensure that you have used the correct resistor for them.

    http://www.arduino.cc/playground/Main/MAX72XXHardware

    At the bottom of this page is how to check you have used the right one. I am not sure the data sheet I got for my ebay LED's was correct so you may want to go bigger than you need just to be sure. It will not effect the brightness noticably but will stop the nonsense you are experiancing.

  • @Mckenic

    Thanks, I've crimped a few sets of cables, tested them with a multimeter and each set has the same problem. Thanks for the photo, I'll double check those points, but I'm pretty sure that they're ok, but it's always better to check.

    @grooveshysta

    I recently changed the resistors from 22.5k to 24k. I was advised that the 22.5K may run a bit high. I did get the LEDs from ebay, their spec was listed as "forward voltage 3.2 to 3.8v forward current 20mA(typical) 30mA(Max)".

    Thank you both for your suggestions.
    In conversation with FingerTappin in the IRC room this morning I think this actually may be a software issue. The windows laptop I'm testing on is on loan from a friend so I can't go changing too much. Now that serialOSC supports linux I'll be able to test on my linux laptop.

    Thanks again

  • I really think its your Rset and LED choice. That range is not very specific. I had a set of white LED's from Ebay with a wide range of opperation. I did not trust it in the end and got a set from Farnell which meant icould accurately calculate the value.

    Check this link http://www.arduino.cc/playground/Main/MAX72XXHardware

    Have a look at the Rset chart and read on to the mulitiplexing section relating to how rset works with the max driver. By having the wrong rset, when you start getting more LED's lit, you will send a greater current to the max chip making it not happy.

    I would suggest playing with the resistor value maybe install a variable resistor to tune in the 24 to 29k range and adjust till it works. I replaced all my LED's but which i had just done this. It would have cost a lot less and saved loads of time.

    Good luck, your nearly there!!!

  • @grooveshysta

    Ah, now I'm with you, I'll try and get my hands on a variable resistor today. Do you think I could have damaged the max driver(s)?

    Thanks again.

  • you could have damaged it but i think you should be ok. I was having the same issue and only got it fixed when i had Led's that i knew exactly what values they where. You max have anything plugged in right now. I think they put wide values on ebay data sheets as it makes them more useful in more situations. You may have illegal North Korean LED's for all we know! Try out the variable, looking back, this is what i would have done. You may hit the correct value. Failing that, get better LED's.

  • More fool me for cheaping out on the LEDs :P

  • Well I attached a 50k pot, started it off at 25 and moved up. The problem still exists all the way up to 50K. The lights got slightly dimmer, but not by much.

  • I ended up making a new button board and that sorted it for me. Where are you? Is there anyone local to you that can swap working parts with you? I am in London.

  • I'm in Glasgow. I don't know of anyone local to me I'm afraid. Did you order new bibo boards, leds and diodes or just replace all the LEDs?

    Thanks

  • Dean is up in Aberdeen and super knowledgable. Ill mail him and get him to get on this thread.

  • first off, Pete you suckah, im in dundee!!

    Marto will you be swinging by the dee anytime soon bud?

  • Oh balls. Its all the same. I new it was somewhere backward.

  • Hey dean,

    I'm less than two hours drive away, I guess I could swing by.

  • hey marto, im totally cool with that bro! Friday afternoon would be the best time, i know its a pain in the ass as its a week away, but im not sure what i have on next week!

  • Hey dean, thanks for getting back to me. I work 9-5 Monday to Friday, so I'd need to arrange time off if a Friday afternoon is best for you. Sadly this Friday is too soon to arrange that. Are Friday afternoons normally good for you?

    Thanks again.

  • no bother man, most of the time fridays are fine. If you want you can send it to me in the post and i can look at it? aslong as you pay postage i can hopefully fix it up for you as i have lots of spare parts etc. and can test it with another button board/brain.

    Whatever suits you best. it shouldnt be expensive if you just send the parts rather than enclosure, but either ways fine. Im happy for you too come through though. I might even be able to do this saturday but ill get back to you on that.

  • Hey dean,

    many thanks for getting back to me. If you were able to do this Saturday I'd be up for that. I'd be keen to turn up. Failing that I could post the stuff up to you.

    Thanks again

    marto

  • Wow Dean! You will no longer be the only Monome owner in Scotland! You will still be the only gay in scotland though!

  • Fellow Scot Firebrandboy also uses a monome:

    http://en.wikipedia.org/wiki/Firebrand_Boy

  • ^indeed, that's me!

    also, miaouxmiaoux was a monome owner before me!

  • shows you what i know! Dean is a gay lord though.

  • I am no gay lord! You know knothing pete -_-. haha

    @Marto - Ill get back to you tomorrow regarding if saturday is free, i dont think its going to be though :(.

  • cheers dean!

  • As rud suggested in the IRC room I tried using old harddrive ribbon cables, purely for testing. The same problem still exists.

    In MProg when looking at the properties of the device 'Max Bus Power' is set at 90 Milli amps. Can anyone confirm that this is correct? I'm using the Seeeduino boards.

    Thanks

  • Dean was kind enough to spend some time looking at this build problem for me, and was able to recreate the problem. This was good to know because I wasn't going mad. Dean didn't see any soldering problems.

    Someone had mentioned that the LEDs I used from eBay may be the cause of the problem. Before ordering and resoldering is there anything else I can check?

    Thanks