mlrv 2.2 [new version]

  • hahah, sounds like me and a lot of people need a video to show them how to get a basic soundflow going on this beauty, it's just a bit of a head scratcher hehe. I think I'm giving up for the night but some sort of explanation video wouldn't hurt at all those who are wise :)

  • @goose hey trent, what in your humble opinion would be the best way to get mlrv running correctly with launchpad?
    It works but has some button overlap, I'm wondering if it has something to do with the fact I've no where to set the /mlrv ? (MonomeSerial won't work with launchpad)

  • % and galap: dim the screen, take a breath, have a beer. you've earned it.

  • @loganderson — why not make one and share?

  • @goose @miller first row of 4 trigger for me, then are interrupted by the pattern buttons

  • @kane:
    what's the overlap? i had to rework a bunch of the launchpad mapping so it's possible that it broke... let me know what issues you're having and we'll get it done for 2.1 (veryyyyyyyyyyy soon)

  • @galapagoose no worries.

    The first row of square buttons also trigger the first sample row. I'll experiment more with it tomorrow.

    A workaround could be to just not use the first sample - load your first loop into the second sample row.

  • > Awesome app guys! The UI is so slick - the fact that this is all Max/MSP blows my mind.

    it blows my computer's mind too. nearly 1gb ram used just to load a few loops!

  • @ %, dude, I'm so lost in this right now! haha. you be da masta!

  • @goose I think the best bet for troubleshooting the launchpad would be sitting down with one for an hour or so. I'm not worried - you guys are genius's I know it'll be working like a dream soon

    Someone in NY lend these guys a launchpad stat!

    as already stated, this is some sexy sexy soft - exciting times ahead!

  • if anyone wants to send us a launchpad, we will graciously accept it, use it for mapping, then sell it on ebay. message us hello@parallelogram.cc

  • @%:

    Wait, MPD support is missing? So it can't be used as a basic device to trigger one-shot samples/slices, like drums? So how is galapagoose using his MPD in the "too many" video? I thought that was one instance of mlrv2 being used for both the monome and the MPD18, with the latter's pads being MIDI-mapped to drum samples.

  • first off thanks a ton to all those in the crew who made this rig possible... The thing seems to be just out of hand and I applaud the fast action on the responses.... And now I am going to ask yet another question. Anyone resolve the issue with rewiring to Live??? The DAC keeps shooting up the audio disabled screen. Makes me wonder how I was able to work the previous mlr...

  • @nightmorph:
    yes indeed that was all mlr2. unfortunately the mpd + drumpad mapping is still not solid enough to release into the wild (trust me we'd have even more complaints if we had released it!) but it will be with us very soon! 2.1 baby.. or is it 2.001........

    @kinematix:
    glad to hear you're digging it! if the rewire was working with your old version, there's no reason it should be disarming now... we've got rewire working on both of our machines, but i have heard of the DAC being auto-disarmed in rewired mode. still an unsolved issue i'm afraid but we've gotta ship! we'll keep it update regularly and hopefully find a problem for your solution.

    if you have any more info, please post to: http://code.google.com/p/mlrv/issues/

  • yeah it'll be fully possible with 2.1 or 2.001 ..... whatever... updates soon.
    for now, we've got wine to drink.

  • drink wine and be merry ;-)

  • word son

  • Lovely! Unfortunately It won´t play on my launchpad. Pattern recorders and fx send light up, but no sample playing.. Is there a play button I missed? Am I supposed to run it with nonome , or just straight LP into mlrv2.0?

    I´ll try some more here..probably me just doing something stoopid.

  • can anyone here tell me what the correct "SETUP" would be if im using my monome 64, monome serial, and Mbox2...the buttons seem to be responsive - the only problem is that I cant hear anything at all. Is this a standalone app or do I need to be using it as a plugin?

    thanks for any help or examples shot my way

  • we dont understand. elaborate.

  • already playing around with loops and gawking at the lovely UI. you guys have truly outdone yourselves this time.

    figuring out the mapping and the corresponding lights will take some getting used to, but from here, it seems the sky is the limit. to infinity and beyond! (that's right!)

  • when I click on the setup section i am pretty lost

    I dont know which settings i should choose in order to hear something going on

    Device inputs or outputs??

    osc remote??

    dsp??

    i would like to know what selections i need to make for everything to be running properly

    i loaded samples into all the slots but all im getting isflashy lights, no sound

    Thank You

  • helllo 1212 — dsp makes audio come out, take a look at that. make sure the correct driver is selected. did you install xgroove? if not you should have received an error message. is your monome configured correctly? are you using mlrv/ as the prefix? do other apps work correctly (like mlrv 1)?

  • /parallelogram/ crew is going to sleep after three straight days of patching. we have a release party to play. please log your questions in the bug tracker. we love you all.

  • i dragged the three xsample files to their proper homes

    opened up the program

    im using a MBox2 for all my other programs like logic or ableton

    so i chose the "CoreAudio Digidesign Mbox2"

    i dont know what needs to be selected on the device input or output
    i dont know if i need to set anything in the remote section
    im not sure if i need to set anything in the osc remote section

    right now it says
    receive port 8000, send port 8080, device ip 268.254.250.176

    and then i loaded samples in each slot

    and then nothing will be heard

  • Mind is blown. I love /parallelogram/ get some rest homies.

  • sorry if im buggin maybe ill just wait till a set up video comes out or something like that, and just one more thing doesnt the "/" come before the mlrv for the monome serial?

    have a good rest

  • Guys try looking in the Max Window if you are having problems - it may shed some light and allow for swifter debugging.

  • Big ups to the creators/supporters! Cant thank enough... I will now be sleep deprived for weeks.

  • just been trying out the midi mapping with a nanocontrol. So awesome.
    Accidentally deleted the mapping for the top row buttons though.
    I need more knobs- if you had a fader and two knobs for each row you can adjust volume/gain with the fader and use the two knobs to select the start and end point of the sample. Sooo good, quick to work.

  • been a crazy last couple of hours trying to figure out the pattern and mapping controls...love the way the response feels. quick and sharp, like a whole new instrument at my fingertips. can't wait to refine things and start up some new work on this glorious program.

    thanks again parallel brovs. you guys are heroes.

  • yo kids! LOOKS DOPE! Love the new layout...still trying to get it to work. Only the top row plays regardless of what I press. In the left corner of my 128 the buttons light up like they should when I press the corresponding row, but I get no sound out of them, and no led slice following (except for first row). Thanks for putting names up...not necessary...it should just be YOUR NAMES!!!! THANK YOU THANK YOU THANK YOU...weird seeing my name on a program I worship haha:) Sleep...I'll see what the feedback is tomorrow. YOU GUYS KILLED REGARDLESS OF MY TROUBLES! THANK YOU!

  • Ok for all my Launchpad buddies:


    The launch pad does work, just needs to be configured

    1. you have to have the launchpad drivers
    2. latest max-msp runtime
    3. mlrv

    -------------------

    1. plug in your LP
    2. open max runtime
    3. open mlrv
    4. click setup and set:

    device: LP
    device input: LP
    device output: LP

    clock source: internal (or rewire for rewiring)
    sync: off
    remote midi input: off

    osc remote:
    receive: 8000
    send: 8080
    device ip: your device ip should show up automaticlly

    driver core audio (or whatever soundcard/rewire/live etc)
    io vector : try 512
    signal vector: try 512

    in enviroment leave everything to default but set row count to 8

    leave setup

    set all samplers steps to 8

    now in mapping:

    delete everything in input, hit start mapping and assign the group stops (above the mute on the faders) to the round buttons (1,2,3,4) now unclick start mapping and delete any rule other than the ones that look like:
    cc:1:104 /mixer/1grp/stop

    Your Launch pad should operate pretty well now.

    the round buttons down the side of the launch pad can't be mapped, from what I can tell, they just trigger one shots of the sample on that line

    After a short while, maybe 10 mins, the lights will stop responding, and sometime will start working again, seems totally random, and nothing in the max window says anythings wrong... so thats a pretty big bug to squash

    Hope that helps

  • Thanks Kane, I´ll try your method now. Got it up and running on my LP as well, but the lights were all over the place and had some strange stuck delay and pattern recorder behaviour..maybe just me noobing it though. Took me while to notice the dac and master faders where set to zero by default lol.

    The midi mapping and timing is just lovely!

    Well done /parallelogram/ !

  • am on win 7 x64, running latest max msp, unable to get it running. All 3 xsample files have been put in respective folder. Clip able to trigger, but no lights across a gs128

    Tried running older mlrv versions, working fine with no problem.

    Attached the max window, other than the sound card part, i cant get paramap and aux bpatcher part.

    1600 x 900 - 107K
  • no joy on windows (xp) here either, max crashing, latest runtime etc...

    same story as above with older version of mlrv etc running fine,

  • this is amazing, I love it!

    one quick mapping question:

    anyone know how to setup a button to do 'next tempo'

    I tried typing in '/time/tempo[next]' next to a button assign, but it just sets the tempo to 1.0!?

    cheers :)

  • interesting, after i unclick the box for "in audio interupt", within the dsp status through max instead of the setup option within mlrv2, clip triggering with light feedback is back to normal on the gs128, running asio4all btw.

    now to try out rest of the functions. Lotsa fun it should be.

  • This is just great ! I love it !

  • Anyone know how to set up Ipad touch OSC yet?? The Max window is reading it but mlr wont map it... Probably a dumb mistake on my part. WORD

  • hi, what a beautiful looking update!

    has anyone found out how to use the cell mode mentioned in the docs:
    "alternatively, the user may choose to divide the row into a
    number cells, into which individual samples can be assigned. this is accomplished by clicking the row/cell toggle at the far left of each row."

    i can't get my head around this one... i see no toggle :)
    cheers!

    a

  • Couple of questions to everyone.

    1. Anyone else not seeing a working delay/aux channel? (I'm Win 7 64bit)

    2. Anyone else getting an error "1[ch]slpress: no such object"? I can't seem to reproduce it - it doesn't seem to effect functionality (that I can see) but might be worth looking into at some point.

    EDIT: the above error is caused when a row hasn't been assigned to a group. maybe rows should be given default of group 1 like in mlrv 1.x?

    Looks absolutely amazing btw, such fun!

  • This might have been covered, but I download 2.0 I double click _mlrV.maxpat, max opens and crashes, flat on it's face. Force quit required.

    Any thoughts? OSX. Max 5.0.8.

    Update, I was able to see the max window this time, can't scroll as max just freezes, almost crashed osx this time.

  • @JP requires "Max/MSP version 5.1.7+"

  • :-) - oppsie !

    actually, same identical error on 5.1.7

    I'll try and home, this install might be b0rked.

  • Installed and loaded up fine.

    When I click DAC, the "audio disabled click here to enable" window pops up. When I check setup, the proper driver (coreaudio built-in output) is selected but no lights, no sound.


    The strange thing happens when I open the pervious mlrv while mlrv2 is running... It sorta starts working, but I have to have both open, and it's isn't exactly working correctly. A sound file shows up on the old mlrv as if I dropped it in there (actually dropped into mlrv2). Sound is playing from both programs. If I mute mlrv, the file still plays in mlrv2, but very buggy.

    Top row isn't working for me. The LEDs on the top row are lighting up along with the 2nd row.

    OSX
    gs128

  • wooww. here I was trying to set up nonome to use with my launchpad

    as soon as I realized my launchpad was supported natively I exploded

    this is just awesome software, guys. good job.

  • @galapagoose & @% : Great job !!!
    Keep up the good work !

    I think i found a few issues that i reported on the bugtracker

    And ... any plans to re-add top-row configuration ?
    That was a must.
    Also, button to fullscreen the UI could be nice ;p

    #edit: and what about backwards-inner-looping ? is it supposed to work ? or is it my setup that has too old xsample/max/whatever to get backwards playback of inner-loops running properlly ?

    R.