gs128 buttons seem to 'stick' and not work or stay on

  • I have a gs 128, and it seems that for some reason, when i press buttons, they will stay toggled 'on' at times, or act as if they are continually being pressed when i've already depressed them. also sometimes i'll press down a button and find that it doesnt respond, and then go back and press the same button just to find out that it responds the second time.

    I've uninstalled monomeserial, and reinstalled it a few times, I've tried serialosc a few times as well, and yet, for some reason this keeps happening. I tried uninstalling and reinstalling the FTDI drivers too.

    I did a quick search on the forum, and it doesnt seem like people have had this specific issue. all the LEDs work fine, but when i tested this in monome test, I have the same problem.

    I just bought this second hand from someone on the forum, and when i got it it was working splendidly! is this most likely a software issue, and if so, could someone point me in the right direction? or is there a chance it's a hardware issue? I've got some shows up in early march, so i gotta get this figured out now!

    also for the record, I baby this thing, so i haven't spilled anything on it, or eaten around it or anything ;)

    thanks in advance for any help!

  • and in a stranger turn of events, i unplugged the damn thing and plugged it back in and it all works perfectly now... lol stay tuned. :P

  • Talcum or baby powder can do the trick:

    http://post.monome.org/comments.php?DiscussionID=7846&page=1#Item_3

  • thanks! i'll check that out later :) everything seems to be working well right now. i think it was a software false alarm...

  • awesome!! you worried me for a minute, lol never did that when it was mine. Hope your enjoying it! Just found out im going to have to wait a bit longer for its replacement to arrive!

  • it comes and goes. I'm convinced it's not the monome! it worked perfectly before i installed serialosc. I think it may have something to do with running monomeserial and serialosc together at the same time?

    I'm trying to find the solution now, but I'm not worried. I've read a lot on this forum about people having issues that seem hardware-related, only to find out that it's actually a software issue. Really this is fine, as it's forcing me to clean up my computer, and make sure it's running nice and smooth!

  • did you uninstall serialosc?

    using both serialosc and monomeserial at the same time will create big problems.

  • yes, i uninstalled serialosc. It made the difference. I think my issue may be with mlrv 2.1 more than anything at this point. I loaded monome test and everything shows up perfectly and nicely, just the way it's supposed to.

    I think i'm going to hold off on serialosc until after I play a few shows, just so i have a chance to really mess with it. I know that i dont seem to understand it very well yet - but I can understand how cool it can be.