mk firmware / serialosc

  • here's a beta version of the new mk firmware.

    this new version requires serialosc. this version is for mk keypad boards only. 40h/alt compatibility is next.

    you must have serialosc turned OFF to flash the firmware: run

    you must reflash your serial number to m0000000 (number of your choice, 7 digits long)

    you must rename one of the .hex files to mk.hex, according to your grid size-- included are 0 grids, 1 grid (8x8), 2 grids (16x8), and 4 grids (16x16).

    normal reflash (substitute your serial):

    avrdude -p m325 -b 115200 -P /dev/tty.usbserial-m0000000 -c arduino -e -D -U flash:w:mk.hex:i

    or run this (after changing your makefile):

    make boot

    remember to turn serialosc back on! run

    test with monome_test and monomeserial.maxpat (i'm about to put together a new testing patch)

    will post to github after some cleanup.

    please report problems and successes.

    encoders and analog on the way.


  • Quick question tehn... in the upcoming encoder + analog update... is it going to be input only... or output as well?

  • at some point i'll get around to writing a digital-out firmware... it's built into the serialosc protocol spec already.

    what are you hoping to do?

  • Not sure at the moment... but if it is possible to send out digital signal / PWM it could make for some interesting expandable possibilities...

    maybe something as simple as a series of 1/4 inch jacks for input and output... those could then in turn connect to a series of external modules to do any variety of things from controlling motors to DMX

    I guess the real question will be whether or not it will be as straight forward of a process as programming for arduino...

    But if you are implying that controls for digital output would be done through OSC... it offers a really interesting option for live AVR programming...

  • What physical device must I purchase to upgrade my kit (one of the first) and greyscale chips?

  • I think you would need a jtagger... basically you would need whatever avr programmer is used for programming the atmegas

  • this is mk firmware only. there's no reason to upgrade other device at this point.

    the grayscale and original kit will work fine with serialosc.

    the initial mk firmware had some bizarre bugs that i've fixed.

  • Sorry, I was unclear. I understand that this isn't for either of those. I was trying to get ahead of the discrete LED firmware update. I looked into it and there were quite few choices but it seemed dependent on chip and sketchy on a mac.

  • @thealphanerd:
    cheapest solution:

    This new update sounds awesome, I'll be trying it tonight. Just to verify, the mk's are the kits that went out in the last year? I sometimes find the nomenclature used to differentiate between different models slightly ambiguous, and confusing.

  • @stdmtd - thanks ;-) Didn't see that last time i check ladyada but is perfect.

  • will this work with windows?

    win7 64 bit.

    just curious. Thinking i may need to wait till bugs are ironed out.

  • serialosc for windows is on the cusp of being finished, so i'd hold off.

  • is there a huge difference between monomeserial and serialosc

  • unless you know about all this low level stuff, i would leave it to the techy types until its released properly. monomeserial works fine as it is.

    that's what i'm doing!

  • Super excited for the windows release.

    One concern though, and this might be ignorance on my part, apologies in advance.

    What About python and java apps. I keep seeing apps need to be Modded to work with serialosc, how does that process start?
    My main performance tool is Livecontrol, no interface to speak of, so I'm concerned on changing it up and killing the time I've put into customizing my live rig.

  • there's a monomeserial router that runs with serialosc to make it backwards compatible.

  • greet'gs.. new guy here.. just recieve'd january 2011 walnut follow'g setup.. ftdi driver site what do i do here..? i chose win zip evaluation version to start.. other down loads- max5.1.7 setup wizard.. max5.1.. max runtime 5.1..monome serial my zeroconf neighborh.. and sourceforge im registered..theres no response of the new edition.. i realize serialosc isnt ready.. whats miss'n that i havent done :(

  • could you start a new thread?

    did you start here?

  • Am I right in thinking that the new firmware requires serialosc and will not work at all with MonomeSerial?

    I notice a few weird bugs on my mk-based DIY 512 (occasional LEDs not lighting up -- cured with a TEST flash or a Clear LEDs) and would like to cure them but I am coming up to a graded performance on March 29th with a 20 minute performance (on monome and my other controllers) and don't want to make the transition to the new firmware if I also have to move everything to serialosc as well.

  • correct. that is bizarre that a clear/test somehow fixes a missing packet? are you using a custom app or refreshing a lot of data at once? (max drop osc packets after a certain rate)

  • Nope. I'm not yet ready to use custom apps live. If I stick to a simple set of application -- say Polygome and Straw I tend to use one app per monome at a time -- left and right. Polygome is always at a sedate -- 50bpm and Straw together sometimes loses the bottom left and right leds of the right hand monome (running straw) or goes half-powered. Both left and right boards are powered from an iMac's by and seem to do fine BTW.

    Straw 512 sometimes goes top faded LEDS

    I really am looking forward to SerialOSC being the standard as I like the idea of having it remember all of my settings and directly addressing each application and assigning them. I guess we are at one of those transition crossroads....

  • ok, so it's not working for me. the problem is my monome is advertising with a 6 digit serial number in /dev, so when i put the 7 digit serial number in the makefile, i'm getting "avrdude: ser_open(): can't open device bla bla bla". Am I missing something here? Do I need to change the serial number before i try to flash the firmware?

  • the makefile should match the serial number in /dev

    make sure you have monomeserial and serialosc OFF as they steal the port

  • so i have my monome mk, i flashed it with a pc/windows.

    Will it work with a mac? Is the firmware/flashing specfic to operating system?

    if i had a mac i would try myself......

    thinking about switching teams in the future.

  • Just tried re-flashing mine, and it isn't working- the monome shows up in monomeserial.maxpat, but when I try to use a patch (polygome) all I get is the entire grid flashing, and seemingly no input from the buttons

    Also: mk-set doesn't seem to recognize presses either

  • mk-set is no longer relevant.

    did you change your serial number?

  • I wasn't sure how: every time I entered something different under the makefile, it just gave me an error

    whats the specific method for modifying the sn?

  • hi all

    i have a grayscale 128. serialosc seems to work fine with that. i was just wondering about the firmware upgrades, if one them is relevant to the grayscale 128 or not. my config is as it was shipped. and is the grayscale able to do
    the led brightness changes?

  • @ priesen

    The firmware update just applies to the monome kits- the pre-made monomes are unaffected

  • @pewt
    oh, i was not aware of that. mk = monome kits, well, now its obvious.
    sorry for interruption and thank you ;0

  • SerialOSC for windows pweez? :( I feel so out of the loop...

    Like someone not invited to the party, and then walking by in a rainstorm looking in at the party.

  • when I type ./configure; make; make install

    I get a

    configure: error: no acceptable C compiler found in $PATH

    I assume with MacOS C is not part of the standard Installer options on the Snow Leopard install DVD? And I need to go to Optional Installs on the DVD

    Just saying so as a warning to anyone who, like me never needed the developer bits before. Might be worth pointing out... Obvious really but still...

  • for OSX, you should be fine using the serialosc package:

  • Ok serialosc unloaded I get

    avrdude -p m325 -b 115200 -P /dev/tty.usbserial-mk000136 -c arduino -e -D -U flash:w:mk.hex:i
    avrdude: stk500_recv(): programmer is not responding

  • er whoops sorry.

    make sure you activate the bootloader

  • :) you see this is why dumbasses like me are useful -- we find out stuff :)

  • Ok next trip up. I have the firmware flashed, rebooted, loaded and visible in the Bonjour Browser

    However the Apps cannot see it. I have loaded it obviously as its visible in the browser

    The Monomeserial SerialOSC Bridge does see the two monomes but does not connect when I hit the connect button.

    Same for serialosc-test they appear but do not connect

    901 x 822 - 104K
  • did you install the zeroconf externals?

  • Ahh that was the bit I missed out. That did the trick...

    All working fine now, running latest and greatest... well... everything... Back to composing...

    Many thanks for the handholding...

  • should i just keep using monomeserial or serialosc not really a programmer so was wondering if one was better than the other.

  • you may want to wait until serialosc stabilizes

  • i have just flashed my kit, worked after a few hassles due to my lack of experience with this stuff, but now the keypads don't respond at all. tenh wrote that mk-set was obsolete (didn't work here) - so what can i do to get my buttons and leds working?
    I used my original serial number for the flash and it shows up correctly in the serial-osc patcher and connects as well, just unresponsive...

    I redid the whole process making sure i used the right mk.hex file (8x8), the leds flash on connecting to usb but else - nada.

  • you need to flash with m0000000 instead of mk000000 for serialosc.

  • I'm having similar problems to zuchtfisch. I reinstalled Max, Serialosc, latest FTDI and tried to flash m0000000 and other # combos with no button feedback - I had proper response before I tried to flash firmware.

    after adjusting (or not) the makefile, tried to run

    ...only recieved

  • @robotjones:

    apparently you need to flash the serial separately after the flashing the firmware. Brian wrote me the following:
    "you'll need to flash the serial number to m0000000 using ftprog (win) or piraterename (osx)"

    I did it with piraterename and after i did so, the stuff seems to work again without reflashing the firmware...

  • OK,

    I reflashed successfully after unloading FTDI, unloading serialosc, renaming using PirateRename, and then performing mk serialosc flash. AVR dude said "YEHAWWW" and so I reloaded the FTDI & serialosc and when I load monome_test I still dont receive response.
    Running serialosc 0.9, macbookpro 2006

  • I have a macbook with two user accounts. In order for the monome to show up as a bonjour device I have to be logged into the orginal user and the secondary user(mine) at the same time even though they are both administrators. this took me forever to troubleshoot in the first place. Anyone know any work arounds? Preferably, I would like to not have both accounts logged in as this eats up more ram and adds a step.

  • @gusgreen: could you post this question to the serialosc thread? will should know what's up.

    @robotjones: what's your serial number? did you restart? (or run serialosc-load.comand)?

  • @tehn
    I changed my serial number to m0007391 and then to m0000000 but for neither did I get app response, although bonjour browser says its connected to osc.

  • and you have the zeroconf externals installed properly?

  • all four zeroconf .mxo's are in max-external folder
    I am receiving 0 feedback from apps, but proper connection in serialosc.maxpat

    I just reran serialosc to read avrdude's response and even though I change 64mk.hex to mk.hex it says:

    avrdude: AVR device initialized and ready to accept instructions

    Reading | ################################################## | 100% 0.02s

    avrdude: Device signature = 0x1e9505
    avrdude: erasing chip
    avrdude: reading input file "mk.hex"
    avrdude: can't open input file mk.hex: No such file or directory
    avrdude: write to file 'mk.hex' failed

    avrdude: safemode: Fuses OK

    avrdude done. Thank you.

    Derek-Joness-MacBook-Pro-15:~ derekrjones$