serialosc and first time problems

  • Okay I've been at it for about 6 hours with absolutely nothing happening. This shouldn't be that hard. Granted its the first time I've really worked with M4L, Runtime, and a monome but still I can usually google, look up etc.

    I have followed the install instructions on both my imac 10.5.8 and Mbp 10.6.6
    serialosc, bonjour browser/zeroconfig, serial driver. created IAC bus ports 1-5. I'm trying to think what else.. trying opening different monome test patches to check connection. bonjour Browser shows connect when i plug in the monome.

    I've tried to focus on up to date apps that will work like polygome, press cafe.
    preconfigured settings in live preferences. still nothing. Heeelp I'm lost.

    oh and oddly serialosc load command kept saying I haven't got sufficient privileges to open it even though I've changed the settings under info for the primary folder and for the apps itself. Finally just trashed it and tried starting it over but still that was just odd.

    And another thing I'm not clear about is when trying to use polygome for example do I need to put it into another folder or should I just click on any of the patches from the original file. Any help will be appreciated.

  • make sure you keep the polygome file in the original folder. i've made the mistake of moving it to other folders to try and organize, but don't do it. if you want to organize, do it by folders. before trying to get synced with live, download the free max runtime: http://cycling74.com/downloads/ on the right side of the page and see if you can get connected through that.

  • I'll give it a try thanks. I'm having the same problem as this guy
    http://post.monome.org/comments.php?DiscussionID=11266&page=1#Item_0

    I've gone into the terminal and come up with errors such as access denied and lo error can't find port? suggestion 2 copies of serialosc are running uninstalled serial osc reinstalled then I get denied permissions. this is a headache. I'm not sure how much to uninstall to try to correct the problems... I mean should I trash all instances of max runtime etc. with zeroconfig stuff and try to hunt down the FTDI drivers and get those out too.

    when i cut the monome and then replug it, it shows up again as having found a port. bonjour always showed it as connected and it showed up in my system profile.

  • if your device shows up in bonjour, serialosc is working fine and you don't need to mess about with it. running two copies of serialosc will do some very especially weird things.

  • well I uninstalled serialosc, (I'm assuming one uninstall removes all instances) max and bonjour and have started all over again. I think since I'm on EST. I'll leave it alone until mid morning. I'm beat. seriously have been at this for 8 hours now. I'm sure its something I'm doing wrong. Because both systems have failed to have a connection.

    okay wait. Just pulled up polygome and it showed a connection but stated it wasn't connected, hit connect and it did! There are lights....oooh pretty.

    Okay I'll be back at this tomorrow and give a follow up if there are further issues.
    thanks for the help.

    ETA for anyone else who links on this thread in the future. I'm still not sure what I did right.

  • Okay have both computers able to handle the monome as of late this morning. It required uninstalling serialosc and max/runtime and starting all over. Particularly on my imac 10.5.8. I was having odd conflicts with maxruntime trying to open other apps with polygome like berna and my waldorf blofeld editor. I basically uninstalled both.

    The only question I still have is, is it normal for polygome (or any other app for that matter) to ask to be connected to the monome each time it is opened?

  • @ machinea
    i have the same problem here. i uninstall max runtime and serialosc. then install again. but max can't connect with monome. maybe i didn't uninstall max/runtime properly.

    how did you do it ?

    (2011 64, Mbp 10.6.6)

  • Okay what I did was start over uninstalling everything. maybe overkill but still.

    I took out max/runtime. (I'm running m4L not max proper) and I even uninstalled bonjour. I ran a check to make sure that serialosc was uninstalled using the terminal and typing in serialosc which couldn't be found after I did the uninstall.

    I restarted the computer. I installed bonjour and then added max5 and added the zeroconfig .mxo files to apps/max/cycling 74/max-externals, and the FTDIUSB driver. I then installed serialosc and restarted the computer. (then I linked up m4l again with max) I opened up bonjour to see if it was seeing the monome when I attached it. It did but it had been before so..? I opened up ableton and opened up polygome I could see that polygome saw the serial but was still not connected. I clicked the connect button and suddenly I had it.

    eta: I didn't do anything special with uninstalling max.. I just trashed the main folder in apps. I think it had more to do with the order of installation and making sure the zeroconfig files are in the proper place and then installing serialosc and restarting your computer.

  • Thank you. I let you know how it goes for me as soon as i can.

  • i followed step by step your process. i'm still getting at the same point :
    -permission denied
    -lo error, can't find port
    -bonjourbrowser shows connection and port for monome

    Now, if i unplugged monome, unload serialosc, type serialosc in terminal, plugged in monome: terminal shows serialosc connects to the right port. But Max apps don't connect with monome.

    i'm really lost...

  • Okay I'm not well versed at this as a first time user of both monome, apps and m4l. But I can say I was having the same lo error with permissions denied on the serialosc load command (is this what you are referring to as permissions denied? because if it is I can tell you that I tried to change the permissions in get info>unlock several ways and it never worked and this was an issue on my 10.6 not on my 10.5 system)

    I trashed serialosc completely.. redownloaded it and then uninstalled it with the unistall command (it asked for my password to my mac for this process interestingly only on my 10.6 mbp but not on my imac 10.5) and then I went through the process again. I have no idea why I was getting denied permissions on my own setup with this.

    In any case the second part of your post is exactly what I was showing. If I unplugged the monome and replugged it then it would show the serialosc connecting to the right port. Tehn had said that the lo error was probably coming from running more than one instance of serialosc. So I tried to make sure it was really uninstalled. and that is when I ran into the issues with the permission denied junk. so I trashed that entire serialosc folder and downloaded it then and it seemed to work for the uninstall. I restarted the computer and then reinstalled it.

    Just to double check you put the zeroconfig files into the max externals folder correct? (I almost forgot this step the umpteenth time around because I was so frustrated over the serialosc permission issue) and as soon as I did that and got the usbdrivers done.. it was then that when I opened polygome that it allowed me to connect it at the bottom of the app and the grid came online.

  • i'm a beginner too with monome, apps etc. i saw permissions denied within the console report. i also did info>unlock... i put zeroconf.mxo in user/app/max5(not max/runtime folder, right ?)/cycling'74/max-external/
    i didn't trash the serialosc folder. i will.
    i guess i'm going to trash everything and do all the process again, trying to follow your steps. i'll let you know.
    thank you for your answers.

  • yeah I trashed pretty much everything and downloaded it all over again. like I said overkill but there you are.

    so yes there are 4 zeroconfig.mxo's (zeroconf.browser.mxo, zeroconf.mxo
    zeroconf.resolve.mxo, zeroconf.service.mxo) that go into the HD/Apps/Max5/Cycling74/max-externals/

    serialosc was last in the process. I didn't even run any console the last time I went through the process it just connected to polygome when I clicked connect in the apps field. attached is the picture of what I'm talking about and what it should look like. Personally I do better with visuals.

    380 x 213 - 21K
  • YES ! at last, i got the 64 connected to apps.(i made at least one mistake : i didn't put all the .mxo files in the externals folder, just the zeroconf.mxo...).

    you were very helpfull. thank you.

    so far i've tried trails in m4l. (very nice app !). then i opened polygome, connected too (now i need to figure out how to set up IAC busses).

    Now, if i close live, launch max/runtime , open polygome, i can't connect the 64 ! i don't get it.

    again, thank you.

  • I had a feeling that might have been what was messing you up but wasn't sure.

    For IAC busses just go into audio/midi set up in app/utilities.. (I just created a short cut onto the desktop dock. And then go into midi devices and then click on the IAC driver and keep hitting the + button until you get as many devices as you would like. Bar/none had a video up showing how to set up Sevenup Live (with the old monome serial) but it shows how to do this.

    That is odd about it not connecting in just max/runtime. For example polygome should default connect to your AU DLS synth 1.

  • i found the video here :
    http://www.vimeo.com/4438775. it was helpfull. Thank you for pointing.
    everythings are running fine now. i had to put the max runtime app icon into max folder.