Left half of 128 stopped responding [SOLVED]

  • I bought a kit-built 128 at the end of January from one of the other folks on the forum (pics here: http://post.monome.org/comments.php?DiscussionID=10412). It's more or less worked just fine, but last night, just as I finished recording a piece using flin, the left half of my 128 stopped working.

    Specifically, it no longer responds to keypresses. If I activate "test mode" in monomeserial, the LEDs light up correctly. And if I use the mouse to activate LEDs in monome_test.mxb, then the left half buttons light up as they should. When I run "mash", samples loaded in will light up in sequence across both halves. But the left half doesn't respond to any input from fingers; I can't control anything with it.

    The problem persists in OSX and Linux, so I think it's a hardware issue, but I have no electrical equipment so I can't do any detailed diagnosis there. There was no visible spark/short or magic smoke let out between recording sessions. The MacBook was running on battery at the time, so I don't think it was zapped by the mains. One minute the 128 was working; several minutes later it wasn't.

    What I've done so far:

    - Verified that all cables seem to be tightened and in place.
    - Kept it free from dust, moisture, bumps, and scrapes.
    - Replugged all cables, including USB.
    - Restarted monomeserial multiple times.
    - Rebooted the laptops multiple times.
    - Reinstalled the FTDI driver.

    Attached is a pic of the underside, so you can see that it's pretty easy to access the bottoms of the circuitboards.

    * * *

    Edit: the fix, as @elquinto and @tehn suggested, was to run "mk-set" and set the number of grids to "2."

    1000 x 562 - 285K
  • run mk-set as the grids setting may have gotten reset somehow?

  • Thanks, @tehn. @elquinto emailed me with the same suggestion. I downloaded and ran mk-set, setting the device to 2 grids. Dunno how it worked, but this apparently fixed the issue. It lights up and responds to keypresses.