insanity_3 (updated 19/12/2012)

  • tilt what exactly?


    double tap would either interfere with normal sliding or I'd have to introduce a delay to presses to time them.


    midi feedback/light triggering i've figured out and got working.

    toggle option IS made for drones :)

    fixed the finespeed issue, just a message ordering problem. when they weren't working they were actually sliding in the wrong direction..


    should be set for a release shortly. might just add speed/fine speed options for individual faders for people who wanna get right in to there configuring

  • also fixed the min/max fine speed problem

  • individual speed configurations per fader sounds amazing.

    is triple tap possible? ;P

  • maybe just a third press in the column to keep it moving in fine speed will do?

  • something like bends, where a button press turns tilt on one or both axes. I see it would be tricky to display though, given that the rest of the grid is supposedly displaying other faders status and midi notes feedback.

  • @Anangel Argonaut,

    Are you holding your monome and using this app while you envision that?

    It's an odd question, but the ergonomics are important. It seems to me that what you're asking for will take too many fingers away from the buttons, giving the user less power and control.

    I'm not saying it's a bad idea, but you'll need to describe its use a little more thoroughly. That'd make it much easier (possible) to design and program.

    -----

    I personally think your best bet is to just run Tilty Magee alongside your other apps, and maybe map the X and Y enable buttons to a foot pedal somehow...
    http://docs.monome.org/doku.php?id=app:tiltymagee

    That way, it's always available no matter what else you're running. Consistent interface, no extra work for developers.

    If you're not controlling more than two CCs, there's little reason to build tilt into anything else.

  • I can get this to function but there are no lights lighting up. 64faders works no problem with the lights. What am I missing.

  • @jasper-ryder

    the faders and notes are functioning but you are seeing no lights on the monome? are you running the serialosc version, or monomeserial version, or serialosc via monomeserial bridge?

  • @away message

    Correct, the faders are functioning (notes didn't seem to do anything though) but no lights, running the serialosc version on a mac. When I switch to the faders64 serialosc version all lights function normally.

  • interesting.. was pretty sure that was all good

    can anyone else confirm this problem with the serialosc version?

  • works fine here

  • http://docs.monome.org/doku.php?id=app:64insanity

    1.03

    - midi CC button mode
    - on/off messages configurable per slider
    - midi LED input (ableton live etc) selectable per button via 'M' toggle
    - single inc/dec cc messaging on sliders. press and hold 1 button then tap direction with another in same column.
    - fine speed, press third button in column to continue fine speed without holding buttons down
    - speed setting per slider
    - fine speed setting per slider

  • forgot to resave over the ports when testing the saving in the monomeserial version...

    change them to in 8000 out 8080 then save over the faderconfig file if you need too.

  • Great patch Sean!

    is pattern recording a possibility? A la raptor?

  • recorders?, hmmmmm....

    would mean another row option, perhaps shared between pages?, 7 recorders at most, would mean adding some midi sync perhaps? or unsynced? or perhaps unsynced but synced to each other? would probably add more to the loading time... and i'm notorious for long loading times... notorious...*strokes beard*

  • wow!!! this is beautiful! no more apc40! thank you! can you tell i'm excited?!

  • yeah. cool with the update =)
    i have some problems with the lights.
    when i make a preset the contains buttons. when i close the app and reopens and reload the preset, the lighting doesn't work.i have to choose fader and then back to buttons for it to work. also midiled is not working for me.
    also i tried to map buttons in live and i can not map more than one thing at a time. i have to go in and out of midi learn mode for it to work.

    last. when i mapped a button to trigger a clip it triggered both on the on message and the off message :P i should check out cc buttons for this but notes are usually no problem. and it wasn't in the old version. just didn't get the lights.

  • btw i used the old version on a gig yesterday. great stuff indeed =)

  • make sure you're not opening any of the previous 64insanity saved files. i did that and things were messed up. i recreated the files with the new version and everything was fine.

    do you have live's midi remote output set to on? if so, make sure only the "m" is checked on the buttons page within 64insanity.

  • aha that must be the reason. will test with new file.

  • yeah new features means new numbers in lines in the save file and taking some of the old ones out so yeah, old configs mess up the new one. sorry

    will try avoid this in future updates..

  • with regards to ableton i've notice some things you map to respond to on/off messages and some things to just on messages. some will then require tog mode on and some will require tog mode off.

  • Rad, the new version is working just fine on first light test. Don't now what the deal with 101 is.

  • love it!

    i understand that it is not necessary, considering the fine control you have implemented with only 64 buttons (big props!), but would you have any interest making a 256 version of this identical app (if for nothing else, to be bigger and scarier looking)?

  • i am making a new preset from scratch now. will report back. one thing that is definitly not working is decreasing fine speen. only works up.

    edit: it does work. but not from the top buttons. so you can't go 127-0

  • allright final conclusion:
    everything works prefectly now. BUT it doesnt work if i call the file faderconfig and let it autoload. then i have to reload the preset to make it work.


    i spoke to soon:
    it seems that if i have a fader on page 1, map that to something in live, map a fader on the same row in page 6 to another thing. then i tak fader on page 1 to the top, fader on page 6 to the top, fader 6 to the bottom, switch back to page 1, then some of the lights is gone on the fader on page 1... not all. just some in the middle..

  • i've experienced a similar problem with slide times under 100ms, not sure why but the sliders get fragmented also. could be a limitation of the process i'm using (line object maybe) will look into it though

    this could also be down to the fact that faders in live, when moved by a remote device only output values of midi to remote devices once they have reached their final destination and not the incremental values inbetween.. this i find kinda annoying.

    think i just got a mad idea of how to make the faders better, hope i remember it in the morning

  • yes i have had this problem too. so i use 150ms, but strange that one fader affects another i think..

  • the faders aren't using the same cc are they?

    re "think i just got a mad idea of how to make the faders better, hope i remember it in the morning" i was drunk, it was a stupid idea.

    will have a look at this problem in the next day or so. I write a lot of my patches at work using an emulator patch for testing. some thing particularly with led data go through unnoticed.

  • update!

    http://docs.monome.org/doku.php?id=app:64insanity

  • now everything is working for me. i used the patch yesterday at a bandrehearsal. worked great! thank's so much.

    the only bug left(wich i don't care about) is if you move a fader pretty quickly with your muse your fader get's fragmented. but that doesn't bother me. who wants to use the mouse when you can use the monome?


    thank's for a great patch!

  • always some last bit testing shows some more hehe.

    i don't get any feedback when mapping stuff to the arm track.
    i get from everything else. like mute/unmute, effect on/off, clips, but not from the arm. this works on my launchpad and my faderfox. not the biggest deal but maybe there is a way to fix it =)

    also maybe there should be a clear button? cos sometimes when i change liveset and forget to turn off a toggle f.ex. the led gets stuck on. i am still on monomeserial so i just use the clear button there, but for people with serial osc ?

  • yeah a clear button probably not a silly idea.


    ableton record arm buttons don't output midi. which is stupid and probably cos they want you to use their hardware.. lame.

    just use a cc toggle button with M toggled off, set off to 127 (cos thats the only message it responds to) also and assume it's displaying the right led data or check your screen.


    why would they make something that half of the buttons respond to on/off messages and half of them don't and some stuff sends midi data and some stuff doesn't?

    maybe write them a letter about it. use the words "unfinished" and "overpriced" a lot. lol

  • my rants about ableton probably need a new thread, or forum.....

  • Hey guys, novice question here.

    If I click on the Midi light box in 64insanity should that then light a button if I have it mapped to a function in ableton? The normal presses and toggle presses are lighting fine. I'm assuming if I have the Midi light function set up properly it would light on/off with the ableton function being triggered on/off, or am I mistaken?

  • yep you need to have ableton sending midi out.

    in live midi setup choose a midi output channel (IAC for mac, midiyoke for win - you may have to set these up) and enable 'remote'

    then select that channel and the 'midi led input' channel in 64insanity..

  • @stevieraysean
    Thanks! I have Insanity working great and I must say kudos to you man. Such a great practical app!

  • very useful app.

    how about a countdown option in button mode i.e. if your using a button to toggle a record function then have the option of timing the midi toggle from the button press - so you could set a wait period of 4 seconds and a flash period of a second then when you press the button the led flashes three times (every second) after the fourth second the led stays on and the midi note or cc is toggled on. sorry if this has already been suggested.

    this would make recording guitar easy with an app like mash or mlrv - gives you time to get your hand back to the guitar. i know the mash and mlrv pre-roll options are supposed to allow this but i've never had much luck with these so i have a little java app that allows me to do what i'm suggesting for 64insanity...

  • just got around to playing with this as i've been using 64 faders. i have to say this really improves my set in terms of expressive capacity. the amount of granular control is fantastic without sacrificing large sweeps. more expressive control than knobs i might say. hooray for buttons and flexibility!

    will certainly be sending a donation your way.

  • @knecht will ponder on it a while. I've pretty much squeezed every pixel outa the current GUI so any more additions will have to wait till i'm ready to redesign the whole thing.. maybe when i get round to making it bigger-monome compatible which i intend to do. probably after i've updated mash

    @watson thanks man :)

    still surprised i got all the different movements working harmoniously. slide, fine-speed and single increments. maybe i should make an external of the slider object so others can dump it in patches if they wanna.

  • greeat work i am a big fan of 64faders

    perhaps if you changed two or more columns to an alternate fader mode you could have the type of faders that are in dj64 so as to get more resolution if need be. does that make sense?

    by all means i would love to see what you would be updating with mash these are my two main performance tools lately

    thank you

  • having an issue with some faders sticking and wont move. once i was able to unlock it by moving the fader in ableton but sometimes this does not work. i even unplugged and replugged. help?

    ive got a gig on friday and really want to use this!

  • it it using single press, fine moving (two button) or the three button (fine cont) movements?

    it's probably the press counter thing not resetting properly, that'd do it. think i might have an easy fix for it...

  • also what speeds you using?

  • Im using both single and two... not sure which one made it lock....

    speed: 500 fine: 100

    thx!

  • is it when you hold 2 buttons then change the page before releasing? that seems to do it for me...

  • that is certainly possible. i'll test it out this eve...

  • fixed that. 1.033 on the wiki

  • thanks! i'll put it through my fingers tonight.