electric dharma wheels

  • FM instrument for the arc

    download here

  • wish I had an arc.... Great video by the way!... Many positive comments from people I've shared it with. Keep up the good work!

  • Holy damn, thank you for sharing this stretta. I downloaded holocene and have watched it an obscene number of times. Truly my favorite video of yours.

  • OMG I love this app. It's just grooving at the moment and I don't want to touch it.

  • respect!

  • @tehn
    Ha took the words out of my mouth.

    First 5 min with this app on iPhone video.


  • can't get any sound from the fm synth engine. if i send the midi out to a vsti in a host, it works great. yet no sound from the application itself.

    i've checked out other similar apps in max runtime (like straw) and they all made sound. don't know what's wrong here.

  • plus1, same problem like aryschien, maybe its to do with a possible implementation of rewire and therefore no audiostream, because the app is waiting for a masterhost? havent tried it yet.....great app notheless thnx again

  • did you check your dsp options?

  • @tehn - i couldn't find the dsp setting window of the edw, but i did launched mlrv or 64fingers and checked the dsp setting there. everything was good; mlrv and 64fingers both made sound except edw.

  • There is a speaker icon in edw.
    Is it on?
    Do the LEDs on the wheels spin when you turn them?

  • @stretta - yes. if the speaker icon is not on, there is simply no movement from the LEDs. when on, it spins quite well, and i could see movement of volume on all 4 parts in the application UI.

  • If the LEDs are not moving, the DSP isn't on.

  • @crazeebo - seems we two got the same problems. here's the info of my setup:

    macbook 13" 2008
    osx 10.6.6
    max runtime 5.1.8
    2011 monome 128
    serialosc 1.0b

  • Have you tried selecting a preset?

  • yes i have selected every preset, and it was all the same: ok when triggering vsti within a host; no sound when using internal fm synth engine (with the midi out toggled of; blank square).

  • Can you send a screenshot of your DSP status window?

  • i couldn't find the dsp setting window from the edw, so i launched 64fingers, opened the dsp setting window and then closed 64fingers. here is the screenshot.

    267 x 406 - 105K
  • if you're using the runtime, use this to access the DSP status window

  • OK, try this.

    Set I/O vector size to 512
    Set signal vector size to 64
    disable in Audio interrupt

  • orange! http://farm5.static.flickr.com/4104/5605621187_399ed287ec_z.jpg

    this app is amazing. thanks so much stretta. hope you others get the audio working...

  • i tried 512/64 and some other combination, but nothing worked. (the audio interrupt had been turned on and off too.)

  • if it's worth anything to you, i'm using the built in soundcard on my work laptop with i/o vector size at 128, signal vector at 2, and a sampling rate of 44.1k.

  • @oootini - tried that too. no luck. but thanks. ^^

  • @aryschien: exact same setup except a 2011 64monome and osx 10.6.7

    arent you also in the 15 that need a reflash? maybe something to do with this?

    i will try it with my rewire setup next week, i cant seem to make it work either with my built in audio

  • @crazeebo - yeah i'm one of the BOF15. but i'm not sure it'd be the problem, since stretta had been working perfectly with the "genesis arc". XD

  • flash is not the problem, in fact it's not a monome problem. there's a maxmsp audio setup problem, or an issue with the patch. i'm still trying to figure out what might be a discrepancy one different systems. any errors in the max window?

  • i didn't see any error message or anything strange around the max window.

    since both applications' volume indicators (lpr: the bottom leds / edw: the long boxes on the left) showed activities during playback, it seems that the playback port (or how it should be called correctly) did not link to the system's audio output?

    or will there be any difference between the full max msp and the max runtime?

  • This is amazing...will it work with non-arc OSC sources (I'm thinking touchOSC, duh...) to control parameters?

    As usual....AMAZING work!!

  • @stretta

    still no sound from edw, but maybe you can fix it with the same method as you fixed the lpr?

    again, thanks for the amazing device and applications. they make my life better. thanks.

  • cool app name =)

  • really really like this app. such an expressive sequencer.

    i'm going to hack in a midi out for each bank and a switch to change between fm synth and midi out. i'll post it up when i get a chance.

  • Yes! ...would super love a midi version of this app!!!

  • plugged in my arc for the first time last mnight and this was one of the first apps i tried. like aryschien i can only trigger sounds in vst instruments in my daw via midi output. the inbuilt fm synth is not audible. will try your dsp add-on for max runtime users (which is what i am) this evening. i presume thet the fm synth engine is the same as the one from straw? if so this is puzzling because straw works perfectly. can you add a dac button to edw? haven't exactly worked out how the app works as yet. at the moment its magic. could you post a brief explanation of how to control it and what info the leds are reflecting? it's a great app though, even with an arc2. i aimagine it would be interesting to control mlrv with this. map midi notes to the sample playback buttons and then trigger the playback using edw - will give this a try this evening.

    [EDIT] I'm on Windows XP SP3, bang up to date on all the add-ons required to run serialosc: bonjour, zerconf externals, etc...

  • here's a tini tiny edit of EDW. you can mute the individual banks and route the notes to an individual midi output.

    i'm in work so i haven't tested it with the arc, but it should be ok.

    it's got me thinking about a midi sequencer that uses the arc to control note velocity dynamically...

    edit: file removed.

  • hmm. does anyone else notice a bug on the original 0.41 version where the midi input is switched to a encoder bank when you select the enable the midi output? happens about 1 in 3 times...

    start and stop the dac a few times and select and deselect the midi out, do you notice the midi input jumping to enc0 clockwise or similiar?

  • i think the coll recmap in the midi input section should use the second outlet, not the first?

  • argh. that edit is useless, i'll need to add some note duration controls...

  • tried the dsp status access patch - still no sound from the fm synthesis engine unfortunately - works great with other instruments though...

  • @knecht
    try the version 0.42 I just uploaded

  • @stretta

    0.42 works! ^^

    i haven't got the arc2 next to me, but i just launched edw0.42, enabled the dsp and then i heard sounds.


  • i'm excited - will try tonight & report back

  • works fine here as well, thnx

    and on constant play, cant get my hands off it

  • Hey stretta... small problem I was having with .41 have not yet tried to reproduce it with .42

    If you have the wheels all moving super duper fast I am getting lagging response time from other serial devices... for example when I try to move the mouse it is fairly haphazard.

    I have seen this happen before when working with the arduino, it is a result of having too much information being sent to the serial bus at once... which makes sense with all the light updates that are being done.

    Just thought I'd give you a heads up

  • @thealphanerd

    I don't think it would be difficult to provide some control over the refresh rate at the expense of fluidity.

  • all working beautifully now - thanks stretta - being able to control the fm synthesis engine from the arc is awsome...very responsive :)

  • boy i love this app. i'm not even going to try to change it. it's perfect.


  • thank you for posting this stretta -- i got my arc2 last night and edw is the first thing i used it with... i can't leave it alone. :)

  • here's a quick edit of v0.42 i made that should allow use of an arc 2 as an arc 4.
    instructions are in the zip, you'll need the original edw 0.42 folder.
    hope this is ok and it works for people, if not shout and i'll take it down.

    @stretta thank you for creating and sharing

  • @stretta
    thank you for building and sharing this app. i enjoyed a lot playing with it.

    thank you for arc. such a beautifull instrument !)

    about presets : i switch between them with the mouse (is it possible via midi ? would it be possible in a future version via monome ?), but the state of the encoders are not refreshed : let's say that preset 1, mod offset is 1; preset 2, mod offset is 5; if i go from preset 1 to preset 2, i hear sound's changes. now if i play with mod offset, i should play from 5, but it jumps to 1 (and the sound make a step as well). is it by design ? is there an issue with my set up ? (i'm running edw0.42 and the edit by 2D10. same issue on both).

    thank you for this edit ! works fine. very usefull.

    as far as i've been playing with your edit, i found : when i'm in b is group/enc is sound : i've got led feedback from enc 3 (and responsive to my move) but no changes are heard, or seen on the UI. is it possible to link this encoder to env time/mod amount ?

    thank you for your help on these

    mbp 10.6.7, max rt 5.1.8, m64, a2

  • @beo
    hello. although you cant see the value on screen enc 3 is already linked up to a tremolo rate mod value.
    as far as i understand it at the moment the tremolo rate requires either of the other mod amounts (fm or envelope) to be set above zero to be of any effect.

    could you try/have you tried muting all but one of the pools of notes and adjusting enc 3 in very small twists (a few degrees at a time) both clockwise and anti-clockwise after setting the mod amounts?

    I tried this on the first preset and you should hear a difference after a minimal amount of tweaking.