I (WAS) so lost - Thanks to everyone who helped!

  • Just got my 2011 128 in.

    I have gone through about 4 or 5 different installs but can't get the monome or anything I am trying to control to work. Serialosc , is it there or not... would be nice to know it is running and working somehow.
    I can't get the monomeserial patch to run with OSC in Max5, it only shows up "working" in Max Runtime (Any ideas as to why?).

    If I try and uninstall SerialOSC with the script and use monomeserial it cant find the monome.

    There has to be a better well detailed written way of getting up and running. I have gone through the forums for hours now and am getting frustrated.

    Any insight would help, I want to use the monome exclusively in Ableton.

    So far, my first expierence is not a positive one and i don't expect it to just "work" but this is getting ridiculous. Thank God I am not trying to make music right now.... or wait, I am.

    Please help so I don't fully hate life.

  • Ahh. Msleading filenames did you in.

    The "monomeserial" patch in Max5 is not monomeserial. It's a bridge to let you use monomeserial-based apps in serialOSC. I believe it's been renamed to "monomepseudorial" to avoid confusion, but of course there are still copies floating around under the other filename.

    So, I know you won't appreciate the irony, but based on your description of this patch's behavior, it sounds a lot like serialOSC was working fine on your system before you uninstalled it. We just need to get you up to speed on what that means and how to use it.



    monomeserial itself, the real one, can be found here:
    http://docs.monome.org/doku.php?id=app:monomeserial

    That is just a temporary stop-gap, though. Sooner or later, you're going to need to transition into serialOSC.



    The good news is that SoundCyst led a pretty solid "this is what you need to know to get started" session at GridFest that should help. We even have video of it. Yay!

    But having now gotten your hopes up, the bad news is that this video's been processing on my computer for two days solid and isn't done yet. It seems to be progressing 1% every hour, so that's useless for... about a week. But I swear it's going online eventually.


    Ignoring that, why not jump into theLive Chat by clicking the "live chat" link in the left-hand column, and see if anyone's able to walk you through a few tests to make sure everything's up and running?

    Again, I think it was working before. You just need to get back to that place, and then figure out what to do next. Which sounds duanting, sure, but it should go much smoother not that this much is established.

  • (if I remember correctly) 2011 will only work with serialosc, won't work with monomserial, so step one is reinstall that.

    After you've gone thru the install steps post back and we'll try and get you up and running.

  • Are you following...

    http://docs.monome.org/doku.php?id=app:serialosc ?

    You on osx or windows?

  • He's making headway in the live chat. There's just a world of deprecated knowledge that still matters, and it's tough to sift through all that if you don't know what you're looking for.

  • Huge thanks to everyone who helped get me up and running.. It's actually easier than expected...

    GreaterThanZero - a huge thanks to you... I requested to join the FaceBook too.. Cheers for all of your help bro, I am already making music, and fast!!!!

  • Saw you working through some issues as I was lurking chat. Glad you got things squared away. Keep digging in!

  • Now if you could just document your journey in detail on the wiki that would be awesome.

    ;-)

    Glad you got it all working.

  • @JP The might be difficult because I am not 100% sure how it all got sorted out.

    I think I have an idea but I wouldn't want to give anyone the wrong information of what to watch out for. Best advice with new users is talk to people in to forum before you go screwing around messing things up before getting started.

    Everyone on here is more helpful than anyone would ever imagine. Took just one question with a quick response for me to figure it out. Thanks again everyone, I have been going IN!

    Now I am on a quest to figure out how to run MLR or MLRV with my monome and Lemur to control faders, sends, program changes etc... basically everything that isnt "musical".

    Any ideas?

    Ant