64fingers Serialosc Update

  • Thanks to 2D10 down there VV I solved the problem of the row 2-8 leds not lighting.

    Wiki will be updated to match shortly.

    So for now, here ya go:


    P.S. Dovemouse feel free to change the layout, I kinda put the serialosc bpatcher the only place it made sense.

  • Hey MCDELTAT,

    in slot.maxpat change -

    prepend /64/grid/led/set

    to

    prepend /64/grid/led/set #1 #2

    should work fine after that.

  • @2D10
    Thanks for that, works perfectly now. I knew that someone would figure it out faster than me just guessing.

    Can you explain the difference between $1 and #1 that made the difference? I can't seem to find it on the c74 forums or in the reference material.

    Note: Working version posted above, and will be placed in the wiki shortly.

  • also keen to know, i wondered about that convention myself ;]

  • sorry guys, wish i could help but i don't fully understand the use of # either.

    to fix the patch i worked out where the error was and what parts of the message were missing, then took a look at the old patch and made the missing changes in the update.

    soundcyst mentions a bit about using # in the following post but after trying to put it to use i still cant fully wrap my head around it.
    http://post.monome.org/comments.php?DiscussionID=3135

  • baaaaaasically....

    $1 is replaced by the first argument that is passed into that object. $2, the second etc. like so:

    ----------begin_max5_patcher----------
    345.3ocwTFsaCBBEF9Z7ofP1kcMhRUytaOGKMKT8rVVTvHXR2Z569DTSaWRa
    Xqo5MP3bNd9+8iS3P.hrQsGzD7K32vHzg.DxExF.MbFQp36yK4ZWYjJPq4aA
    xh9benjFs3avliFsLbHbcCnAogaDJ46MPtoWBZHsqjtMlcKbXAud3qjsUBYI
    XbJEclBRdkSAxqMBdI4T4pVyX8zQo4l7cB41qJ6JmtzryDVT35tZymOmN189
    Va9pF5aBgfWaybLHvtr3+wKCr2YJhFL3mhtKLllLGTrWUV7sfX1iEhWgVOpe
    73LumdRlxoG5rxCelCXSDNX3Tb7rRi9wh3zaQiHOog6aIkB4ueY1otM9kHRq
    ZaxGa0fP3SNn.zFgz8FxY0jcQM6DEEfK8HtpDE0JgzLXAV5xUc24T6JkFNd3
    J2h9ZzLOLZ5eyn2oiXd3njI0Q9bYxtCG0c3XvOf9DTMa
    -----------end_max5_patcher-----------



    #1 on the other hand only works within abstractions and bpatchers.
    for an abstraction it will take the first argument (after the abstraction name).
    ie [myabstraction 5 4 1] #1 will be 5, #2 is 4 etc.

    in bptachers the arguments are set in the inspector window but work in the same way.

    hope that helps :)

    in the case of 64fingers each instance of slot.maxpat (all the bpatchers) have the arguments as the coordinates of that slot. so #1 and #2 are the x and y of the button you want to light up.

    thanks for the port by the way mcdeltat!

  • @maersk
    That was a great explanation thanks for that. It'll probably help me out in the future if I do say so myself.

    Actually, now that I think about it, I might go back and look at an old piece I wrote when I was just learning Max, I think it might improve the efficiency drastically.

    And as for the port, welcome. I use it pretty often myself so I just went for it.

  • @maersk
    thanks as well for the explanation, should prove useful for future patching.

    does anyone think this explanation is worth replicating or linking in and another post for future searches?

  • I have nothing muted. unresponsive to the buttons. anything in the settings is not correct?

  • hey everyone,

    ive posted this in the 64fingers app page a few times, so i thought id move here.

    i cant get my samples to play and i think im setting it up right..?

    64fingers is running,
    64 prefix set,
    DAC is on,
    opensound control selected,
    .wav samples loaded,
    ...and the top right button is blinking

    ..yet when the corresponding buttons are pressed (or held) the sample is not playing at all

    whats going on??