Windows 7 Problems Setting up 128

  • Downloaded/Installed:
    Max 5.1 (purchased)
    Monomeserial
    serialosc
    Ableton 8.2.2 (purchased, although I'm not runnign for inital setup)
    Monome Base (monome_test)
    FTDI Driver (although windows auto configured my driver installation, still I've tried uninstalling and manual installing the drivers)

    Operating System: Windows 7 Professional

    Monome: 128 from spring of 2010

    Ok, this is really frustrating. I'm wondering if there is a problem with my monome. I had this same monome setup on another computer about a year back, running simple stuff like sevenuplive. But when trying to get it setup for apps like parc the monome stopped working. Frustrated at not being able to fix the problem I kind of just abandoned my monome.

    Recently I got a new laptop, so today I pulled out Ableton and my monome and began to set everything up again. After following all the directions on the 'Setup Page' I cannot get my monome to work (even for Monome Base).

    The monome lights up when I plug it in, windows downloaded my driver, I've tried running monome_test with monomeserial running and/or serialosc, but nothing works. For all of the scenarios just mentioned, under serialosc and monome_test there is nothing in the box with arrows next to "connect" which also reads "not connected" next to it.

    Of course choosing "press" or "toggle" and mashing buttons yields no results with monome_test.

    I've tried multiple wires, windows recognizes my monome, but i can't get it to work.

    Please help.

  • max zeroconf externals are missing is my guess (at least for serialosc).

    i never had any luck with getting monomeserial exe to work with windows 7.

  • Thanks, do you have any idea how I find those and install?

  • https://github.com/cassiel/zeroconf/tree/master/dist/win32

    Stuff in the zip files goes into the max-externals folder under the max directory in either c:\program files or c:\program files (x86) if you're running 64 bit.

    You'll also have to install bonjour for windows if you haven't done that yet.

  • Thanks for the quick response.

    I'm sorry, do I move everything to max-externals or do I just take the three zeroconf files in the zeroconf_20110226_win32 folder?

    I already have bonjour downloaded.

  • Tried both ways and still nothing is happening.

  • are you running monomeserial and serialosc at the same time?

    did you try it with monomeserial.maxpat from http://docs.monome.org/lib/exe/fetch.php?media=app:max5-serialosc-osx-examples.zip instead of the monomeserial exe?

    I noticed too you said Max 5.1? I am assuming you meant 5.1.8 but just checking.

  • Yes, Max 5.1.8

    And yes I've tried using monomeserial (serialosc bridge), monome_test, serialosc (presentation), and monomeserial.exe - for the max based programs, there is no device in the drop down menu to select and connect to.

    Monomeserial.exe does recognize my monome, but that is all.

  • Tried another USB port and now it is showing up. I'll run Monome_test and see if it works.

  • OK, so my monome now shows up on the drop down menus, but I cannot connect to it in any of the max apps.

  • if you stop the serialosc service, make sure you're not running monomeserial and then open a command prompt and run

    > netstat -an

    do you see anything running on ports 8000 or 8080?

  • 99% sure it's your firewall.

    Open up yur firewall settings, make sure serialosc/max is not blocked.

    Disconnect your internet, then make sure serialosc in running and monomeserial is not. Open a Max app and it should now connect thru serialosc.