Saving in MLRV 2.2

  • Every time I download and install the latest version Max Runtime I'm exited by the prospect of it resolving my saving issues in MLRV2. Still not there though. I use MLRV2 with a Korg Nanokontrol and every time I load the patch I spend some time mapping every control on the Korg to a MLRV2 parameter, then changing the parameter values so that I can shift samples within octaves. I also map a few buttons on the monome (GS64) to give me momentary mutes for glitchy type stuff. After all this is done I feel like i have the best setup for doing what I do, it really is great, with live recording into the sample section it feels like using my EHX 2880 but with much more freedom. But..... Every time I have to quit Max, or when it occasionally crashes, I lose all this good stuff. I've tried saving in .json and .xml formats and have even tried using a variety of names (with numbers, no numbers, with spaces, no spaces). When I go 'open' my files come up, but upon clicking nothing changes, no mappings. I'm using MLRV 2.2, OSX Leopard 10.5.8, Max Runtime 5.1.9.
    I would be very grateful for some suggestions for a resolution. With my mappings intact I'd be able to use MLRV2 even more. Thanks.

  • I always think there's something a little sad about a BUMP

  • There are still issues with presets that the guys are working through with mapping presets. Check the bug tracker. http://code.google.com/p/mlrv/issues/

    Keep an eye out for 2.3 release for a fix or become a supporter and get email updates.

  • Ok, good to know its not just my system and that they know about it. I'll keep and eye out for 2.3. Those guys really are doing amazing things. Changed the way I work. My favorite patch.

  • Hey there HN. I was having the same issue as you on 10.5.8 as well. I found that if i load the session twice that it will recall the mappings. It still wont recall the setlist, but at least I've gotten it to recall mah'mappings. So basically click "load" and load your .json file, then once its loaded click "load" again and load the same session again. Hope this helps!

  • @Vfierro

    Thanks for the tip it worked for me as well !

  • Thanks Vfierro, I'll have to try that when i unpack my nanoKontrol. After saving my pennies for the past few months I've finally managed to get hold of an MPD32. Bizarrely, when I yet again remapped everything, this time on the MPD32 rather than the NanoKontrol, it saved and re-opened almost perfectly. I've no idea why this should be the case, considering the mappings appear to be simple cc messages, so I thought it shouldn't matter where they are coming from in terms of saving/ recalling. Oh well, thought i'd post this as it may help with diagnosis. Cheers. HN