ftdi/serialosc problem - won´t run (SOLVED)

  • hello folks.

    seems like ftdi driver and/or serialosc won´t run on my new macbook pro i5.
    i´m pretty sure i´m doing the same stuff i´ve done on my PowerMac G5 on which everything works fine. so this is what i´m doing.


    1. installed ftdi vcp driver 2.2.16. from here
    http://www.ftdichip.com/Drivers/VCP.htm

    2. installed serialosc

    3. restarted my mbp

    4. insralled max runtime and put the zeroconf. files in max-externals...

    i really like tehn´s setup guide.

    http://docs.monome.org/doku.php?id=setup:mac

    now. serialosc is not appearing in the terminal. stopped and started serialosc with the script command "start" and "stop". nothing. uninstalled and reinstalled ftdi driver. so i did with serialosc. nothing.

    plug in my old walnut 128 and started monomeserial. everything works fine here..

    serialosc or ftdi driver won´t run...

    i even reinstalled mac osx just to be sure. and re did all the procedure. nothing.

    bonjour browser runs but no devices appears in the browser..


    mbp 13" dual core i5 256 ssd hd, mac osx 10.6.8, serialosc, ftdi vcp 2.2.16, new edition walnut 256, old walnut 128


    spent the whole day on this. tried any re.tried over and over but without success. don´t know what else to try.

    any help highly appreciated!

  • @RajaResAlien

    actually your are quiet a bit of help. true. Monomeserial is running, means FTDI Driver is running correctly.i haven´t thought about that. So this means, that i´m actually not able to install serialosc. at least it won´t appear in the terminal. and thanks for the reminder. monomeserial is not running. hold on.. bonjour browser is running... it shows me different conections i have in the moment... i´m just connected to my mac G5 via ethernet server in order to transer all my files. for instance this is one of the connection showing in bonjour journal....

    i´m not to sure if it would run without serialosc running in the backround?!?!!?

    but yeah, i think that´s exactly what i need. a reminder on a little particular thing that i forgot....

    the only thing that comes in mind is that i´m working with a SSD HD and not an spinning HD!?!?!? could this cause the problem?

    any other monomista out there using a SSD GD?

    thanks dude. appreciate your help.

  • I doubt the SSD is causing any problems. From lurking I've noticed a few threads where mac users experiencing such problems are advised to create a new account for testing/debugging:

    http://post.monome.org/comments.php?DiscussionID=12411

  • Hi, monoaural. I just experienced a very similar situation with my new Macbook Pro i7.

    If I may recommend....

    Try making a new user account and running through the whole process again. FTDI & Serialosc. I found the new user ran serialosc perfectly. After some digging in terminal, i was able to locate a permission problem in my /bin/ folder which serialosc tries to install. When i get more time today i'm going to try to post up the fix incase anyone else needs it. But let me know if it helps, If so its just a quick chmod permission fix in terminal and you'll be up and running.

    Goodluck!

  • I'd be interested in seeing the fix. After trying to install serialosc on my main account my monome stopped working completely, even after a return to monomeserial.

    I set up a test account and monomeserial worked fine. Haven't had the guts to try serialosc again though...

    Actually I'm growing somewhat fond of having an account strictly dedicated to monome use; It makes organization/navigation quite a bit easier.

  • I had a similar problem a while back trying to install on someone else's brand new macbook. It was a permissions issues with the /usr/local/bin folder...

    http://post.monome.org/comments.php?DiscussionID=7891&page=6

    On a computer that you've had for a bit, that folder would have already been created by another installer. But since this is a new computer and the monome installer does everything as root, the folder isn't created properly.

    Just need to do a 'sudo chmod 755 /usr/local/bin' as discussed in the link.

  • W O W.

    love you all guys.

    @Ambassador Hobbes.
    YEP. this did work. just did a 'sudo chmod 755 /usr/local/bin' and everything works like a charm. beer for you if you happen to be in berlin.

    @syscrusher
    i would say. this is the fix.

    @ant.eater
    hi ant.eater. yeah. it did help. 'sudo chmod 755 /usr/local/bin' did wonder.
    everything seems to work fine now. just had a nice _mash session ;-)

    @marto
    thanks for your help. yeah. read about creating a new account is a good way for testing/debugging. always good to know....


    MAY THE FORCE BE WITH YOU.

  • Great! I'll give it a go. Thanks!