Java AWT-AppKit crashes ... molar, pages or Mu ?

  • Hello all .. and happy holidays :)

    i'm having a hard time with my setup at the moment while preparing for my new show, basically at some point Ableton Live will crash on me and from that point on i can't even open the file anymore, it will crash Live straight after loading. The only solution (which took me days to figure out) is to trash Live's prefs, rename the Max 5 folder (i'm on Mac so it's in the Applications folder) and then Live will load my set with everything Max 4 Live disabled. Sometimes my set will load and be stable for days, but when it does crash on me then i'm completely stuck and my only option is to rename the MAX folder, then chuck away all my plugins and start loading everything in, reconfigure my Live prefs, etc, which takes a lot of time ... so if this happens during the performance i'm super fucked.

    Ableton support couldn't really pin down the problem but they are positive that Java AWT-AppKit is crashing on me ... the only thing is, i don't quite know where this thing is coming from.

    I have three suspects: Molar, the Mu (a M4L patch used to control Live with the Lemur) and although it isn't a M4L patch maybe Pages since it's a Java app.

    Ableton suggested i'd upgrade all my plugins to the latest versions, but in case of Molar and the Mu that's not possible since they are both discontinued and won't be updated anymore. Ableton provided me with a link to a discussion which apparently discusses a similar issue, but i can't make much sense of it: http://www.cycling74.com/forums/topic.php?id=25897

    I'm starting to have nightmares seeing myself on stage for 15 minutes without sound trying to get my Live set back up and running .. not a pleasant thought ...

    so maybe someone here is more clued up about these things (i'm really a Max noob) and has a guess where this is most likely to come from and maybe even some advice on how to avoid these crashes. I can't really live without any of these three plugs/apps but at this point i have to reconsider if i cannot stabilize this thing, it's totally weird, i can work a whole day without problems, save and shutdown normally at the end of the day, and the next morning the Liveset won't start anymore ... it's driving me insane

    thx for any help with this

    PS: Macbook Pro i7 from 2010 with OSX 10.6.8, Live 8.2.7, OS and all plugins up to date

  • Sorry to hear that!
    Not sure if I can help you. It reminds me of a similar problem I had though.

    I worked on Ableton projects (8.2.6) and also couldnĀ“t open them later on anymore. Took me days to find out what caused the problem.
    I am using pages / molar / all the time > osx 10.5.8 > latest pages

    I found out that disabling the control surface in Ableton preferences in an empty project for my MT Player (for my Nanocontrol) first, before opening the actual project solved the problem. I just enabled MT Player as a control surface then again in the wanted project.
    To my surprise Ableton 8.2.7 fixed this though.

    Maybe phortran can help you through his smart traces and check if pages is the isssue. As long as I know his last Live OSC version is still for 8.2.1. So this might narrow down the problem.

    I remember phortran saying the following:

    "i also wanted to add that i saw a few crashes from people that seemed to me to be due to 2 things:

    1) java 6 is now required instead of 5, and you may need to go to your java preferences and put 6 on top. i've seen a couple of these lately.

    2) libmmj in some instances, i'm not sure exactly what, will cause pages to crash. i think when you have a mismatched libmmj / java version. if you're having trouble try removing these files from /Library/Java/Extensions. "


    I doubt Molar is an issue, but I am on 5.8.
    Maybe Mu, this is still a really old version, right?

    Sorry, maybe not the expected help. :/

    GOOD LUCK & HAPPY HOLIDAYS!!!

  • Well if it's really Java that's the issue then Molar can be excluded.

    Look in /Applications/Max5/Cycling\ \'74/java/max.java.config.txt

    This file will either point to Java jar files that should be loaded OR, the jars will be placed in

    Look in /Applications/Max5/Cycling\ \'74/java/lib folder

    These are the default MAX jar files that should be there already.

    jitter.jar
    jode-1.1.2-pre-embedded.jar
    max.jar

    Are there others in there? Might try removing them.

    If you take out max.jar then the entire Java subsystem will not be able to run. Not what you would normally do but it would help reduce the problem and find out if it really is a Java app.

  • hey discopimp, i'm pretty darn sure that it isn't pages just because pages and the aspects of ableton that use java (i'm guessing it's m4l specifically) aren't going to use the same jvm or overwrite each others files / configuration / etc. they should be as separate as any other applications even though they both happen to use java.

    i would look towards m4l stuff specifically, user add-ons, etc. unfortunately i can't offer much help as i don't know it very well at all. ableton / cycling74 are probably your best bets for support.

    good luck on getting this solved!

  • hey .. thx for your replies ...

    so it's good to know that it's not molar or pages ... so it's probably to do with the Mu

    @mism
    in my Library/Java/Extensions i only have:

    DBusJava.jar
    librxtxSerial.jnilib
    RXTXcomm.jar

    In my Java Prefs, i only have Java SE 6, one for 32bit and one for 64 (64 on top) ... the version is 1.6.0_29_b11-402

    i assume it's the latest one since my system is up to date.
    I wonder if i should change sth in the Network or advanced preferences ?

    @barnone
    in the max.java.config.txt i only have this uncommented:

    ; specify some jvm options ;
    max.jvm.option -Xincgc
    max.jvm.option -Xms64m
    max.jvm.option -Xmx256m

    in the lib folder i have:

    core.jar
    jdom.jar
    jitter.jar
    jode-1.1.2-pre-embedded.jar
    max.jar
    oscP5.jar
    proxml.jar
    SevenUpLive-v2.0.4.jar
    SevenUpLive-v2.0.5rc2.jar

    (i'm not using 7up in this setup btw)

    @phortran

    unfortunately Ableton support sort of gave up saying that the only thing they could tell me is that

    "it seems to be happening in some Java extensions of some Max patchers. It keeps crashing Java, more precisely Java AWT-AppKit"

    then they provided the link in my first post ... haven't tried Cycling support yet, i thought M4L support was handled by Ableton, but apparently not

    --

    it might well be that the Mu is the culprit, but i don't even know how to figure out if Java AWT-Appkit is involved/used in it ... this is the final Mu version 1.1 and Liine who bought up the Lemur are not providing support for legacy hardware so there won't be any help coming from them i guess

    i also can't quite shake the feeling that it's an Ableton bug ... just coming out of a week of full time rehearsals Live appears to be one of the most unstable 'professional' software i've come across ... we have another mac running a setup without Max 4 Live and there also we had a lot of random crashes and bugs ... all in all we lost almost 2 entire days just trying to get our setups to work again