Raspberry Pi

  • Thought I should post this - extremely exciting and interesting.

    Could this possibly lead to some amazing innovative works!

    http://www.raspberrypi.org/

    Good to see it being UK too for a change.


    Dean

  • http://www.raspberrypi.org/wp-content/uploads/2011/11/Raspi-Model-AB-Mono-1.png

  • Looks good. My Dad pointed me towards this last year, there was a fear that it would evaporate but they seem to be getting it done. If you could run an automation on startup that loaded your daw and set then theoretically you could do a set without a visible laptop/computer.

  • Yea seen that popping around for a while. It's an exciting time for computers/technology.

  • @steveoath - would be awesome without the laptop/computer.

    I was thinking about building my midi controllers using this as a brain as it would be able to send midi and OSC ala Lemur Hardware (which was built running linux)

  • Can't you do that with an arduino now?
    They have a 32bit one coming out soon.

  • You can but you have to change the library on the atmega usb chip and it still wont allow OSC unless you have the costly shield.

  • I'm eagerly awaiting the arrival of my Raspberry Pi board.

    For my final project at university I'm building a 128 monome into a large case with 16 ADCs and a 64-point CV patchbay, and I've decided to build one of these little RPi boards into the case so that the finished device can have some basic functionality without being connected to my Mac.

    Looks like I may be able to use Pure Data Anywhere since the boards are ARM-based, but I'm not sure if SerialOSC or Monomeserial will compile. Anybody else thinking of using the Raspberry Pi in a monome or arduinome?

  • ahh you were one of the lucky ones to grab one, im awaiting the hype to pipe down before i grab one. Keep us in the loop on this mate! very curious.

  • also missed out on first batch - on the waiting list for one of the next set...should hear something at the end of this week.

    definitely thinking of using this to achieve laptop-less monome control...busy learning pd partly for this reason.

    i'll also keep the forum informed of any progress i make.

  • I managed to snag from the first batch myself. I've been doing work with embedded linux for a couple months now. I was thinking about putting together a monome friendly music making distro. Get puredata, supercollider, c-sound, jack, etcetc etc working. As well as serialosc, and a handful of ARM friendly monome apps.

    Can't wait

  • i have ordered one dean

    not really sure what i will do with it

    let you know when it arrives for a look

    @alphanerd - i'd be interested in this for sure :)

    m

  • @thealphanerd

    I like that idea, a custom monome-oriented Linux distro.

    Would be cool if we could script the startup to open everything necessary for a performance and be able to run the whole thing with no GUI.

    Turn up to a gig with a monome with a built in Raspberry Pi, and play a set from Rove without ever needing to hook up a display, mouse or keyboard!

  • @marcus - for sure mate! we still need a jam soon. Text me when your free bro.

  • @dean - will do bud maybe next sunday afternoon? 18th :)

    @alphanerd - that sounds ideal and i'm sure the Pi can fit into the clone i bought off dean :)

    I have looked at a mac mini setup with a usb hdmi mini screen but would love a headless setup too

    gadget on dude !!!

    m

  • have my raspberry pi now people

    its amazing but not yet sussed out where it fits in with my analog cave

    anyone else have their's ?

    m

  • will get mine next week it seems, has anyone done something with the monome on it yet ?

  • When and where did those have it order from? I had 0 luck.

  • wohooo ... just got a tracking number ... finally on it's way to me :)

    would be nice if bitwig runs on it ... if only i could get into the beta pgm now ...

  • I've got a couple. The one sitting next to me runs chuck nicely; I haven't tried serialosc yet (but plugging a 256 directly into the USB gives an immediate kernel panic because of the power load. will have to use a hub)

  • @declutter

    what distro are you running chuck on ?

    gonna give this a try

    cheers
    s

  • debian wheezy

  • @declutter, cheers

    I will try this weekend as pick up a gs128 tomorrow

    s

  • I don't suppose anyone has tried any more with the raspberry pi ?

    or knows anyone using serialosc on them yet?

    cheers

    s

  • Hey all,

    after a long break from the monome forums I'm enjoying catching up with things.

    This morning I've installed libmonome, serialosc and rove on my raspberry pi, the only additional dependency was:

    sudo apt-get install libavahi-compat-libdnssd-dev

    Serialosc detects the monome and everything looks good:

    pi@raspberrypi ~/git/serialosc $ serialosc
    serialosc [m128-522]: connected, server running on port 17561

    However it seems that jack has some issues with the audio driver, I'll need to do some more digging.

    Cheers

  • nice one, keep us upto date man.

  • :D!!!

    what kind of jack issues are you seeing? sometimes it takes some fiddling to get a jackd command that works reliably.

  • So I've done some digging and there's apparently some problem with the Raspberry Pi driver for the broadcom audio which causes some problem with jack:

    http://www.raspberrypi.org/phpBB3/viewtopic.php?f=41&t=5787

    Investigations are on going, thanks to visinin, the beers are on me next time I'm in Berlin.

  • man, jack is //fucked//. marto i made your pi stop responding to ssh, i hope it didn't catch on fire. my bad.

    seems to just be the same thing everybody else is saying: it's the audio driver. it's a broadcom device, surprise surprise.

    i've got a pi on the way (big ups to the homie phortran for the pi), so i'll dive in when i get it. so close!

    theoretically, serialosc + pd (without jack) stuff should work already.

  • Visinin, thanks for looking at this. No fire:) I'll check out the pd route.

  • On a related subject, the hackberry board is similar to the pi, but has more RAM and a faster CPU:


    https://www.miniand.com/products/Hackberry%20A10%20Developer%20Board

  • @marto

    the hackberry looks good and hopefully the pre-order will be available soon and maybe they will even migrate to the UK :)

    I haven't had time to install yet and will have a go later

    I'm running raspbmc so wil see how it works later

    I found this link for anyone interested:

    http://www.nielsmayer.com/bin/view/Raspberry+Pi/MIDI+Just+Works+With+Rasbpian

    I am only interested in running the RPI with midi only to run analogs so audio isn@t a problem

    s

  • Wow, within the last few days the wait period dropped from 12 weeks to within 3 weeks for shipment.

  • http://www.raspberrypi.org/archives/1878

  • Gutted, didn't even know we had a Music hack day here in bonnie Scotland.

    Cool synth for sure, very exciting

  • It's not the most practical idea, but the I'm obsessed with seeing the raspberry pi powered nixie clock (pictured here http://www.raspberrypi.org/archives/1824 midway through the post) displaying SMPTE or MTC (slaved to Ableton or Final Cut or what have you...)

    Probably need more digits, though.

  • hi peeps

    i'm having a probleM installing libmonome and serailosc from the linux guide in the docs on my pi

    anyone else have issues or can guide me ?

    seems to fail to get them

    i'm a noob with linux so be patient :)

    Cheers
    S

  • @spqr6510
    you gotta be more specific than that, man. let us know what you tried to do and what didn't work.

  • @visnin

    sorry about that i wondered if generally there was a problem with it first.

    I installed latest debian wheezy from the rpi forum

    I managed to get as far attempting to install libmonome with the following:

    $ cd libmonome
    $ ./waf configure
    $ ./waf
    $ sudo ./waf install

    and it wouldn't install, I think it said fail at waf or something and the same with serialosc

    i'm not at the pi just now but can repost later

    appreciate your help

    s

  • let me know what the specific error message is and we can go from there.

  • @visinin.

    good to have you arround, bro.
    :-)

  • @spqr6510

    read my note on the first page regards installation on the Pi.

  • Apparently there's a new firmware dump for the Pi. I'll check it out asap and see if it resolves the broadcom audio issue preventing jack from running.

  • @marto

    thanks

    Did you install the additional dependency below before libmonome and serialosc?

    "sudo apt-get install libavahi-compat-libdnssd-dev"

    I updated the rpi firmware (i think) so it should work with jack later hopefully

  • @spqr6510

    yes, this was required in order to build.

  • @marto

    your a star :)

    if the broadcom audio is sorted then that will be awesome too

    cheers
    s

  • @spqr6510

    Cheers, I'm planning on starting from scratch with the official Rpi image, and making notes to put on the setup wiki.

  • @marto

    great idea

    not sure where the pi fits in my studio yet but liking the idea of headless with the 128

    s

  • @marto

    i'm getting this :


    pi@raspberrypi ~ $ sudo apt-get install libavahi-compat-libdnssd-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    libavahi-client-dev libavahi-common-dev
    The following NEW packages will be installed:
    libavahi-client-dev libavahi-common-dev libavahi-compat-libdnssd-dev
    0 upgraded, 3 newly installed, 0 to remove and 51 not upgraded.
    Need to get 193 kB of archives.
    After this operation, 572 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libavahi-common-dev armhf 0.6.31-1 [68.3 kB]
    Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libavahi-client-dev armhf 0.6.31-1 [61.9 kB]
    Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libavahi-compat-libdnssd-dev armhf 0.6.31-1 [62.3 kB]
    Fetched 193 kB in 0s (249 kB/s)
    Selecting previously unselected package libavahi-common-dev.
    (Reading database ... 55899 files and directories currently installed.)
    Unpacking libavahi-common-dev (from .../libavahi-common-dev_0.6.31-1_armhf.deb) ...
    Selecting previously unselected package libavahi-client-dev.
    Unpacking libavahi-client-dev (from .../libavahi-client-dev_0.6.31-1_armhf.deb) ...
    Selecting previously unselected package libavahi-compat-libdnssd-dev.
    Unpacking libavahi-compat-libdnssd-dev (from .../libavahi-compat-libdnssd-dev_0.6.31-1_armhf.deb) ...
    Setting up libavahi-common-dev (0.6.31-1) ...
    Setting up libavahi-client-dev (0.6.31-1) ...
    Setting up libavahi-compat-libdnssd-dev (0.6.31-1) ...
    pi@raspberrypi ~ $ sudo apt-get install git libconfuse-dev liblo-dev libudev-devReading package lists... Done
    Building dependency tree
    Reading state information... Done
    git is already the newest version.
    libconfuse-dev is already the newest version.
    libudev-dev is already the newest version.
    The following extra packages will be installed:
    liblo7
    The following NEW packages will be installed:
    liblo-dev liblo7
    0 upgraded, 2 newly installed, 0 to remove and 51 not upgraded.
    Need to get 158 kB of archives.
    After this operation, 700 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main liblo7 armhf 0.26~repack-7 [40.9 kB]
    Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main liblo-dev armhf 0.26~repack-7 [118 kB]
    Fetched 158 kB in 0s (244 kB/s)
    Selecting previously unselected package liblo7.
    (Reading database ... 55948 files and directories currently installed.)
    Unpacking liblo7 (from .../liblo7_0.26~repack-7_armhf.deb) ...
    Selecting previously unselected package liblo-dev.
    Unpacking liblo-dev (from .../liblo-dev_0.26~repack-7_armhf.deb) ...
    Setting up liblo7 (0.26~repack-7) ...
    Setting up liblo-dev (0.26~repack-7) ...
    pi@raspberrypi ~ $ mkdir git
    mkdir: cannot create directory `git': File exists
    pi@raspberrypi ~ $ sudo mkdir git
    mkdir: cannot create directory `git': File exists
    pi@raspberrypi ~ $ cd git
    pi@raspberrypi ~/git $ git clone https://github.com/monome/libmonome.git
    fatal: destination path 'libmonome' already exists and is not an empty directory.
    pi@raspberrypi ~/git $ cd libmonome
    pi@raspberrypi ~/git/libmonome $ ./waf configure
    Traceback (most recent call last):
    File "/home/pi/git/libmonome/.waf-1.7.0-42cb2ab347be0e291e68a16588fc8514/waflib/Scripting.py", line 97, in waf_entry_point
    run_commands()
    File "/home/pi/git/libmonome/.waf-1.7.0-42cb2ab347be0e291e68a16588fc8514/waflib/Scripting.py", line 153, in run_commands
    ctx=run_command(cmd_name)
    File "/home/pi/git/libmonome/.waf-1.7.0-42cb2ab347be0e291e68a16588fc8514/waflib/Scripting.py", line 146, in run_command
    ctx.execute()
    File "/home/pi/git/libmonome/.waf-1.7.0-42cb2ab347be0e291e68a16588fc8514/waflib/Configure.py", line 108, in execute
    self.logger=Logs.make_logger(path,'cfg')
    File "/home/pi/git/libmonome/.waf-1.7.0-42cb2ab347be0e291e68a16588fc8514/waflib/Logs.py", line 159, in make_logger
    hdlr=logging.FileHandler(path,'w')
    File "/usr/lib/python2.7/logging/__init__.py", line 897, in __init__
    StreamHandler.__init__(self, self._open())
    File "/usr/lib/python2.7/logging/__init__.py", line 916, in _open
    stream = open(self.baseFilename, self.mode)
    IOError: [Errno 13] Permission denied: '/home/pi/git/libmonome/build/config.log'

    dont have a clue whats happening now :(

    cheers
    s

  • @marto

    i'm now getting this in root terminal


    root@raspberrypi:/home/pi# mkdir git
    mkdir: cannot create directory `git': File exists
    root@raspberrypi:/home/pi# cd git
    root@raspberrypi:/home/pi/git# git clone https://github.com/monome/libmonome.git
    fatal: destination path 'libmonome' already exists and is not an empty directory.
    root@raspberrypi:/home/pi/git# cd libmonome
    root@raspberrypi:/home/pi/git/libmonome# ./waf libmonome
    No function libmonome defined in /home/pi/git/libmonome/wscript
    root@raspberrypi:/home/pi/git/libmonome#

  • @spqr6510

    I'm not at home right now, a couple of things.

    The warning from git means that the clone command has failed because the directories for libmonome and serialosc already exist. You can remove these and start again by doing rm -rf libmonome/ serialosc/ from within your git directory. then git clone again as per the setup wiki.

    In your last libmonome example you're not reconfiguring:

    $ ./waf configure
    $ ./waf
    $ sudo ./waf install

    There seems to be some permissions problem in your previous post. With this in mind I'd suggest removing and recloning (as mentioned above) and then reconfiguring.

    More information may be found in /builds/config.log (for both git/libmonome and git/serialosc).

    I'll definitely spend time on this over the weekend.

    Cheers