SevenUp 2.0.5d (UPDATE posted 08/02/2012)

  • wooooow! just downloaded it today and been playing with it for the past 4 hours (felt like 30 mins)..
    mate, you are a freakin' genius! this is tonnes of fun..

    although, I too am having issues where the monome suddenly isn't recognised. unplugging and re-plugging and re-connecting solves this.. I think the issue was the "tilt" feature as this problem only occurred when I tried to use tilt to control various parameters etc.

    but great work bar-none! you rule dude!!

  • @NiX
    Yes!!!
    Yeah, I don't know specifically whether such things are serialosc related or maybe we are not doing things quite perfect, but I still think it's huge improvement over the old way.

    @deshazo19
    It's funny cause another user dredged up that thread today.
    http://post.monome.org/comments.php?DiscussionID=12195&page=1#Item_7

    This...not sure that solves your question specifically but it may. Too tired to grock it all right now. I'm positive I've explained this a few times in the threads, so might search on some of the terms I am using below and see what you can dredge up.

    "If you set the each Looper track to "Master" by clicking the "Master" button in the Looper UI, it will transfer it's settings to the core when it's power button goes "On". So you can have 4 tracks with different loopers loaded, All set to "Master", but only one Looper has it's power button on at a time. You can automate the power buttons via either midi OR via a clip envelope loaded into a scene. So for example, changing scenes will transition to a new set of looper samples. This can also be done with device chains but the difference is that with device chains, the loop settings like length must be the same for all loopers in a chain. Using the multitrack approach, each looper can have different settings and be switched by pushing their settings to core using the power button.

    It's complicated I know but it does challenge you to use Live as the automation engine and mixing engine. So try to use Live features to accomplish your set flow."

  • Hey im that livid block user from earlier, still experiencing this issue where sevenupcoreclassic works perfectly until i try to open a new set, then all the leds and navigation work but no bones with making live "do" anything.

    Ive found if i restart live completely then open these sets, they work fine. It seems the error happens if i try to open the sets while live is still open.

    Only if i try to open sets without completely exiting live first, they loose functionality. I have included the "max window report" and it seems its having a live.path error, can anyone help?

    710 x 620 - 104K
  • I'm so frustrated. I really don't know what is wrong. I've uninstalled and reinstalled serial osc and zeroconf files everything I can think of and I'm back to the same dumb problem except now none of my M4L objects work with my monome.

    External Max programs work fine. When I use your serial osc tester it can see my monome but no longer connect with it. So basically M4L works as long as I don't want to use my monome with it.

    I'm having port binding issues and zeroconf resolve and browser issue even though everything is in place and there are not two instances of max running nor two monomes. I never installed monomebridge. I've rebooted too many times to count. I've deleted and reinstalled Max, Ableton is pointing to the proper folder.

    I've attached screen shots of what I'm seeing.

    ETA well I got it finally to recognize the monome and when I run test everything lights up on the monome however I do have one error in the max window: Could not load class 'mtn.seveuplive.max.mxj.SevenUp4Live' curious.

    441 x 453 - 71K
    625 x 696 - 105K
  • @machinea
    Sorry for the frustration.

    In the first log it definitely cannot find your sevenuplive jar files. 7up won't work without.

    See the log entries
    /Applications/Max5/Cycling\ \'74/java/lib/....

    There are no sevenup jar files in that folder.

    But in the second log file I see the jars.
    Why?

    But the zeroconf issue looks like the real problem.

    You sure these are here?

    /Applications/Max5/Cycling\ \'74/max-externals/zeroconf.browser.mxo /Applications/Max5/Cycling\ \'74/max-externals/zeroconf.resolve.mxo /Applications/Max5/Cycling\ \'74/max-externals/zeroconf.service.mxo

    @mrneb
    Your 7up log looks ok. Makes me wonder. Have you tried other m4l monome apps like polygome for m4l or other?

  • That was it! I don't know why they weren't showing up.. I had to go find them on my MBP and send them over in a drop box. And put the jar files in. Now I have a bright blinky 7 on my monome.

    I have no idea why the jar files were showing and then not showing in the log. However when I went into the cycling 74 folder they weren't there. In any case zeroconf files are in the right place. I've had them in there from the beginning.. and wondering if they were somehow corrupt I made sure I had the newest ones and replaced them all to no avail. So I'm not sure what was going on there at all.

    In fact here is a picture of my max folder with the zeroconf files. (see attachment) However you are right I cannot connect with polygome in M4L any longer for some reason. I keep getting the [sprintf can't convert symbol to type of argument 1]

    591 x 502 - 68K
  • eidt to add further.. that is true on both mbp (10.7.2) and imac (10.5.8) so something is still wonky.

  • yay?

    note: you have to understand the work week I had to understand the humor above. It's the little things when everything hits the fan.

  • Honestly as hokey as it sounds ever since mercury went retrograde its like my studio went bonkers. So I get it. I spent hours 2 weeks ago chasing down what turned out to be a firewire problem in my recording chain with my audiocards which wrecked so much havoc on my imac firewire ports it was hard to initially tell what was wrong. So since I've had to be all software until that is repaired all I've been dealing with this nonsense on the monome.. so no music making at all for me for the last 2 weeks and by now I'm in a foulish mood from lack of synthahol.

    So I thank you for checking in after a long week really.

  • (mercury?) is that what is happening. When is it going to end? Seriously.

  • april 4th.. I know people say it makes all manner of electronics and transactions go south but I've never had my studio bonk on me like this. Its all communication oriented stuff too.. my monome won't talk to the computer properly my soundcard can't communicate with the computer. I've taken to not discussing anything of importance with my gf for the time being just to be safe :)

  • So what is the issue do you think if everything looks sound in m4l externals?

  • -- remove bad advise here --

  • okay I'll give that a try. They all came with the latest download.. hmm.

  • damn I am getting the same problem again!. I just ran press cafe for a while and then shut it down and went back to run seven up and it won't recognize the monome again! geezus. this is hair ripping I'm so frustrated.

    it also shows the zeroconf.mxo in the folder here along with resolve service and browser.
    http://docs.monome.org/doku.php?id=setup:mac

  • @Machinea- according to the zeroconf installation instructions, the .mxo externals are supposed to be placed in your max externals folder, and from your screenshot it looks like they are in your m4l externals folder instead. I'm not sure if this would cause the issues you're describing but it's probably worth an experiment to see if moving them clears up your connection problem

  • yeah I caught that thanks for mentioning it. Oddly it didn't make a bit of difference once I deleted them (also I still had the proper files in the Max externals folder). At this point I can get sevenup to connect only if I use something like viewport serial osc in front of nosiemaker and then close out of that and open up sevenup. However the blinkey 7 is gone although all the lights check out on test and when I open up the max window it shows no conf problems at all.

    This is just bizarre. And still I can't get any of strettas stuff to connect any longer.

    Thanks for the help guys.. I really want to straighten this out and just have a decent workflow.

  • So strange... I didn't read too far back in the thread, but did you try a fresh reinstall of the serialosc app itself (not just the zeroconf externals)?
    I'm a little out of my depth here since I know exactly nothing about the protocol, just trying to help out with some troubleshooting...

  • Yeah I pretty well tried everything you could think of. I'm not super well versed in this stuff but am pretty good at computer stuff and figuring out what I'm doing particularly with detailed installations.

    I reinstalled serial osc. double checked in the terminal. Checked bonjour browser.. generally followed the guidelines from my first installation a year ago. Deleted sevenup 2.0.4. Tried to isolate any configuration issues that were maybe related. checked to see if I had more than one installation of Max/max runtime. Made sure ableton preferences pointed to appropriate max folder. Double checked zeroconf files. And... here we are.

  • now this is weird: drag sevenupcore into a new midi track... get 7s on my 256 with good response (can switch windows and create stepper patterns for instance). However, whenever I try and add a new sevenup component my monome blanks out... for instance, I drag the stepper into a new track and monome blanks... I can add the stepper drum rack, go back to core and re-connect the monome and it'll start working, until I click on the stepper track in Live and then the monome blanks again.

    same thing for the melodizer...

    in fact, I can set up all my sevenup tracks in live after the monome blanks, save it as a live set, restart live, open the set and the monome works fine unless I click away from the Core track... in which case it blanks again!?

    help me obar|none kenobi, you're my only hope.

  • @GetTheLEDOut
    This is the MAX6 bug. You need to redownload the distro. It was updated 3/10. You need to replace your .amxds. Easiest way is to grab them from the ./components folder and replace your old ones.

    If you did install from a distro downloaded after 3/10, please let me know.

    @machinea
    I would really recommend you find the .conf files that serialosc generates at look inside for example at the prefix. Each app that connects to serialosc will likely change the prefix to what it wants. I describe how to do this up a bit in the thread. You can also monitor changes to these files when the monome is plugged / unplugged.

    I shouldn't have told you to delete the one zeroconf file. I went back and downloaded the zeroconf distro from the setup instructions and unzipped. All the .mxo files should be installed at minimum.

    zeroconf_example.maxpat
    zeroconf.browser.mxo
    zeroconf.maxhelp
    zeroconf.mxo
    zeroconf.resolve.mxo
    zeroconf.service.mxo

  • I thought I redownloaded the distro but perhaps not correctly. last night I tried to re-install 7UL (from new distro) according to instructions on the site. I deleted the instruments and exported as per instructions as this was an upgrade. No fix.

    just now, I pulled the amxds out of the components folder from the new distro and replaced the corresponding amxds in the Seven Up 2.0.5 template project folder (under presets in the 3 folders I found amxds).

    still no go. as always, I'm overlooking something but can't figure out what... probably where I'm dropping the amxds? What do I need to delete to completely reinstall (not upgrade)?

  • @ bar/none they are all there in the proper Max- Externals folder including the .maxpat and .maxhelp files other than the .mxo. Deleted the ones I accidentally put in the M4L externals last night. I've had some luck connecting this morning again. I'm trying to go through some tutorials to see where things are at. I'll get back to you.. thanks.

  • @GetTheLEDOut
    Have you tried simple dragging from ./components folder on filesystem and dropping directly into your set?

  • Solved my problem...

    Guess it had something to do with "leftovers" from previous Ableton installs. Turns out that the "library" folder was hidden by default in osx Lion.

    After installing everything from scratch it works again! Omg, how can anyone live without 7up????

  • okay so I've played around a bit.. don't want to jinx myself but seem to have sevenup working on mbp 10.7 yet no polygome or other stretta M4L programs.

    Back on the imac I tried to get the monome working again and while I can connect if I go through view serialosc and noisemaker or clipmapper (then sevenup will recognize the monome otherwise nada) but I no longer get the blinking 7 on start up/connect.

    so I opened up the sevenup and found this and am not sure if it means anything.

    I can see there is a conflict. When I click on that option it shows me its still the zeroconf.browser and zeroconf.resolve. It looks like its trying to choose between a device version and disk version. and as you can see the only version that shows up when I ask the finder to do a search is the disk version (at least according to the date attached to that version as you can see from the picture) However it doesn't fix the problem when I select it to choose the newer device version.

    I know you have said there is a zeroconf problem and obviously this is showing it but I can seem to track down what it is and how to fix it. But this seems to be the problem I'm having as those two keep showing up in almost every M4L program I try to open.

    843 x 631 - 100K
  • If I press "connect" Ableton freezes, if I press "start/stop" I get the blinking 7 and everything runs smoothly from there on... weird stuff!

  • @machinea
    Never seen such a dialog. I'm going hazard a guess that both versions are on your filesystem. Mine BTW is dated Nov 22. I'm guess one set in m4l-externals? and one in max-externals. Maybe spotlight can find all of them.

    I would put the newer Nov 22 files in max-externals and delete the conflicting ones. This two machine setup thing where neither works quite right sounds a bit scary. Why not get one working 100% and copy the entire MAX folder over?

    @peterlaustsen
    Have you done the right-click on the 7up core title bar and choose "Open MAX window" might be something in there? Not sure. Freezes, like for how long?

  • Thanks bar/none. I'm pretty sure that what I've been experiencing isn't the normal types of problem but some configuration issue with m4l and maxruntime or something of the sort.

    Yeah I've been trying to get one working fully and then figure that out and fix the other.. the only difference between the two machines is the OS other than that ableton and max are same.

    I've deleted all the zeroconf from m4l-externals so I'm not sure where this file is when I did a check in the max-externals they showed the oct 21 date. But I'll keep looking and if I find the answer I'll post it here in case anyone else runs across this issue.

  • Wow.. I'm really bewildered now. I have no idea how this installation could have screwed everything up so badly. As far as i know the monome was working on both macs without a problem until installed this program. But to be honest I can't be 100% sure because I hadn't worked with it in a while.

    So what I've done at this point is remove both zeroconf files that have the conflict since there seems to be another later version running in devices somewhere that I can't track down at all. so its somewhere on the system but who knows where since the older version is in the proper max externals folder. Anyway I opened everything up and of course there is no more conflict but still the monome is sketchy connecting unless I used the viewport serial osc program.

    So I've been doing other research trying to see if anyone else has had a problem like this. I continue to have 17812 port binding issue something else is already bound to this port (yeah but what) so I do a terminal cat /var/log/system.log | grep serialosc and all I get is this:


    Mar 26 16:20:40 Corrinne-Haskinss-iMac org.monome.serialosc[199]: serialosc [m0000107]: connected, server running on port 11554
    Mar 26 16:20:40 Corrinne-Haskinss-iMac org.monome.serialosc[199]: serialosc [m0000107]: disconnected, exiting
    Mar 26 16:35:03 Corrinne-Haskinss-iMac com.apple.launchd[198] (org.monome.serialosc[208]): open("/var/log/serialosc.out", ...): Permission denied
    Mar 26 16:35:03 Corrinne-Haskinss-iMac com.apple.launchd[198] (org.monome.serialosc[208]): open("/var/log/serialosc.err", ...): Permission denied
    Mar 26 16:41:35 Corrinne-Haskinss-iMac com.apple.launchd[91] (org.monome.serialosc[204]): open("/var/log/serialosc.out", ...): Permission denied
    Mar 26 16:41:35 Corrinne-Haskinss-iMac com.apple.launchd[91] (org.monome.serialosc[204]): open("/var/log/serialosc.err", ...): Permission denied
    Mar 26 17:05:43 Corrinne-Haskinss-iMac sudo[571]: chaskins9 : TTY=ttys001 ; PWD=/Users/chaskins9 ; USER=root ; COMMAND=/bin/rm /usr/local/bin/serialosc
    Mar 26 17:05:43 Corrinne-Haskinss-iMac sudo[574]: chaskins9 : TTY=ttys001 ; PWD=/Users/chaskins9 ; USER=root ; COMMAND=/bin/rm /Library/LaunchAgents/org.monome.serialosc.plist
    Corrinne-Haskinss-iMac:~ chaskins9$ serialosc
    serialosc: lo server error 9904 in (null): cannot find free port

    I'm aware that the lo server error suggests that I have two copies of serialosc running. but I don't. but to be sure I uninstalled it again and reinstalled it. Same thing.

    Could all of this be a response to having more than one profile on my computers? I have my own profile with a password and a general user profile without. I don't understand these denied permissions and I don't know how to find what is using the port that is supposedly bound up. Bonjour browser hasn't been much help there.

    ETA...I don't think the different accounts have much to do with this.. as its not affecting the 10.7 lion mbp.

    Do you think I should just open up a separate thread under the help section? I don't want to further bog down this update as I think this is going to take some special trouble shooting... the rabbit hole just keeps going deeper.

  • Well just a quick update: I've got max objects loading and sevenup working on 10.7 mbp. The m4L devices like Stretta's will not connect still due to the port binding issue conflict. I reinstalled max/maxruntime on the 10.7 and at least now the maxruntime stuff works okay. Before I only had sevenup working on the mbp.

    The imac is turning out to be a much bigger headache than I'd anticipated. Maxruntime works but that is it, no sevenup and no m4l devices (other than the ones that allow viewport serialosc). Interestingly in the console it shows that there is a problem with zeroconf failing to load at all. This along with the with the denied permissions.

  • You have to run serialosc with admin permissions.
    Your user doesn't have admin permissions on this machine?

    I'm kinda thinking this epic adventure of your might need a new thread. Would like to keep this thread focused on 7up and readable for users.

  • I'm doing just that... thanks again bar/none.

  • Hey Bar-none

    I noticed that you tried using griddle to mix several monomes into one for use with 7up, but it appeared there were some issues.


    My friend and I want to connect a 256 and a 128 to be used with the same instance of 7up, and we tried doing this with griddle. in order to make one monome, but without luck.

    7up sees the "supernome" but it's not possible to connect.. or at least it doesn't do anything.


    Is what we're trying to do even possible in 7up 2.0.5?


    We wrote the following in griddle.basic:


    # virtual device name
    [supernome]
    port = 3333
    size = 16, 24
    offset = 0, 0

    # attached physical devices
    m128-083 = 0, 0
    m0000126 = 0, 0


    and we get this error in terminal:


    OSCServer: NoCallbackError on request from dsldevice.lan:56785: No callback registered to handle OSC-address '/7up/grid/led/all'



    Regards
    /S

  • i've got sevenup running on my 128 finally.

    however, i'm wondering something:

    on my desktop in live 8.2.8 seven up runs in two instances on a single 128.

    on my macbook, it only runs one instance on the left hand side of the 128 (with cable left orientation).

    any idea why?

    *edit* i just reopened/relaunched everything at it is working fine now!!!

  • will it ever be possible to increase/decrease the number of steps in the stepper? will it ever be possible to increase the number of patterns in the sequencer beyond 7?

  • You mean beyond 7x8 or 56 steps?

    No plans for it right now. Make a case.

  • So... I've downloaded Seven Up Live for the first time and I've followed the instructions on the site.

    SevenUpCore can detect my monome, it automatically starts when I connect and I see dual flashing 7s on my 128 grayscale. So we're all good at this point. My log in the Max Window looks normal. I hit play to just make sure my monome is communicating correctly and I see what I would expect: rows highlighting in unison with Ableton.

    Then I click over to another track I made with the seven up drum rack stepper and it just stops communicating with my monome. The rows stop highlighting and button presses do no thing. I can go back to the SevenUpCore track and restart it, but the same issue occurs when I click off that track and onto another.

    I've tried clearing out my serialosc conf files for my monome to no avail, and also unplugging/replugging my monome in doesn't fix the issue either. And my last restort but usually solves-anything-strategy of rebooting solves nothing. :(

    I've attached my log from Max as a png to this post and the bottom highlighted line is the last output I receive when clicking to another track from the SevenUpCore track.

    OS: OS X 10.7.2
    Ableton: 8.2.7
    Java: 1.6
    M4L: Max6 Runtime

    Any ideas?

    965 x 529 - 92K
  • That problem is a dead ringer for an issue we had with MAX 6, since fixed on 3/10, see top of thread.

    Did you install this after 3/10?

    Any possibility there are old .amxd's left around?

    You could try the ones the ./components folder in the distro directly.

    I now what this issue is but I was certain the lastest .amxd files fixed the problem.

    BTW, this is MAX 6 only issue.

  • Hey,

    Sorry I'm just getting back to this thread. I downloaded after 3/10, but I've noticed my .amxd's have a modified date of 3/9/2012 6:26am. Is that correct? I got the distro from: http://makingthenoise.com/sevenup/dist/SevenUpLive-v2.0.5.zip

    I just checked it tonight as well. Is there an updated distro somewhere else?

  • hey there y'all in monome land,
    got a few questions, cannot figure out if i'm doing something wrong, or if sevenup isn't capable of the following:

    i save the sevenup patches when i'm ready to shut down ableton, save the patch from inside the ableton set,
    when i reload the ableton set, i can reload the patch and the sequences will show up on the monome, from the stepper/etc.
    but there's no sound. none at all.
    i can get sound if i manually click or midi key the drums/keys/etc. from inside ableton.

    am i missing a critical step?

  • melodizer button presses delayed and lagging when trying to play to ableton clock, everything else working fine can someone point me in the right direction where to fix this? In ableton preferences do I need to change midi sync times on iac ports? also if someone could point me to more info on configuering the buffer shuffler?
    thanks for the help and great app.

  • Hi
    I have a question. I'm using sevenup classic with MonomeEmu and Novation Launchpad and it works really great as a multicolor device. But now I'm wondering how to record the midi signals. e.g. i want to record the midi signals for the stepper drum rack as a ableton-clip. Is there any posibility to do this?

    Thanks for the great app, the nav menu allows fast acting and intuitiv work

  • Hi,

    I want to take osc data from 7up and pipe it into another max/msp patch or maybe even to another program that understands osc. There is an app called serialosnoopy which helps with this. However, it ask that you to first copy the serialosnoopy.maxpat file into any monome application folder. Open the application and modify the patcher file from serialosc.maxpat to serialoscnoopy.maxpat.

    Where do I find the serialosc app for 7up. What port does 7up send out to?

    Would you recommend another way to take the osc data from 7up to another program.

    Great app and great documentation. You rock!

    max osx 10.7.4
    2011 monome

  • Hi,

    first of let me thank you for this incredible tool!! It's fantastic. And on OSX on my macbook it works like a charm together with my _arduinome_. However, I ran into several problems on my windows 7 box.

    First I made sure the device is working by testing it with Renoise, Duplex, and Arduinomeserial. No problem, everything okay!

    But SevenUpCore + serialosc doesn't appear to work at all. I think it might be linked to the OscP5 library [see attachment sevenUpError01]. I also got the port binding issue, though I think that might be related to this as well [see attachment sevenUpError02], in fact, the port was used by Ableton already, probably sevenUp [see attachment sevenUpError03].

    [continued in next comment due to attachment restrictions].

    593 x 463 - 37K
    632 x 802 - 122K
    928 x 692 - 138K
  • I tried the obvious and downloaded the most recent OscP5 lib and replaced it with the original one provided by sevenUp but that did not help at all :) [see attachment sevenUpError04].

    So I reverted everything back and tried using SevenUpCoreClassic. This works! However, it has some other issues. It works exactly one time. If I connect my arduinome -> launch Arduinomeserial -> launch Ableton -> insert SevenUpCoreClassic -> test it with Melodizer or Stepper etc. it works.

    Then when I open a new session and add SevenUpCoreClassic the whole device communication appears to work just well. But none of the provided Effects like Stepper, Melodizer appear to send any data to the drum racks or instruments. No errors in the Max window to be seen this time!

    I believe I could probably fix this myself but I would love to get some pointers where I should start looking for issues. If the whole midi sending thing is implemented in the java side of things I am not much of a help though :(.

    Thanks in advance for any advice and again thanks for this cool tool!

    [UPDATE] Okay I think I might have a guess at whats going on. I looked in the melodizer patch and found out that you don't use unique send/receive names (ie ---receiveName instead of receiveName). This might be the culprit. I am looking into that this weekend.

    739 x 796 - 136K
  • @michaelklier
    Glad classic is working. You can only use ONE core in a session ever. This is due to the global communication mechanism. It already provides so many tracks, pages etc with one core that the added complexity was not worth it for us and would affect usability.

  • Re recording midi signals. You need to use a duplicate melodizer, stepper etc in another track that does not have instrumnt to record.

    To play back route to the track that has the component plus instruments, however incoming midi will not pass througfh the sevenup componets unless you switch their power button to off. This is by design.

  • yo dudes

    i'm wondering if there's any way to use 7up, especially the sequencer with my 128 using 16 steps instead of the 8.

    also (totally unrelated) anyone have any success with step64? i simply cannot get it to run.