SevenUp 2.0.5d (UPDATE posted 08/02/2012)

  • @bar|none thanks for the reply! I know I can only use one instance of SevenUpCoreClassic per live set.

    Maybe my explanation wasn't clear enough (English is not my first language :/).

    Let me explain the issue again: I have a live set running SevenUpCoreClassic just fine. When I save it and create a _new_ live set and load an instance of SevenUpCoreClassic, the communication between my arduinome and SevenUp works, but none of the of provided effects send/receive data anymore. As if sevenUp still sends the data to the instances of the effects in the session I have _closed_ before.

    That means I actually have to _quit_ Ableton Live if I want to switch between live sets that use SevenUpCoreClassic to make it work.

    I also would love to use SevenUpCore. Is there anything I can do to debug the OscP5 error. I just need some pointers where I should start looking. (my Java is very rusty to put it lightly, but I would really love to make this work :P).

    Thanks again!

  • Got a bit further using some tips on here, now my computer and monome are connecting but nothing happens when I press Start/Stop or Play. The test and clear seems to work but apart from that no lights or response

    I've attached a picture of the Max Window.

    Any help would be great, I have been scratching my head about this for 2 days

    CHEERS

    1440 x 900 - 307K
  • @ tim whispered screenshot looks like zeroconf cannot load. What model mac is this? Os version? I know some older macs had issue with the binaries.

    Second screenshot looks like cannot start udp server on port 8000. You could try deleting your serialosc conf file for this monome ans let it choose a different port.

    In user home ./Library/application support/monome.org named your monome serial num .conf like m128-089.conf

    If you really want toget beyond this, use sevenupcoreclassic with monome serial and make sure to kill the serialosc running process.

    Sudo -ef | grep serialosc

    To find the process then

    Kill pid

    Where pid is the process number.

    On ipad right now so instructions are not the best

  • @bar|none, hmmm maybe I misread your reply.

    By " You can only use ONE core in a session ever. " you mean a live session (instance of Ableton live running != live set)?

  • @barnone, thanks very much for the reply. I'm using a old MacBook pro with OS X 10.5.8. Its about 5 years old.

    I have tried using SevenUPcoreclassic but still no joy?

    I also don't seem to have the /monome.org folder in my application support folder? Do you think this is the problem?


    Also how do I kill pid? Not exactly sure what that is.

    Thanks a lot for your help

  • anyone else having trouble saving patterns/patches in 7up?

  • Post in the 40h thread saying upgrading to snow leopard fixed discovery issues. Kinda thinking that we need to consider moving latest tested os to snow leopard or greater. It impossible for us test older than that.

    @timshaw 5 yr old macbook might even not be able to run java 6 properly. If it's 32 bit machine apple basically ditched java support on these. Apple is really the ine aggressively deprecating stuff. Seems definitely the zeoconf binaries will not run. Maybe p5osc also has compat issue.

  • @bar|none,

    I don't have any trouble with any other m4l instruments (such as schwartzinator)
    which seem to run on Java 6.

    I got it working for a second, the 7 lit up and we were going but then after I switched to the sequencer it stopped communicating.

    Maybe its time for a new laptop :(

  • Got a little bit further with this..

    It always recognizes my monome and now I'm just getting 'oscbonjour' error.

    I've attached the screen shot..

    1440 x 900 - 289K
  • If it says that then MAX can't see the max external. You positive it's installed correctly?

    You can actually try a MAX patch yourself and type in "oscbonjour" as the object name and see if MAX recognizes it.

  • My Monome seems to be recognized by SevenUp--when I press test the device lights up. However, I never see the 7 on the device and can't do anything else. For instance, when I try to use Stepper, the monome never lights up and Stepper does not respond to button presses. I have Max 6 and Windows 7.

    I have serialosc installed and working with other apps, the zeroconfig files and the java files are in the right place. The error window in Max is attached.

    It seems like a great piece of software and I really want to use it, but always encounter this error.

    1656 x 944 - 341K
  • It says not connected. When you hit "connect" button, does that change?

  • Hello, I have the same issue here.

    The monome is connected and the test turn on all the grid.

    But when pushing in start/stop, the 7 doesn't appear on the grid.
    I have a new 128 2012 edition.


    Any Suggestion?
    Thank's

  • IMPORTANT

    .alp file from 2.0.5 did NOT have the latest bug fixes in the .amxds

    You can also just drag and drop the .amxd files from the ./components folder in the distro over the top of the ones installed from the .alp file.

    Seems that the .alp was NOT updated properly in 2.0.5 which has led to a lot of confusion.

    Fixed distro is here.

    Also added a fix for broken multiintensity led support that was broken with new serialosc version.

    http://www.makingthenoise.com/sevenup/dist/SevenUpLive-v2.0.5c.zip

  • bump for spam

  • I would love to see a 2.0.6 version. And install it fresh.I try this 2.0.5 since the beggining and never worked very well for me.Now i downloaded this 2.0.5.c and seven up stop working again.
    Sorry but I don,t have any idea what distro is.I just follow the steps every time i installed seven up and i can,t get this working again.

    mac 10.5.8
    ableton 8.3.3

  • What does the MAX window say? Right click title bar in SevenUpCore and Open MAX Window.

  • I installed the new version last night and I cannot get it to work. Steps I took were:

    - First uninstall previous SevenUpLive instrument, midi, audio components

    - Replaced supporting .lib files in Cycling '74/java/lib with new ones

    - Install the live pack, open new set, manage set and export

    I did actually got the startup 7's a couple times last night but things seemed to be off (could never get the actual clock "bar" to move with the ableton set)

    Haven't been able to get any response yet today from SevenUp Core


    Anyway, attached is the max window

    I'm using Max5.

    800 x 779 - 120K
  • OK, I see what happened. In fixing the multiintensity led support, looks like I broke the regular mode.

    @emergencyofstate
    Your MAX window looks perfect. If you want a temp fix and have the old SevenUp...jar file around still, just put that jar back and should fix it.

    I will fix this tonight.

  • Cool, thx for the temp fix! Now I can play at work :P

    I assume all I'll have to do is replace the SevenUp...jar file again when you have a fix?

    Also, I'm curious, how does the multiintensity led support actually play into SevenUp?

    --edit---

    When I copy a pattern from the stepper (this is now with the previous version) to another pattern it does not seem to play when I set the sequencer page to that new copied pattern. I see the lights of the copied pattern but nothing plays.

  • this is my max window.I always drop before 7up other monome m4live device to detect the monome.I have problems with zeroconfig and 7up that i can,t resolv.Anyways if i do this 7up recognize the monome.

    No lights on the monome.

    1920 x 1200 - 465K
    1920 x 1200 - 475K
  • @Bite
    Looks like you have 2 SevenUpLive...jar versions in your java lib folder in MAX. That could certainly cause some issues.

    I just updated to 2.0.5d which fixes the bug I injected using the non-multilevel led mode.

    Since you already installed 2.0.5c, you should only have to replace the SevenUpLive...jar file inside that folder. Make sure there is only one.

    Other users upgrading from the original 2.0.5 should do a full install to get the upgraded .amxds

  • 2.0.5d uploaded. 2.0.5c had a critical bug injection.

    http://makingthenoise.com/sevenup/dist/SevenUpLive-v2.0.5d.zip

  • Awesome. thanks!

    -edit- nevermind about the pattern problem, I had stepper set to slot 1 - :/

    -thought-

    For users with devices bigger than a 64, One of the awesome things about seven up with a 128, 256, etc is you can have multiple components of SevenUp open at the same time. However, the nature of the grid makes it difficult sometimes to discern the borders of each section especially if you're moving quick.

    I'm thinking it may be a super useful feature to be able to say make

    section 1 = intensity 5
    section 2 = intensity 15

    or maybe it would make sense to be able to set brightness for each component? I'm not sure.

    that way you have a clear separation of the sections on the grid accomplished by the variable brightness. :)

  • Thanks!
    That was the problem.Everything works fine again.

  • good news

    @emergencyofstate

    Well with the multilevel option, there is only one blinking light and that light is always in the nav column, so it seems to help at least me see the borders.

  • New 2012 multilevel look great.

    Really a pleasure.

  • Hi bar|none - sorry for this probably dumb question - with this new update, which files do I need to delete/replace? Should I go through the whole process of opening the .alp template in ableton again?

  • You want the new .amxds and the new .jars. You can replace the .amxds in your library directly by finding them and dragging dropping from ./components folder of distribution.

  • Hello bar|none
    I have a problem using SevenUp live 2.0.5d
    just installed following the instructions
    I opened a new project, plugged my monome gs64
    I dropped SevenUpCore in a new track
    Then i connected the monome, tested it and it worked
    I dropped the looper in another track
    dropped SevenUp looper from max midi effects in front of the looper i dropped before
    I pressed play but it didn't work
    Monome doesn't light up
    Can you help me?

    (sorry for my bad english)

  • Hi gio, when you start SeveUpCore did you get the flashing 7's?

    If not, can you right click in title base choose "Open MAX Window" and attach a screenshot of this window, after clicking start in SevenUpCore?

    Screenshot of the set might also help

  • Dear bar|none,

    I have some trouble too, it might be the same as gio above.
    Running latest max and live, java, serialOSC, osx 10.7.4 and followed the download and installation list on your site.

    After dropping SevenUpCore onto a track I get 2 7's (running on a 128) and 7up runs. Then I add the stepper on a different track and all lights go off. The Max-window prints the last two lines, see attachment.

    When I return to the track with the core and press start/stop again it will run and I can press the buttons and hear the drums play. As soon as I click on the Stepper-track (or any other track) the monome goes dark and the sound stops.

    I tried adding the Melodizer and got the same result. It works, but only when the Core stays selected.

    It certainly looks great, can't wait to have it running smooth. Hope you have enough information. Thank you.

    693 x 384 - 100K
  • I read some older posts about Max5, so installed that one and now it works fine. Little bit confused as I read Max6 should have worked too. Not sure how this affects my other m4l-pachtes, but at least now I can have some serious fun with SevenUp.

  • This was 2.0.5d that you installed?

    Yes, that MAX6 bug should be gone. Did you install this using the template and did you have an old version installed before?

  • just set up 7up 2.0.5d. works like a charm here with my gs64&gs128.

    some points i don´t understand:

    1) i just trying to calibrate my tilt. no mather how i do it, i will always get the same result.
    - holding my monome flat, button up - i get a 64 value
    - turn it by 90 degrees, button facing to 12 o´clock - i get a 0 value
    - turn it by 90 degrees towards me, button facing 6 o´clock i get a 127 value.

    how could i manage to calabrate my monome in order to have value of 0 when holding flat and a value of 127 when turning towards or away from me.

    2) in Sevenupcore/tilt i can see both indicator showing my a tilt feed back of both axis. but the first axis seems "muted" as said in the manual.

    so, how could i mute and un-mute these axis. i´m on serialosc and not using monomeserial
    actually, i am wondering how i could turn on an d off my adc ports. is there an serialosc command which i can type in my terminal.?

    osx 10.6.8

  • 2.0.5d. is the only copy on my machine. I discovered SevenUp this week so had no earlier version installed. Before this post I trashed all the SevenUp files, alp, amxd, als and jars. Downloaded 2.0.5d again and installed it following each step from the list, using the template. Again, same problem, after dropping the stepper all stopped. Changed back to Max5 and it worked again.

    Running Max 6.0.5, Ableton Live 8.3.4 on OSX 10.7.4

    If no one else has this problem anymore I might have overlooked something essential. Any ideas? For now I'm enjoying SevenUp a lot. Although it would be great to have it running with Max6.

    If you want or need some more information, please let me know.

  • Did the posts with @Machinea get continued on another thread? I am having pretty much the same problems and wanted to see if it came to a resolve?

    I am using OSX 10.5.8 with Max6 and Live 8.2.5
    SerialOSC 1.1d caused me lots of headaches so I have installed v 1.0 which seems to be okay.

    At first I had trouble connecting to the monome through sevenup at all, as per Machinae's problems the list wouldn't refresh. This then fixed itself when I dropped in serialosc tester (very useful, thanks!) but now as soon as I move off of the core track, the monome disconnects again. Any ideas?

    No errors in the Max window, but I have the same zeroconf conflicts as Machinae had

    Thanks in advance

  • @mrsibs
    The stopping on focus change is a MAX 6 we thought we had fixed (read top of thread). If you installed the .amxds with a version before 2.0.5d then definitely you should upgrade. If nothing helps, You can switch Ableton to use MAX 5 which doesn't have the problem.

  • thanks bar|none, I will try it out tonight!

  • Hello bar none,
    hope you are well, long time we do not speak.

    I have restarted using launchpad + 7up + monomeemu.
    I am now on a MBP with Lion OSX 10.7.5 and with the newest Ableton Live 8.3.4.
    I have downloaded you latest 7up 2.0.5d and did a fresh install.

    I own also MAx6 but I am using max5 for M4L as monomeemu would not work instead.

    I have tried several times to make it work but everytime I press start on Sevenupcoreclassic the big 7 does not appear on my launchpad neither the 2 blinking buttons.

    I am frustated at the moment as the last time i have used it in windows xp (old machine) it worked like a charm
    Any other M4L application for monome works perfectly but I want 7up!!!!!

    Attached a screenshpt pf max window + ableton...any tip?

    thanks
    bassik

  • Hello All,

    A quick follow up on my issue to see if it can be resolved (please!)

    I have noticed that when I start Sevenup core the in led of monomeemu remain lit and nothing happens.
    I believe there is some communication error but max windows doesn't help.

    Really chasing in the dark at the moment.

    It is a shame I cannot use my favorite app now when I changed OS (win to mac).

    Please help!

    bassik

  • hi,

    just wanted to ask you guys, i can't seem to be able to connect my 40h into sevenup.

    i'm pretty sure i've met all of the requirements needed. so yea, i'm not sure what's up. :/

    i'm on max 6 by the way.

    advanced thanks to anyone who can help.

  • @bassik
    Have you simply tried manual config and set the prefix and ports that way?
    Your 7up logs looks perfect, I don't see anything I'd worry about there.

    How do you know that monomeemu is working? Is there a test mode or something.

    In the manual config use 127.0.0.1 as hostname.

    @sleepersecond
    You need to provide a lot more information on what you have tried exactly. Also see bassiks screenshot. Right click over SevenUpCore title bar and "Open MAX Window". Start 7up and look for any errors there.

  • thanks bar|none!

    max seems to be having problems with the zeroconf externals (see image 1, and 2.) i'm using serialosc so i use the sevenupcore, but even with my 40h connected, sevenupcore can't find my device (see image 3.)
    it seems to only deal with two externals that works with serialosc (see image 4.)

    i also only recently upgraded to max 6. but i did a clean reinstall of serialosc.

    other info:
    osx 10.5.8
    live 8.3 (did not upgrade to 8.4, had gui related bugs)
    java 1.5
    max/msp 6

    thanks again. :)

    1280 x 800 - 570K
    1280 x 800 - 692K
    1280 x 800 - 396K
    1280 x 800 - 818K
  • found a solution for my 40h. just sharing it in case anyone else have problems with serialosc inside m4l.

    all i did was copy all of the zeroconf files into the m4l-externals folder. (although i am pretty sure i'm not the first one to try it.)

    now sevenupcore can connect to my 40h, BUT the serialosc dropdown still can't find my 40h. (which is a rather weird thing.)

    1 drawback; i can only operate 7up if the sevenupcore's midi track is in focus. if i touch other parameters in live (i go to the master track for example) sevenupcore instantly cuts off the connection with 40h.

    still a bit puzzled.

    however, i enjoyed playing with the app! cheers!

  • @sleepersecond

    That is interesting information and kudos for working it out.

    I wonder if something has changed regarding externals folder. I haven't even looked at or seen the m4l-externals.

    Re the focus problem. That is specific to MAX 6. We thought we had fixed it but obviously not as we still get reports about it. Strangely I don't have the issue. You might try dragging the core from ./components folder directly and see if that makes a difference.

    You can switch to MAX 5 when using 7up as a temp solution.

    I really have had 0 time to work on 7up lately. My wife and I just had our first child and life is focused on that, but hoping to get back to the community soon.

  • hi,
    I am having issues while connecting to sevenup from live, it doesn't recognize my monome 64 (all I can see is 128 and 256).

    Apart from that everything else seems to work just fine, I have been trying every patch I could fine like a mad man for the past two weeks and they all work like a charm.

    live 8.2.8
    max 5.1.9

    if anyone could spare a minute and have a look at this it would be much appreciated.

    thanks

  • oh and here is the max window screenshot

    it seems to me that is something wrong between live and max - because if I click the edit patch in max button in live it suddenly works fine, it sees my devices (m64 and arc) and I am able to connect (the huge 7 lights up and everything), it just doesnt work in live for some reason

    thanks

    737 x 762 - 240K