error loading zeroconf externals - solved

  • So.

    After a couple of years away from these forums i thought i'd update to serialosc, time to leave monomeserial behind! Followed the setup instructions but when i open the monome_test app the max window says

    "error 14001 loading external zeroconf.resolve"

    and the same for zeroconf.browser. I've tried moving the externals around but where i place them shouldn't matter, right? I also tried downloading them again but still get the above message.

    I'm on windows xp sp3 max 5

    I'm guessing i'm stupid....any other ideas?

  • You put the externals in the Cycling 74/Max-externals folder right? It does matter AFAIK that they are in there specifically. Have you also stopped running monomeserial?

  • I tried in the externals folder, didn't work. I thought you could just put them anywhere in the max folder but maybe i'm wrong. Also, it's a clean install so monomeserial is not the problem.....

  • Do you have Bonjour installed? Itunes will install it automatically though I think you can also install the bonjour print services.

  • I don't have itunes but yes, bonjour is installed, although im not sure how to check if it's "working"....

  • you're using these right?

    http://docs.monome.org/lib/exe/fetch.php?media=app:serialosc:zeroconf_20110226_win32.zip

  • yep, the ones in the setup guide

  • Found a thread in the Max forums hinting that i needed to install "Microsoft Visual C++ 2005 or 2008 Redistributable Package". I don't know what that is or why i don't have it when everyone else seems to but it's working now.
    Thanks for the help.

  • ah. this is due to XP. this should be added to the setup guide, thanks for your good discovery.