[¿fixed?] Serialosc Mountain Lion Compatibility?

  • yeah, testing the installer, will be out later today. having some weird trepidation about this one, dunno why, not much has changed. just double-checking everything.

  • once this posts, will i need to uninstall my previous version of serialosc?

  • //[broken link, removed]//

    k, this should do it. should be fine on older versions of OS X too but i can't test that right now.

    if you've done some hacking to make serialosc start automatically on mountain lion, undo that or you're gonna have a bad time.

  • w00t! thanks dood.

  • Don't need to do anything as far as uninstalling the old serialosc?

    And does this do the varibrightness compatibility stuff too?

  • oh nope, the varibrightness compatibility stuff isn't in there yet. thanks for reminding me.

    shouldn't need to uninstall anything, it'll just overwrite the old files.

  • Damn, I //did// uninstall the old serialoscd, but that shouldn't matter right? However when trying to connect my monome in monome test after installing the new version, it wasn't being picked up. (It just says "no devices detected" - I have tried this with my GS64 & GS128)

    I thought, OK ...do I have to do the chmod thing again (aka Lion fix)? So I did that and serialoscd is showing up in local/bin/ like it should...
    //Camerons-MacBook-Pro:~ artpunk$ which serialoscd
    /usr/local/bin/serialoscd
    Camerons-MacBook-Pro:~ artpunk$ //

    so why is my monome not being picked up? Bummer...

    Latest (non-retina display) ivy bridge Macbook Pro, running Mountain Lion

    (btw, I did delete my old .command serialoscd start stuff, so it's not that messing with it either) Oh well, got to get up in 6 hours so better go to bed. Sorry for any extra headaches visinin, but it just doesn't seem to want to play for my installation of ML. I'll check in tomorrow, down-under time...

  • did you reboot after the install?
    if so, type this at the terminal for me, with your monome plugged in:

    > ps aux | grep serialosc

  • After installing 1.1b and running serialosc manually, I get:

    dyld: Library not loaded: libmonome.dylib
    Referenced from: /usr/local/bin/serialosc
    Reason: image not found
    Trace/BPT trap: 5

    I see libmonome.dylib symlinked to libmonome.1.1.dylib, but libmonome.1.1.dylib isn't there.

  • Isn't 1.1b supposed not need manual launching?

  • @Rodrigo That's right AFAIK. I was just troubleshooting.

  • i did a clean install of 10.8 after a wireless card fail, and i can't see serialosc or connect to my arc. just about to run out the door so can't really do much more foofing about for tonight. rodrigo or anyone else, did you get this working ok?

  • also seeing the same problem as nprolog above...

  • I'm not tested it yet. I'm gonna install it on my desktop now, but I don't want to put it on my performance machine until it's all verified/etc..

  • I installed it on my imac. "serialoscd" appears and disappears from my activity monitor every 2-3 seconds or so. Connecting my monome didn't launch more serialoscd's.

    The monome seemed to show up in monometest (though the umenu might have just had stuff in it). It wouldn't connect.

    Running the terminal line gives me this:

    Rodrigos-iMac:~ Rodrigo$ ps aux | grep serialosc
    Rodrigo 416 0.0 0.0 2432768 592 s000 S+ 7:26pm 0:00.00 grep serialosc

  • wow, i botched that. the installer was broken, it was installing the wrong libmonome version. this one seems fine:

    http://illest.net/~will/serialosc-1.1c.mpkg.tar.gz

  • cool. this one is working straight out of the box :) on my arc anyway.

    thanks again dood.

  • not working for me. and for some reason in activity monitor it is listing serialoscd 3 times and if i quit the processes they come right back.

  • Do you have monome devices plugged in? serialosc will spawn more versions, one for each device.

    Just installed, gonna restart and test.

  • yes, i'm plugged in

  • worked for me :)

  • Ok I started and I have 2 serialoscd's in my activity monitor. One of which is idling around 80% CPU!!! (spiking up to 96%)

    That doesn't seem right....

  • I'm wondering if I can fry an egg on it.

    http://rodrigoconstanzo.com/monome/serialoscd.png

  • yikes. mine are idling at nothing. @rodrigo is it at least working for you?

  • thats weird, mine is idling at 0% too.

  • It does work, but the CPU usage is brutal.

    So with this 1.1 serialoscd there should be 2 instances with nothing plugged in? Or should there be only one?

  • mine has 2 with nothing plugged in

  • 2. the architecture has changed slightly.

    could you paste me the output of
    > ps aux | grep serialosc
    entered at a terminal?

  • Rodrigos-iMac:~ Rodrigo$ ps aux | grep serialosc
    Rodrigo 222 95.8 0.0 2432944 876 ?? R 12:20am 31:46.52 /usr/local/bin/serialoscd
    Rodrigo 528 0.9 0.0 2432768 592 s000 S+ 12:55am 0:00.00 grep serialosc
    Rodrigo 234 0.0 0.0 2443900 552 ?? S 12:20am 0:00.01 /usr/local/bin/serialoscm
    Rodrigos-iMac:~ Rodrigo$

  • This is on 10.8 on a 2GHz iMac

  • ps aux | grep serialosc
    tonymittica 250 0.0 0.0 2443900 536 ?? S 7:53PM 0:00.00 /usr/local/bin/serialoscm
    tonymittica 238 0.0 0.0 2432944 864 ?? S 7:53PM 0:00.00 /usr/local/bin/serialoscd
    tonymittica 434 0.0 0.0 2432768 592 s000 S+ 7:56PM 0:00.00 grep serialosc

  • brothertony, what device do you have? looks like serialosc isn't picking it up.

    rodrigo, that's a bit worrying. could you disable the background serialosc with launchctl:
    > launchctl unload /Library/LaunchAgents/org.monome.serialosc.plist
    and then run serialoscd from the terminal
    > serialoscd
    paste any errors you get, please.

  • sixty four. not greyscale.

  • ftdi drivers installed?

  • yes. something weird is happening. tried again and my device name showed up:

    ps aux | grep serialosc
    tonymittica 775 0.0 0.0 2434176 1024 ?? S 8:07PM 0:00.00 /usr/local/bin/serialosc /dev/tty.usbserial-m64-0310
    tonymittica 250 0.0 0.0 2443900 552 ?? S 7:53PM 0:00.00 /usr/local/bin/serialoscm
    tonymittica 238 0.0 0.0 2432944 876 ?? S 7:53PM 0:00.00 /usr/local/bin/serialoscd
    tonymittica 823 0.0 0.0 2432768 592 s000 R+ 8:08PM 0:00.00 grep serialosc

  • Ok that gave no error messages and now I have 2 serialoscd's with 0% CPU usage. I'm gonna restart in a bit to see if it loads crazy again (I'm in the middle of a big file transfer).

  • so, i just realized i never moved the zeroconf files into my max folder after getting max 6. problem solved. works. i love you. bye.

  • thanks for the release visinin. just installed it on 13" macbook pro 2.66 GHz Core 2 Duo with ml.

    restarted the computer and checked activity monitor, it shows 2 serialoscd's, both running 0.0%. only went up to 0.1% when plugging monomes in. it created a new instance both when plugging monome in and then arc. both were removed when unplugging the devices, leaving the original 2 serialoscd's in activity monitor.

    plugged monome back in and tested some max patches. serialosc was picking up both my monome and arc, leds and presses were working fine. didn't see any cpu spikes in activity monitor.

    typed "ps aux | grep serialosc" in terminal in case it's of any use:

    Last login: Thu Aug 16 01:12:10 on console
    Jamess-MacBook-Pro:~ jameswaterworth$ ps aux | grep serialosc
    jameswaterworth 197 0.0 0.0 2443900 556 ?? S 1:12am 0:00.00 /usr/local/bin/serialoscm
    jameswaterworth 192 0.0 0.0 2432944 876 ?? S 1:12am 0:00.01 /usr/local/bin/serialoscd
    jameswaterworth 285 0.0 0.0 2432768 592 s000 S+ 1:19am 0:00.00 grep serialosc
    jameswaterworth 240 0.0 0.0 2434184 1044 ?? S 1:13am 0:00.23 /usr/local/bin/serialosc /dev/tty.usbserial-m0000606

    also then unloaded it using launchctl, and launched it using "serialoscd" in terminal.

    Jamess-MacBook-Pro:~ jameswaterworth$ launchctl unload /Library/LaunchAgents/org.monome.serialosc.plist
    Jamess-MacBook-Pro:~ jameswaterworth$ serialoscd
    serialosc [m0000606]: connected, server running on port 17926

    restarted my laptop and tried the same things again. all happened the same way again.

    thanks a lot for the hard work visinin, all seems to be working fine for me.

  • Ok, after the restart the serialoscd are both at 0%

  • Working now for me with the latest, thanks visinin!

  • Thanks heaps visinin! Is now working fine with a 64GS plugged into a 15" macbook pro, updated from Lion to Mountain Lion.

  • > also tried unloading it again, and then launching "serialosc" (no d) in terminal, which produced errors i hadn't seen before. before installing this new release i was starting serialosc from terminal and either "serialosc" or "serialoscd" would work. sure this may not be an issue at all, but just tried it out in case.

    "serialosc" is 1.0 and under, "serialoscd" is 1.1.

    it seems like your installation was fine, though. there was no need for you to unload and manually run serialoscd.

  • why the extra d? isn't that likely to cause confusion in future?

  • stands for "daemon", pretty common among background processes (another example is launchd, for instance). it helps us differentiate between the process roles:

    serialoscd - main process, supervisor/manager role
    serialoscm - monitor process, waits for new devices
    serialosc - OSC servers for the individual devices

    the rename shouldn't be a big deal. most people do //not// need to know what the command is called under the hood. all of the messing-about-in-Terminal stuff is only for troubleshooting or for people who really know what they're doing.

  • so this is all good now?

    i'm gearing up to purchase a new macbook air for live/travelling/woods/nature music making. was hesitant after i saw this thread since all new computers from apple ship w/ mountain lion installed.
    (and mac, at first, not releasing that thunderbolt>firewire adapter for awhile, altho now they have)

    figured it would get sorted out eventually, but didnt want to spend megaloot for something that didnt have all the things i wanted on it sorted. (them shits aint cheaaaaap)

    thankssssssssss!!!

  • yep, everything's good now!

  • You're the man visinin. Now I just have to wait for Allen and Heath to get their shit together and I'm good.

  • I fear Allen & Heath will never get their shit together... Ghosts in the MMC machine. WTF?

  • @dm483
    Yea I have a xone db4, fortunately I can still obviously use it as a standalone mixer, I have an M audio interface that works just fine with ml, I route my audio into that and run RCA cables out of the interface into each channel on the db4. Lots of unnessessary bullshit but a descent workaround nonetheless.

    Maybe we can get it before Xmas :p