hopefully my last ? on setting up mlr on mac

  • finally trying to set up mlr on mac once and for all. i've been having some trouble getting playback and sound. for brevity, here's the rundown:


    osx 10.6.7
    max runtime 5
    monomeserial
    mlr 2.56

    group lights light up upon starting up mlr but the playback lights on the row don't. no sound, cpu usage doesn't budge.

    xsample installed in max externals
    grooveduck installed in max externals
    prefix is correct

  • Do you have the full version of Max 5 installed or just the runtime? I ran into this problem and installing the full version but only using the runtime solved it. Good luck.

  • ^yea i was gunna say that too, but u have grooveduck installed.

    anyway, i had a similar problem w/ mlr2.8 and was fixed by installed the full max, and then using the runtime.

  • boom. that's all it took!

    thank you much gentlesirs

    -- but goodness the buttons are responding to presses less than half of the time. i've reduced the vector sizes but it seems like the rows keep dying on me

  • u got overdrive on? it should be

    maybe a computer restart migth help?

  • the hardware is working seemingly ok in monome test?

  • overdrive's on. monome test works well and functions well on the pc and mac. i've mirrored the dsp settings on my pc to how it is on my mac. maybe i'll try this with a different audio driver/interface when i get back home. maybe that was the issue? i was using the core built-in driver

  • hardware issue has been ruled out. correction to the above post: monometest runs with over 90% accuracy on the pc and about 50% on the mac (based on toggle pressing each button one time)

    it's not an audio driver issue either

    i don't know if switching to serial osc on mac would help because i've never been able to get it to work, but i'm not sure what my options are.

  • Aaron, what processor do you have in your mac laptop? I was having problems installing serialosc on my old powerpc powerbook and discovered there are different zeroconfig files you need (since updated in the setup docs since my problem)
    I'm on a new Macbook Pro now, so I had forgotten about that...
    If it's not that then I'm not sure why serialosc won't play the game on your laptop. My old one was fine with Snow Leopard and the alternative zeroconfigs...