[FIXED! :)] serialoscd(1.1d) fails to install on intelcore2duo macbookpro(10.7.4)

  • Hey, so i tried it again, got the latest serialoscd installer that visinin posted:
    http://illest.net/~will/serialosc-1.1d.mpkg.tar.gz
    and it does the same thing as before(same as i posted in the "[?fixed?]..." thread).
    Steps:
    1) Downloaded the installer, Unzipped and ran it (while having Activity Monitor running in the background)

    Results:
    Immediately, I notice a 'ReportCrash' process pop up in Activity Monitor shortly after an extra 'launchd' process appears and then disappears, i go to inspect 'Report Crash' and notice something like this:
    //
    "/
    /System/Library/CoreServices/ReportCrash
    /usr/share/icu/icudt46l.dat
    /usr/lib/dyld
    /private/var/db/dyld/dyld_shared_cache_x86_64
    /dev/null
    ->0xffffff800b2c4ce0
    /dev/null
    ->0xffffff800b940260
    count=1, state=0x2
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043625_Macintosh.crash.plist
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043635_Macintosh.crash.plist
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043646_Macintosh.crash.plist
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043656_Macintosh.crash.plist
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043706_Macintosh.crash.plist
    /Users/resalien/Library/Logs/DiagnosticReports/.launchd_2012-09-08-043717_Macintosh.crash.plist
    ->0xffffff800d6b3a30"
    //
    i notice that it keeps creating crash reports because an extra launchd keeps appearing and disappearing(this instance of launchd keeps starting and crashing).

    i look up one of those diagnostic reports and see they all read the same(there's one generated around every 10 secs so i have many):
    //"Process: launchd [353]
    Path: /sbin/launchd
    Identifier: launchd
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [133]

    Date/Time: 2012-09-08 04:41:04.186 -0700
    OS Version: Mac OS X 10.7.4 (11E53)
    Report Version: 9

    Crashed Thread: Unknown

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

    Backtrace not available

    Unknown thread crashed with X86 Thread State (64-bit):
    rax: 0x0000000000000055 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
    rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x0000000000000000
    r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
    r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
    rip: 0x00007fff5fc01028 rfl: 0x0000000000010203 cr2: 0x00007fff5fc01028
    Logical CPU: 1

    Binary images description not available


    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 358
    thread_create: 0
    thread_set_state: 0"//

    i doubt i broke launchd because there's another 'launchd' process running in Activity Monitor all along(that first one seems to be there all the time, even without serialosc installed)... plus! i then delete the serialoscd file found in usr/local/bin to uninstall(at this point the crash reporter stops reporting crashes), and luckily i have an older .mpkg of serialoscd(1.1a), so i reinstall that old one and everything works fine again... but the latest one that visinin posted(also available from the 'setup' page doesn't seem to work... leaving me a bit stranded in terms of updating))

    little help? can anyone else confirm?

    MacBookPro, IntelCore2Duo, 3.06GHz, 4GB RAM, MacOSX10.7.4

  • Working fine for me on two machines:

    iMac, IntelCore2Duo, 2GHz, 4GB RAM, OSX10.8.1
    MacBookPro, IntelCore2Duo, 2.4GHz, 8GB RAM, OSX10.8.1

  • Sorry Raja, late to the discussion, but I only updated serialosc(1.1d) on my core2duo iMac //after// installing Mountain Lion. At that price point, it's a worthwhile upgrade however. I hope the upgrade goes well for you (I know I'm teaching my grandmother to suck eggs here, but I always back up prior to upgrading my os anyway)
    ;-)>

  • (all this egg talk reminds me of 1:20 into this video http://www.youtube.com/watch?v=7sn1RUjbL1g)

  • hey raja... I'll be moving to the bay area in about a week. Perhaps I'll be able to help you trouble shoot in person.

    One solution that could work would be to install from source. I've made homebrew formula's for both libmonome and serialosc, which makes the process somewhat simple. (After you install xcode and homebrew)

  • That being said... have you tried doing it on a fresh install? Perhaps you have some weird things going on with your particular system causing an edge case

  • this mountain lion update has fucked a lot up.
    i'm hearing reports from other developers that code compiled for 10.8 //will not run// on 10.7 and below, which is ridiculous. i am looking into this.

  • still not sure why the crash is happening in launchd.

    raja, can you hop on IRC?