Reaktor serialosc?

  • Hi,

    can someone give me a hint how to lid up the led with reaktor and serial osc? I could get key presses with but assigning led messages with /monome/grid/key but monome/grid/led/row does not work. Maybe i set something wrong in the reaktor setup? Is there a tutorial?

  • @raja

    we're beta-testing it. it's done, just got to make sure the last bits are ironed out.

  • hmm, sound complicated. How can i get the send an receive ports? Why is it not 8000/8080 like in the old versions?

  • just got it to work with monome serial. Looks like serial osc is still buggy and difficult to set up. Cant understand why it is recommended to use...

  • is it possible that the new offset value that is required for row is the problem?
    monome/grid/led/row offset? but how is the syntax. The documentation is not so good. MonomeSerial is working with 256/led_row. But i would love to connect my 40h too...

  • I don't have a reaktor version atm, but maybe this helps !?!
    http://flipmu.com/work/software/

  • a little bit. I got /grid/led/set working wich could lid up single led´s but /grid/led/row or col is not working. Documentation says offset is needed but i am not sure how the syntax is right. Cant find any examples. Anyone?

  • prefix/grid/led/col 5 8 255 is not working out of reaktor for some reason. prefix/grid/led/set is working. Strange. Still dont get it.

  • i am on a 256. No, doesnt work. Is there a working, easy to understand max4live patch wich uses col and row with serialosc? its really strange cause it works with monomeserial...

  • i am on osx 10.6.8 And used the latest Version of serialosc 1.2
    hope you find a solution. For that like i said col/ row works fine with monomeserial and reaktor so the problem had to be serialosc or my lack of knowledge...
    btw. there is a 30 demo of reaktor on the NI Page.

  • intelcore2duo

  • @malte

    I tried the 'nomeStateSerialOSC.ens' when the Flipmu guys first released it as I'd hoped it would free me from dependence on Max/MSP (which I don't have a clue about/and in my opinion is super-flakey on PC), but I could not get any osc from serialosc into Reaktor and so gave up.

    One of the problems I noticed was the prefix. The 'nomeStateSerialOSC.ens' patches expects '/box', but my 2011 Monome puts out '/grid'. Monomeserial used to let you put in your own prefix, but serialosc does not have the option. I can't use Monomeserial on my Monome as it's a 2011 version.
    I also tried 8000/8080 ports but got nothing.

    Any tips on getting OSC to work on Reaktor/Serialosc???

  • the default serialosc prefix is "/monome" instead of "/box" (so a complete message would be "/monome/grid/led/row"). you can change this by sending "/sys/prefix

  • i dont think that its an reaktor problem cause as i said monomeserial works perfect. Even stuff like /frame works. row/col too. I just like serialosc cause it can handle more than one monome. I tried to get col/row to work in max4live and this doesnt work either.

  • thanks that you looking into it. I happy with monomeserial for now. i have to look into it, how to handle more than one device.

  • okay so i downloaded reaktor but have no idea what i'm doing. malte, if you can give me a reaktor patch that demonstrates your issue i'll look into it.

    @raja:
    > is there anything different about the way led/row handles messages as opposed to led/set?

    besides taking different arguments? nope.

    again, note that, under serialosc, "/grid/led/row" takes **3** arguments, "x_offset, "y", and finally "row bitmap".

  • the messages you posted above are fine. please post a reaktor patch so we can investigate this further.

  • ok, here is a simple test ensemble. Hope this helps.

  • no, i think its an reaktor issue. Is there a way serialosc could "check" if floats arrive and convert them to integers? So, when you send a message from reaktor it would be /box/grid/led/row 0. 0. 255. convert it to /box/grid/led/row 0 0 255 monomeserial must have a feature like this somehow...

    @RajaTheResidentPoser thanks for the find. i am on the reaktor beta list i will ask the question why it just send floats... :)

  • oh yep /col and /row definitely don't do the automatic float -> int conversion (but the other commands do). fixing this.

  • k, this is fixed as of the next released version of serialosc (1.2b or 1.2 final, whichever gets released).

  • of course conf files aren't going away. can you get "localhost" to work there instead of that number sequence? that should definitely be a string.

  • thanks visinin for the fix. could you post this version to check?

  • and, it works in plugin mode, it says...

    maybe that's why no osc in Ableton...

    NI did it for them ;)