serialosc 1.2

  • hello everyone. we're getting ready to roll out a new version of serialosc that has some serious under-the-hood changes from the previous release. there are a few other pieces of this release that will happen shortly as well (updated serialosc max patch, some new docs), but i want to get the code out there as soon as possible for people to test.

    in a nutshell: everything should work exactly the same as it already does. there are some new features and a little bit of tidying up, but everything should just work. if it doesn't, that means i broke something, and you should let me know.

    for mac:
    http://illest.net/~will/serialosc-1.2a.mpkg.tar.gz

    for windows:
    http://illest.net/~will/serialosc-1.2a.exe

    as with all other alpha/beta software, probably not a good idea to install right before you leave for a show (lest you tempt fate), but this should be a pretty safe upgrade for everybody.

    that said, here's what this release definitely fixes:
    - arduinomes on windows
    - tilt on windows with new devices (i.e. ones from this summer)

    if you install this, please post in this thread. i need to hear from windows and mac users both, and it's cool if you just post something like "os x 10.6.8, working here" or "windows 7 64-bit, working here" or "windows 8, everything is broken". just let me know please.

    happy testing! docs coming soon for the new discovery stuff! this is that release!
    -w

  • wow, thank you!
    tilt for 2012 grids that's what I've been waiting for!

    I am on vacation now and will test it as soon as I get back.

  • OSX 10.8.2... everything seems to work acording to the test files but trying to rework my config per my recent thread - http://post.monome.org/comments.php?DiscussionID=15224&page=1#Item_4

  • Presume this release will also cover tilt for the 2011 upgrades?

  • @teeeny

    yep!

    @raja

    everything will still continue to work just as it did (except for "/sys/mode", fuck that guy).

  • what was 'added'?

  • cant uninstall and its not working on my system. is blocking monomeserial wich was working fine. Is there maybe a version wich is not for nerds? I dont want to hack in terminal commands to get something to work...

  • @malte

    what system are you using mac or pc? Did you install all the zeroconf / bonjour stuff? monomeserial will not work at the same time as serialosc, but you can use the monomeserial bridge or pages to get access to legacy code

  • lllliiiiinnnnuuuux

  • @ visinin- appears to be working fine on my macbook pro (Ivy Bridge Processor - non-retina display) 2.3 GHz Intel Core i7, most recent OS update.
    @ Raja - Used your test patch, it works great, no need to "press to connect" - the patch just recognised when the grid was plugged in or unplugged (just like your cool boing type app that I will always treasure and one day hope to add to if I ever get to buy Max). Just to let you know however, once I opened another max patch (in this case Party Van) and quit out of it, your test patch did not work again until I restarted Max. I don't know if this is expected behaviour or not...
    Cheers!

  • i am on osx 10.6.8. I dont have zeroconfig stuff installed cause i dont use Max/msp use Reaktor. Still cant get the col and row stuff to work. Hope there is a solution.

  • looks like the new version did not install a prefs file where i can look up the ports? I really think it would be cool to have some kind of gui for the people that just want to plug in and play. monomeserial looked a lot easier to me. Especially for new users.

  • ok, after another restart the pref´s where there. But still no way to get row/col to work in reaktor. /monome/grid/led/col
    led/set works.

  • @ Raja - //don't use that anymore// - ahhh! Heartbroken! (But I understand...damn!) Thanks Raja.

  • I'm maybe misunderstanding this "everything should work exactly the same as it already does" comment so let me check.

    1. if I uninstall the old serialosc and install the new-improved 1.2 ver, all max/msp apps will operate as they did before?

    2. I can now uninstall Quicktime, bonjour/bonjour print services and remove the three zeroconfig files from the Max/MSP externals folder?

    and also

    3. Due to no zeroconfig/internet conflict on Windows, I should now be able to use the Monome and go online and the same time?

  • Win 7 32bit, serialosc 1.2a (no internet) -

    connects to max/msp apps through zeroconfig/bonjour all ok

  • @RajaTheResidentPoser thanks. Would be nice to see it work.

  • @joechip:
    yes, zeroconf is now optional as of this release. if zeroconf is installed, it will work as it did before, and if it's not, only the new OSC discovery API will work.

  • with the new release, is it going to be possible to uninstall and reinstall the program without conflicts? i remember not this march that just passed but the march before that when i first got my 256, i wasn't able to use it for a month or 2 because serialosc wouldn't work and i was stupidly uninstalling and reinstalling it way too many times. that would be such a relief.

    won't be able to test it out until tomorrow, but tomorrow i'll give the new version a os x 10.8 test and see how it goes.

  • I'm frustrated. Installed this update, reboot. Nothing happens when I connect my walnut 128 to monome test. Installed the old version (1.1). again, nothing. Was working before.

    And where is that uninstall script mentioned in the docs?

    Please help.

    osx 10.6.8

  • tried "sudo rm /usr/local/bin/serialosc", terminal says no such directory

    after running the installer (both 1.1 & 1.2) and reboot, terminal doesn't understand "serialosc"

    update: serialosc 1.0 is recognized by terminal (after unplugging my device)
    my device shows up in monome test, but cannot connect to it.
    (max 6 with zeroconf objects in the right folder)

  • windows 7 32-bit, working like charm.
    my new app is coming.

  • if you're running into problems with this or any other serialosc release, //please// don't start uninstalling and reinstalling other versions. it makes it difficult to figure out what version is actually installed at any given time.

    if you run serialosc in the terminal while it is also running in the background, it will break. if you don't understand the previous sentence, **do not run serialosc in the terminal unless someone specifically asks you to**.

    @l00p:
    please reinstall serialosc 1.2a. reboot, then open a terminal and type

    > pgrep serialosc

    please paste me the output of that command, and also tell me how many monomes you have plugged in at the time.

  • terminal says: -bash: pgrep: command not found

    one monome plugged in. (walnut 128)

    yeah, lesson learned.

  • for mac open a terminal and write

    ps -u $USER | grep serialosc

    you will get an ouput like

    501 204 ?? 0:00.01 /usr/local/bin/serialosc
    501 277 ttys000 0:00.00 grep serialosc

    (the numbers in the first two columns will be different)

    try also the command
    which serialosc

    and check if you get the same /path/to/serialosc. if you have different outputs, you have several versions of serialosc installed...

    pat

  • thanks a lot for your help, much appreciated!

    my grep output seemed to be ok (was checked from vis). still couldn't connect. yesterday I figured out a pseudo fix, I simply started griddle.. and oddly enough, I could connect (also directly). working, hooray!

    now. today again, I couldn't connect, which led me to the conclusion it's a max problem, because I reinstalled max6 demo earlier (after uninstalling yesterday, initially installed last week, was using max5 before)

    BUT: It is blocked again with every reboot... starting griddle somehow unblocks something at a low level... but as you have noticed I don't understand much of that stuff (yet). any ideas?

  • @priesen "try also the command which serialosc"

    do you mean $ which serialoscd ? (that path seems to be fine)

  • OSX 10.8.2 working great.

    had one cpu spike yesterday. top version of serialoscd listed in activity monitor was around 95%. i was messing around testing the new discovery api unplugging and plugging in the monome, also had a zeroconf patch and it appeared as monome i2c once. later unplugged the monome, closed max and noticed that the fan was still running fast, then checked activity monitor and noticed the spike. restarted the computer and all was working fine again.

    think it might not be enjoying the cheap usb hub i was using that time. it might not be getting enough power, causing it to drop out and disconnect.

    otherwise the discovery api is great. just finishing a serialosc abstraction for max/m4l to replace the zeroconf one i had been using. will post it up if anyone is interested. quite like keeping it all osc and not having to include the extra zeroconf externals in apps.

  • @myr
    the CPU spike was with serialosc 1.2a?

  • yes, with 1.2a.

    been working on it again tonight, lots of unplugging and plugging in the monome, trying to reproduce it and haven't had any cpu spikes though.

    thanks for all the hard work visinin! got my app automatically discovering monomes on startup, or when they're added and removed. very satisfying only having to click click open an app and then have everything lit up and ready to go.

    posting the max abstraction i've been using and a little example patch in the serialosc 1.2 OSC discovery API thread if anyone's interested.

  • @myr:
    okay, i'll keep looking into that though. that's a very nasty bug.

  • I've installed serialosc 1.2a.
    I'm on OSX 10.7.5.
    zeroconfig files are still in place for both Max 5 and MAx 6 Runtime.

    Some notes from me.

    $ ps -u $USER | grep serialoscd
    501 471 ?? 0:00.01 /usr/local/bin/serialoscd
    501 3471 ttys000 0:00.00 grep serialoscd

    I'm testing w/ Myr's AND RajaTheResidentPoser patches and only get the "auto connect" behavior w./ Raja's _serialOSCAPI_ patch (this thread). I have to click "Connect" for Myr's SerialOSC Monome Example patch (also only works in Max 6 runtime, no device shows up in the dropdown in Max 5, from this thread - http://post.monome.org/comments.php?DiscussionID=15231&page=1#Item_15)

  • @emergency of state

    the patch was written using max 6. there's objects in there that won't work in max 5.

    the abstraction was written to be used in m4l, it uses live ui objects and other ui objects with their parameter mode enabled.

    the device-id textedit object has it's initial value set to my monome id. so when the abstraction is used in m4l the device id would be saved with the set, and it could be used to auto connect.

    it wouldn't be too hard to make a max version with the m4l bits taken out. i'm just checking it integrates properly with my m4l app routing/spanning/switching device, which this abstraction is a part of. after that i'm hoping to make a plain max version of the abstraction and routing/spanning/switching app.

    does the patch automatically connect and disconnect when you unplug the monome, after you've set the device id and clicked to connect once?

    if you want it to automatically connect at the moment you can edit the Myr.M4L.Monome.SerialOSC.maxpat. find the device-id textedit object, open the object inspector and set it's initial value to the device id you want to connect to.

    my idea with doing it by device id is so that it doesn't just connect to any old monome as soon as it's plugged in. you link each instance of the serialosc abstraction you load to a specific monome device the first time you load it, after that every time you load the abstraction it will look out to see if that device is added and check to see if its currently connected, connecting whenever the device becomes available.

    the abstraction itself doesn't auto-connect until it has been sent a connect message (or had the connect button pressed). after this it gets the list of devices and starts listening for added or removed devices. in the example patch a connect message is sent to the abstraction on load with a loadbang.

    i could make a version where it automatically generates a port number, checks for devices and listens for added or removed devices as soon as it's loaded. but i think this could lead to issues later on, for instance if you had one monome plugged in and doing something. you then load another version of the serialosc abstraction to connect another monome and the first monome might be taken over and loose it's connection to what it was doing.

    also noticed some problems with the v2 example patch version i put in the other thread, a fixed version is on the way soon.

    lots of testing again today, no more cpu spikes, but i have had 4 ftdi laptop forced restarts.

  • nobody run anything in the terminal unless specifically i ask //you// to, okay? in almost all cases (i.e. emergencyofstate's) it is wholly unnecessary.

  • is there a way to get the latest version from github or is it just for compiling you own...

  • yeah, it's just for compiling your own.

    i know you want to play with reaktor, man. i just don't want to release a whole ton of versions. i only want to do one more (maaaaybe two if things are bad) testing version before i'm happy with a final one.

    i haven't forgotten about you :)

  • On Windows 7 64-bit:

    I uninstalled serialosc 1.0, installed serialosc 1.2, tried tests with my monome 64. It did not detect the Monome.

    Rebooted the machine, tried again. This time it detected it. So far so good, but you might want to warn people to reboot the machine after installing.

  • I tried, and still no detection of my monome.
    This is still the same problem I never fixed,
    New computer no monome
    Old computer monome works

  • @4aron: did you post a full list of your setup in another thread? what's the situation?

  • Mac OSX 10.7.4


    Everything seemed to work fine but it totally breaks mlrV2. Is there a way to revert back to 1.0? Thanks

  • I've been tracking the thread that 4aron started. I'm seeing the same problems, perhaps. but there is a different data point. while networked in a local wireless (with homegroup turned off) I see the gs64 device and its entries running on an older vista machine. (natch they disappear when i close network access). see attached list from the bonjour browser windows program. interesting that it shows the localhost ip from the vista machine in the string that bonjour browser displays. I wonder if serialosc is looking at 'localhost' or using 127.0.0.1 on this asus machine?

    I include a png of the usbview utility which ftdi mentions in their 'toolkit'. the monomes flash leds on/off as expected. beep when added. ftdi driver is from http://www.ftdichip.com/Drivers/CDM/CDM20824_Setup.exe . I have tried removing and reinstalling. the device shows up as a serial com3 port. The default speed is 9600. I tried 19200 as well. am thinking of trying an older ftdi driver, today. (note that usbview shows alerts for current overage from two of the right side usb 3.0 ports which occured while testing the hub on different physical connections - there are 4 on this machine.)

    The machine is a new asus g75vw. windows 7 sp1. all usb ports are 3.0. tested on different usb connections. tested with a usb 2.0 hub (reports adding 2.0 usb drivers) then monomes. tested with gs64 gs128. I see some reports of "several" insertions being required for usb recognition when I use google to check for problems.

    I am using an account with administrator priveleges to work on this problem.

    using windows firewall (turned off for some tests). explicit udp 5353 allowed. explicit all incoming allowed. since I'm seeing the external vista machine, i conclude the firewall is not the problem (it is opened up for incoming, which is different than the default)

    i have tried serialosc 1.2a serialosc 1.0. I use the uninstall script and see the files disappear. I stop the servers before reinstalling. I have tried rebooting after uninstalling, then reinstalling from a scratch boot. I have tried stopping bonjour, which asks about serialosc dependency) with serialosc. then restarting bonjour, serialosc in that order.

    pages 20a45 does not see the device using either apple or jdns discovery. (pages does see the vista machine device, if network is up.)

  • forgot to show what monome test and max 5 window display

    attached png

    -----
    edit: off at peet's, the wireless oracle says "MTAP"...

    hope that's not spinal ;)