Is there a way to know whether an mk logic board is working without Drivers hooked up

  • I have an mk logic board that I flashed with the most recent firmware but no leds light up nor do any button presses register in any apps or monome test. My mk has a serial m0000013 and shows up as monome i2c in the serialosc and in monome test properly shows as 16x8 as I flashed it. Ideas?

  • not a good sign that it shows up as i2c, for an mk.

    try this. turn off serialosc first:

    launchctl stop org.monome.serialosc

  • Will this work on Windows?

  • @tehn, when I stop serialosc and try to use the bootloader method you mention I get:
    avrdude.exe: stk500_getsync(): not in sync: resp=0x81

    avrdude.exe done. Thank you.

    make: *** [16x8] Error 1

    Not sure what is going on. I tried stopping serialosc and using the other protocol mtest you attached and it automatically identifies my device on Port COM2 (Windows 7 32 bit) but I get no response from pressing buttons or clicking on the grids or any of the message boxes. I have an AVRISP mkii here that I can use as well.

  • Another question, I was using the older version of serialosc before. Was it serialosc that was seeing the mk as an i2c device? Or was that because of the serial format. I followed the firmware instructions but used my avr to program the firmware before and I figured since it was seen as an i2c that at least some part of the 325 must be working properly. My task manager shows a new serialoscd instance running when I plug in the device, but I can no longer see any device in the serialosc window. I switched to the new serialosc 1.2a beta to try it.

  • i2c isn't strictly related to the serialosc version. the mk is possibly not sending its init data on startup, ie not reporting the grid size, so serialosc doesn't know what to do with it.

    did the chip program properly the first time? that sync problem likely indicates serialosc isn't off.

  • When I used Atmel Studio 6>Tools>Programming Devices to program the tilt/mk16x8.hex file it said that it flashed and verified fine. Should the monome (mk) do anything like light up a test row or anything when it is plugged in?

  • Okay, a couple of things. For one I feel like an idiot.

    So I stupidly was hooking up the connectors the way they are in the bottom pic on the assembly pic totally forgetting that that pic was wrong!

    Second, I was using a serial m0000013 so m#######, and I recently noticed that vis showed nine # in the serial. Changed that and now the old serialosc version sees my mk as an mk 128.

    Now for the real problems. Question, might I have screwed up the chips somehow with the backwards wiring? My monome is flashing all kinds of craziness with lights flickering anyway they want and they seem to be acting like two keypads not in standard horizontal format but rather parallel to each other. Did I screw up the 325? Or perhaps the 2219 or 138/165 chips?

  • Okay, so I replugged things. Now it's really screwy. It read for a minute as mk 128, now is back to reading as i2c. shit.

  • @tehn,

    I've been wrangling with the AVRISPmkii and Atmel Studio for several days. first seemingly getting a successful programming of the atmega325p with firmware, but things running slow, then realizing I need to set the fuses for low to 0xff but having an error where studio couldn't read the device. Wondering if on PC I am supposed to set the interface speed and com port baud rate differently. I finally did set the baud rate slow and managed to program the device, it took a few minutes. Finally got the device to read and managed to set the fuse bits. Now serialosc correctly picks up the device as an mk128 (16x8) but only the top row of buttons lights or correctly registers presses for each 8x8 keypad. Any idea what might be the problem? I did originally have the driver interface cables wired backwards, is it possible that this ruined the 165 and 138 chips?

  • likely did not ruin the 165/138.

    i don't imagine you have an oscilloscope...

  • Actually I do. Not very versed on it, but if you have ideas I am ALL ears! Would so love to get this working right. Can't figure why the atmel programmer has problems reading the chip though. Kind of figure that might be an issue with Windows and COM ports or some other thing.

    At any rate, if there is something I can do with an o-scope to figure out the issue. It's just strange because the top row works on both keypads, but nothing else. Sometimes there will be random cycling of leds all over the place, and it doesn't appear to react to presses, just starts going crazy. It is reading as an mk now though.

  • see if the 138 is sending pulses out of all 8 rows or just one. you're trying to figure out if this is a hardware or firmware issue.

  • Will do. I assume that the 138 should be sending out pulses regardless of whether it is using any apps?

    Also, should I be changing the Port Settings Baud rate on the Windows virtual com port when programming the chip? Might this be why I can't seem to access the chip for reflashing? I was able to flash the 325 with the updated firmware, but then when I tried to reflash it with the tilt firmware (to add an accelerometer) I kept getting an error in atmel studio that it couldn't read the device id. Even with avrdude, I would get an error saying that it couldn't find device "usb". FTDI still sees the chip however. Serialosc is stopped when I did those.

  • @tehn, I haven't had a chance with the oscope just yet but was wondering if using a 74LS138 wouldn't work despite having the same truth table and being pin compatible.

  • you don't need to change the baud rate.

    ls is fine probably.

    post the flash error here.