Pages - no LED feedback with mash2

  • Sorry for opening an extra thread for this, but i hope it gets more attention this way than in the mash2 discussion.
    It also seems to be rather a pages-related problem then mash2's.

    So basically I was able to use mash2 via pages, but i don't have any led-feedback from mash (pages's mod-button is lighting up & the pattern recordes, but no mash-related buttons/leds).
    Then I can use mash2, start clips and hear them, mash tem up, record stuff, use the pattern recorders, pitch up down, reverse, ...
    but i have no led feedback.

    I'm using a monomeserial-to-pages-to-mash2-connection.
    Mash2 binds to a random port everytime so i have to change pages' OSC-Out-Port everytime manually to whatever port-binding my mash2-max-windows shows up with. I leave page's OSC-In-Port at '8000' (tried 8080 as well).

    I guess here lies my problem:
    How can I determin which ports are used by mash2? In the mash window i think i can just see the OSC-out-port binding, can't I?

  • try ctrl m from mash focus?

    the max window

  • it's strange: my max window tells me:

    binding to port 17812
    zeroconf.resolve: No such object
    zeroconf.browser: No such object
    binding to port 32166
    binding to port 11410

    I guess i can ignore the zeroconf.*, wasn't that the stuff used for serialosc that is now handled by pages.

    the last port listed seems to be mash's current OSC-IN-Port, as i can trigger mash when that port is set as pages OSC-OUT port.
    i tried the other two listed ports as page's OSC-IN ports, but that doesn't work (=no leds flashing).

  • 'binding to port 17812' is always listed first.
    when i start pages with osc-in port set to 17812 before mash the max windows tells me:
    binding to port 17812
    binding to port 17812 unsuccessful.

  • you should be able to use pages external app in serialosc mode -- this will create a device in mash's serialosc dropdown called 'extapp-blahblah-portnumbers' something like that. try selecting that and clicking connect. have pages external app use whatever default random ports it comes up with so you don't step on mash (i think mash is reporting the port it's listening on, not the port its sending on). you will need to click update preferences once in external app to make it register the zeroconf service.

    edit: also install the max zeroconf externals

  • thanks for the tips, i will try them all.
    but in the meantime I have found a workaround by using [[https://github.com/nightmorph/monome|nightmorphs static serial osc maxpad]] instead of mash2's original one.

    Thanks again!
    I'm jamming!!!!!!!!!!!

  • word up! whatever works man! :D