AVR ISP programming on MAC - help

  • I just got a 2008 MacBook and am hoping I can get this mk working on it since windows wasn't hooking up properly. I have firmware flashed on windows and the ftdi chip on board is picked up with my serial. I thought I'd try reflashing the firmware on a mac in case something was up there. The leds flash from one corner out when I plug in the device, but I get no other response and serialosc isn't seeing the device. I also don't have that serialoscm process showing in my Activity Monitor. I have two serialoscd processes.

    What I am wondering is how/what I should use to program devices on the mac. Atmel Studio seems to be only for the PC. I have an AVRISPmkii

  • use crosspack.

    links on these pages:

    http://docs.monome.org/doku.php?id=tech:mk:flash
    http://docs.monome.org/doku.php?id=tech:arc:flash

  • if you're getting a light burst it seems like the firmware flash is ok, along with the LED driving pins.

    since the ftdi detects, most of the pins are ok.

    the main problems that remain are the interconnecting pins between the two chips. these need to be checked thoroughly.

    the last issue is serialosc, but this has been working without issues on the mac (once rebooting).

  • When you say interconnecting pins between the two chips I assume you mean between the ftdi and atmega325 chips right? COntinuity testing should suffice I assume? I have retested an arduinome on this mac and it picked up fine. Happy to have a Mac now, even if it is 2008 (was my wifes, she has a new MBA now and likes it very much). I have 8gb of ram and a 128 GB ssd on the way to upgrade this machine. If continuity is in question I'll check it all.

  • yes, continuity testing. good to hear the arduinome works, which should mean your software is ok, yes?

  • yes, i think the serialosc is okay, though i may have messed that install up. that is why i want to know how to do an uninstall and/or know where the components are located so i can make sure my 1.2a install is clean. i am likely to upgrade to mountain lion tonight. i have 8gb ram and an ssd coming to reinvigorate this 2008 as it is well kept and works well.

  • listen, this is why i want you to send me an email.

    if there //is// something wrong, i would like to figure out what it is. the 100% CPU usage bug in particular is something i've been hunting for a while, and if you can reliably reproduce it then i am very interested in figuring out what's going on.

    here's why it sucks for us when people start blindly uninstalling and reinstalling: if there actually //is// something wrong, and uninstalling and reinstalling fixes it, //we have no idea what was actually wrong or what could have been wrong//, so even if it's our fault (likely), we can't fix it.

  • Update, checked all the connections (chip to chip) and they look good, continuity where it's supposed to be and not where it's not. I changed the serial to a shorter one and get something but still no population in the serialosc window (running the 1.4 test suite you linked on the serialosc1.2 thread). Something is up though. Using the 1.4 suite I can't get the arduinome connecting anymore. I assume 1.4 is using the newer serialosc.maxpat and I don't need to replace it with the new maxpat(2) you posted...?

  • what's your serial now?

    the new 1.4 test package is complete.

  • serial is m000001. Using a command visinin suggested with serialosc unloaded (serialosc /dev/tty.usbserial*) I see it connected on a port but still not in the serialosc.maxpat window in the grid test. I also can't connect my arduinome there either and it also shows using /dev/tty as connected on a port.

    It is strange because I was able to connect the arduinome before when I couldn't get the mk to connect. Then I changed the mk serial but still no drop down. I'm using the 1.4 test suite. Windows platform doesn't work for me either. I get new serialoscd processes in the process monitor, but nothing in serialosc.maxpat. I'm waiting to update to Mountain Lion on the mac to hopefully help visinin figure out what is going on.

  • the serial needs to be 8 digits including the m. so add a zero. but i doubt that's the only problem.

    will and i are working on a script to test the install to ensure everything is correct.

  • That sounds good.