serialoscd drop-outs

  • Hello,

    I am experiencing problems with the serialoscd running consistently. What happens is that every now and then it simply stops running (it seems), as I can not see it in the Mac activity monitor, and the Arc4 does not show up in Max menu.

    I started having these problems since I received my new arc4. Never noticed anything like this happening with just the 128 grid.
    The only way I can restore functionality is by restarting the laptop, and that does work every time. It is, however a problem, and I would like to solve it.

    Does anybody have any suggestions, feedback, advice?

    My key questions are:

    —— What is causing the serialoscd to stop working?

    —— Is there some way to re-activate it without having to restart?

    —— Is there a certain way one should be closing a session using monome or arc in max?

    (By this I mean that there is a clear procedure that is required to establish connection with the controllers, but there does not seem to be a "clean" way to close it, other than simply closing Max patches and/or quitting the program.)


    Here are the details of my setup/system:

    monome grid 128 walnut 2012
    arc4 2012
    Mac OSX 10.6.8
    Max/MSP 5
    (Also have Max 6 runtime installed)
    I have set up monome by installing:
    FTDIUSBSerialDriver_10_4_10_5_10_6_10_7
    serialosc-1.1a
    zeroconf-max5-osx

    When serialoscd is running, everything seems fine. The problem I described always presents itself the same way: I work in the studio for hours with no problems. Then close the session, turn everything off. Next day when starting things up, I realize that the arc is not showing up in Max, check activity monitor, see no serialoscd. This does not happen every time, but with some consistency every few days. Restart, and things are back up.

    I am enclosing a few screen grabs showing the status in Max and activity monitor when things are running, and when they are not.

    I am hoping that with your help I can make this go away!
    Thanks for your help in advance.
    Sincerely,
    p.

    449 x 275 - 38K
    560 x 301 - 52K
    690 x 208 - 41K
  • you seem to have everything properly installed.

    when you say shut down, do you mean completely shut down the computer? or just sleep it?

    it sounds like serialosc simply isn't consistently loading on boot, which is strange.

    next time serialosc isn't loaded, open a terminal and type:

    launchctl start serialoscd

    and it should load. let me know what happens. if this doesn't work then i can debug further.

  • What I typically do is unplug the powered USB hub (with the grid and arc plugged in the hub), and put the laptop to sleep.

    So, the failed loads I describe do not happen on reboot, but after sleep. The reboot of the system is the only way I observed that consistently DOES initialize the serialoscd.

    @tehn :
    A question to you, tehn, is: should I try to install the 1.2a version?

    Meanwhile, next time it does not start I will try to revive it with the terminal command you suggest.

  • try it without the hub. hubs are known to cause issues with monomes, especially since not all operating systems are smart enough to send USB wake signals after returning from an S state.

  • Hmmm.... but I need to use some kind of hub. Just too many things that need to be hooked up! I am using a powered hub, which should cause no problems.

    BUT

    i suppose i should give it a shot and see if the issue goes waway? It would be one way of eliminating the variables.

  • @tehn : well, it happened again. I woke my laptop back from sleep, only to find that serialoscd was gone. As per your instructions I typed the

    "launchctl start serialoscd"

    command in Terminal, which returned:

    "launchctl start error: No such process"

    So, I have restarted the OS, which brought the serialoscd back on... as it was happening before. Back to square one.

    I am very much eager to have the devices work reliably.
    What should my next steps be?

    Thank you for your advice.
    p.

  • try "launchctl start org.monome.serialoscd"

  • @visinin @tehn

    The serialoscd drop-out happened again, and I tried visinin's suggestion. Using Terminal:

    command:
    launchctl start org.monome.serialoscd
    response:
    launchctl start error: No such process

    Please advise.
    Thank you,
    p.

  • sorry for the typo.

    try

    launchctl start org.monome.serialosc

    something is going on the the launchctl setup-- strangely mine works fine, but i've had another report of it not working as expected.

  • @tehn

    the typo being the "d" at the end?

    if so, I will try this, next time the problem occurs (which so far means every other day or so).

    Meanwhile, if you don't mind me asking, is this procedure to make it possible to re-activate the serialosc without having to restart the computer? Or is the feedback from the Terminal going to provide you wiyh some useful information as to the nature of the problem?

    p.

  • @tehn @visinin

    Hi, So this morning the serialoscd was gone again, and I had a chance to try the command without the "d" at the end. This returned no "comments" in Terminal, and successfully launched serialoscd without the need for restart.

    This does not solve the problem though... Any thoughts on what might be causing these dropouts, and how to avoid/eliminate them?

    Thank you for your help and support.
    Sincerely,
    p.

  • we're working on it. glad the restart command worked.

  • @tehn @visinin

    "we're working on it."
    That is very encouraging to hear!
    :-)
    I am definitely looking forward to a trouble-free performance!
    grids and arcs are such amazing and beautiful products, and they definitely deserve a solid performance delivery, so they can shine and be recognized as the high quality standards they represent!
    Sincerely,
    p.

  • Aside: "It's a powered hub" is, alas, no defence...! There are good hubs and bad ones, regardless of power, and apart from my cardinal rule of Never Use Anything Made By Belkin, it's hard to know which is which except by trial and error. I have a cheap but really solid 4-way portable hub w/PSU by Kensington which will happily run two monomes and an arc at the same time. No other hub (including Belkin, D-Link or Saitek) will do the same.

  • @cassiel : great to have a specific reference by someone using it with monome products. I am ready to buy the hub you are talking about, can you please post the name and/or a link to the exact Kensington hub you found reliable? I would appreciate that, as I am eager to solve the dropouts problem.
    I feel a bit "in the dark" on what is the actual problem... From tehn's semi-cryptic "we are working on it" I am thinking this has to do with the serialoscd implementation. But there are a lot of variables involved, so things like a reliable hub are one of the variables I can actually address/eliminate myself...with your help that is! :-)
    p.

  • just for the record I am currently using this D-Link hub:
    http://www.amazon.com/D-Link-DUB-H7-High-Speed-7-Port/dp/B00008VFAF/ref=pd_sim_sbs_e_2

  • absolutely he should be on 1.2a.

  • very well then. I will update tonight and report back.
    @visinin : you did see my system specs (first post) and think I should be fine?

  • @laborcamp

    i'm running the exact same setup and have never had unresolved connectivity issues, so it doesn't seem like it's a hardware limitation, unless it's the usb hub. could well be a driver issue of some kind though.

    if you can stand to run without a few of your usb devices for a few days, you could try and plug the monomes in directly and see if that solves your problem? that would at least let you know if you're looking in the right area.

  • OK, so last night I downloaded the serialosc-1.2a and ran the installer file. I did not change anything else, and it seems that everything is running so far.

    If I understand things correctly, it is not necessary to run any de-install of previous versions, and that new one simply overrides the old one. Correct?

    I will be keeping an eye on this.

    p.

  • > If I understand things correctly, it is not necessary to run any de-install of previous versions, and that new one simply overrides the old one. Correct?

    yep, that's correct.

  • 3 days on, so far so good: no drop-outs since update to 1.2a, and everything working well. :-)

  • Well, ... a week later: no problems, and the serialoscd 1.2a going strong! :-)

  • Update (mainly for the record, and benfit of those who might be searching for related issues):

    More than a month without any problems. I think it is safe to say that update to 1.2a solved this problem on my system.

    Carry on.

    p.