help with monome setup?

  • Hi,
    I thought i had everything working on my new macbook air. The monome test app works fine, but none of the other apps like grainstorm or edw can recognize or connect to my arc or grid.

    party van just crashes when i try to open it. i'm using the latest version of serialosc.

    Any help would be greatly appreciated.

    thanks!

  • have you put the new serialosc patch in the max6 patches folder and deleted the serialosc patch from the grainstorm etc folder?

  • I can't find the max6 patches folder, isn't it supposed to be in the cycling 74 folder?

    i will delete the other serialoscs, thanks!

  • the setup page says max6/patches

    http://monome.org/docs/setup:mac

    (which has worked for me)

    but i think max will search the cycling74 folder as well

    yeah make sure you delete serialosc.maxpat from the app's folder - this forces max to search in the max6 folder.

  • Well i got a little bit closer, when i deleted serialosc from the edw folder i could ostensibly connect to the arc, but the buttons wouldn't light and it didn't control edw.

    still don't know where to find the patches folder in max 6.

  • on my mac it's just applications>Max6>patches

    i got my first arc 2 last week and to be honest i can't get edw to work. actually i can't get any of the arc apps to work with the new serialosc patch except the test patches.

    i think it's probably something to do with the way people have implemented the arc in the software as the messages to and from the arc haven't changed.

  • Here's a link to a screen shot of my max 6 folders. Shouldn't the patches folder be there?
    I opened up almost every subfolder and didn't see it.

  • Hmmm, i don't seem to have that.
    It's weird because all my apps including edw were running on my old macbook pro.

  • Maybe i need to use an older version of serialosc?

  • that's strange, but could well be simply because you've only got runtime installed — most people install the full version even if only to use the runtime.

    i'll update the setup page to reflect this — you really just need the serialosc.maxpat in max's search path, i was just trying to make a standardised location to store it, and "patches" was easier to type than "Cycling '74"...

    edit: i'll check out EDW and some other arc apps to see if they're working properly for me w/ the new setup

  • Thanks. Do you think i should try using an earlier version of serialosc?

    In the meantime, i'll install the full version of max and see if that makes any difference.

  • I deleted max runtime and installed the full version of max, then put serialosc into the patches folder of max. Same thing, in edw i can connect to the arc, but it doesn't work. i'll try some other apps next.

  • Same thing with grainstorm, it shows i'm connected, but nothing works.

  • i just tested edw & plates and they all function correctly with the new serialosc.maxpat

    if you're not getting any response from the device you probably just need to turn on the dsp. it's hiding in the bottom-right of both patches i believe.

    regarding grainstorm — it handles serialosc a little differently, so i'm currently going through to edit it to a functional form with the new serialosc. should be done in a couple hours.

  • grainstorm is now updated on the wiki and is tested as working with the new serialosc.maxpat object

  • no, i did turn on dsp in all the apps.

    Thanks for working on this!

  • still the same, i tested with the test app, which works perfectly, but grainstorm and edw both show my devices as connected, but nothing works.

  • have you tried turning the dsp off then back on?

    did you download the updated grainstorm version?

    on my setup after i select my arc and press connect (and turn on the dsp) it works instantly??

    does the max window say anything (press command-m)?

  • screenshot the not-working app?

  • Yes, i've turned dsp on and off, but i can try it some more.
    Yes, the updated grainstorm.
    I've haven't checked if the max window says anything.
    Screen shots when i get home.

    Thanks helping! I'm pretty lost with this stuff.

  • screen shot of grainstorm not working.

  • apologies -- i broke a bunch of things when updating it. it's checked and should be working now.

    http://monome.org/docs/_media/app:grainstorm:grainstorm_161.2.zip

  • thanks! i'll check it tonight.

  • It works! Thanks! although nothing else currently does.

  • do plates & electric dharma wheels work as discussed above? what else doesn't work?

    if there's something wrong with the patches, we'll fix them!

  • don't currently use plates, dharma wheels and party van don't work. here's a screen shot of party van. i can post error messages tonight.

    thanks!

  • Dharma wheels is fixed! Now hoping for party van...

  • Hi, trying not to be a pest, i know you're busy!
    I just had to bump for a fixed party van.