mlrv 2.4

  • very cool. having fun figuring this all out...

    is there an official TouchOSC layout for mlrv 2.3? i found this old forum topic (http://monome.org/community/discussion/10688/osc-mappings-for-mlrv-2.0/p2), but all of the DL links are broken...

  • i'll make one when someone buys me an ipad... haha

  • i'm having trouble getting the remote OSC option to work with TouchOSC. for some reason my OSC messages are coming into mlrV with "/o/" in front of them...

    the error looks like this:
    /o//mixer/1grp/vfader: no such object

    pretty sure this is an issue inside mlrV, because the printout messages in the TouchOSC test max patch (basic.maxpat) print out just fine, ie: "OSC: /mixer/1grp/vfader 0.992386"

    i don't own max...so i'm afraid i can't look under the hood. perhaps an OSC debugging option would be helpful? just to print values so people can make sure they are setting it up right...

  • can we get some instructions on how to use with the arc 2 please, thank you

  • Do I absolutely have to use serialosc 1.2? last time to downloaded 1.2 nothing worked at all with any apps? I am not techie or max knowledgeable at all, and am worried that the same will happen again?

  • yep, knew it,downloaded 1.2, really want to use new MlrV!! 128 doesn't show up in monome test. how do i uninstall other serial osc?

  • does this support using 2 launchpads at once, so i can pretend i have a 128? :P thanks!

  • problem solved

  • at fluxsta, are you using the newer serialosc.maxpat as well?

  • @galapagoose:
    Upgraded to 5.1.9
    Patch now open succesfully!
    I'll try to play some tracks tomorrow (haven't my walnut here...)
    Many Thanxxx

  • @shimoda yes had installed mate

  • @rawray
    the /o at the beginning of the osc addresses is normal — mlrv internally adds it to differentiate between MIDI (which needs to be scaled) and OSC (which is absolute, 0. to 1.)
    looks like there's an extra slash being added somehow?? perhaps try removing the "/" from the beginning of the osc message you're sending?
    note: the OSC handling has not changed at all since mlrv2.1 so that post you mention should still be relevant.

    @onetwoonetwo
    the arc is used via the +ARC tab only.
    1. load the tab
    2. enter mapping mode (in the mapping tab, or press option(alt)-m)
    3. click on the param you want to control with the arc
    4. press the relevant 'MAP' button inside the arc tab
    5. turn off mapping mode.
    6. turn dem knobs / have fun, experiment with the different controls, you can't break it!

    @fluxta / anyone not wanting to install serialosc1.2a
    there is an option to use the new zeroconf version of serialosc.maxpat
    it will work with previous versions of serialosc that only worked over zeroconf / bonjour
    download here: http://monome.org/community/discussion/15878/serialosc.maxpat-alternate-zeroconf-bonjour-version

    @three
    no support for dual launchpads. you'll need some other kind of bridging software to let your launchpads pretend to be a 128.

  • are there any other useful key commands in mlrv besides alt-m for mapping?

  • @galapagoose -
    TouchOSC automatically adds the "/", even if you manually delete it and save. this is also the OSC convention, so it makes sense. is there a way to error check inside mlrV to condition the internal OSC message? i can try sending OSC from another program to see if its specific to TouchOSC...

    @anyone
    has anyone successfully mapped external OSC messages (from a non-monome, non-MIDI source) to the different parameters with the mapping function?

  • @rawray7

    i just tried to use my touchosc mapping for 2.2 and its not working. max window says-

    /o//mixer/1grp/vfader: no such object

  • re:external OSC -
    I was able to get a volume fader directly mapped by deleting the "/" and sending OSC from Chuck, although Max constantly spits "inlet: list: wrong message or type". i've attached the test code for reference (change .txt to .ck and use miniaudicle).

    Even with the external OSC working directly, I'm still not able to use the mapping function to re-assign OSC messages.

    @elquinto
    so your touchosc mapping worked in 2.2? would you be willing to share it?

  • Does anyone have a problem where the pattern recorders don't work when rewire
    Tempo slave is set to on?

    I

  • @rawray7
    its really basic(just 5 faders), and its for the iphone not ipad.

  • @galapagoose, rawray7

    i found what was making osc not work.

    sprintf \; /o/%s \$1 should be sprintf \; /o%s \$1 in (p OSC)

  • @rawray
    apologies — @elquinto is right. i must have added that slash for some reason when i was adding the 'grid over osc' function (so you don't need an 'in-between' app to make a fake OSC monome). i'm just putting a couple other minor fixes together before we re-upload.

    also the 'mapping' functionality is only for midi / monome presses. when using OSC it is expected the sending device formats the messages to send to different in-app parameters (ie. you have to change the address your OSC fader is sending — this applies to mapping as well).

    as a positive aside, i just realised what was causing the ARC tab to create glitches in the audio (damn UI objects!), so that's fixed now, as well as high-volume OSC not causing dropouts anymore.

    @elquinto
    no other 'useful key commands', but let me remind you that the MAPPING tab accepts computer keyboard mapping as well as MIDI & monome

    @pekopeko
    looking into it now. per a suggestion on the cycling74 forums i changed the tempo patch to use the dedicated rewire transport object but that probably broke the 'tempo slave' patterns.. will try and find a fix.

  • i've been getting a lot of 'zl: fifo unknown mode' and 'bpatcher: bpatcher: error loading patcher EMPTY' in the max window when i launch mlrv. don't know what thats all about. just thought i'd mention it.

  • are the osc commands for 'grid over osc' documented anywhere?

  • @elquinto
    i'll clean up those messages (they just left over junk)
    'grid over osc' is explained on the release page (link in the 1st post of this thread) — it's buried toward the bottom of the 2.3 updates. might take some trial and error to get the layout right, but it is possible.

  • i think i just noticed another bug with the pattern recorders. i'll record a pattern of presses on a particular row, then try to press buttons on that same row as the pattern is playing back, but the presses won't trigger most the time. for ex. if i try to hit a pad (on that same row) 1/16th after one of the pattern's presses it will never trigger. other rows in the same group trigger fine. this only seems to happen when quantized

    edit- this happens with the variable pattern recorders too

  • another bug: i've had this weird thing happen a few times in loop mode, where i press a button it will light up but not move or trigger any sound. sometimes its a button on a different row that lights up. i can easily replicate it if i record a pattern on a row, stop the pattern, stop the group, then hit a pad in that same row. (pad lights up but doesn't move and no sound) i've had this happen in other instances too, but could't nail down what caused it those times.

  • @galapagoose -
    thanks for clarifying re:mapping. could you guys provide a list of all of the OSC controllable parameters and their addresses? the one included in the download (mlrv-2.2docs.pdf) is missing quite a few.

  • @tehn, visinin, or whomever makes this decision. Would it be possible to keep the older version of serialosc (zeroconf/bonjour version) and it's serialosc.maxpat available for download (with disclaimers that it is the depricated version). It seems that for whatever reason it might work better for some. Ideally it would be nice to have everyone on the new version but for some it doesn't seem to work (works on my mac but not windows still). Just like to have it available to download is all.

  • @shimoda
    have you tried the new zeroconf maxpat? i've been handling the transition to the new 'global' maxpat arrangement, and want to make sure it's working for everybody and not causing more trouble than it's worth.
    http://monome.org/docs/_media/app:serialosc:zeroconf-serialosc.maxpat.zip

    @rawray
    the easiest way to find the precise osc address (and to avoid me making typos), is simply to enter MAPPING mode in mlrv, and click on the UI object you want to control. the OSC address will be displayed in the MAPPING tab above the table of current mappings.

  • Thank you galapagoose, for the time you took to create this time vampire. I have one question and one observation. Is there a way to have the mpattern.maxpat tab load on startup, so it doesn't have to be selected and remapped every time. Also there seems to be a problem with the original pattern recorders. It's like they're at a faster tempo than the set, or the first press is delayed, I can't really tell what's gone wrong.

  • Has anyone had success controlling this app with an emulator such as Nonome? I'm just curious. It works great with the Launchpad on its own, but I'm looking for way to control multiple apps and/or retain some of the Launchpad's functions in Live with mlrv running.

  • Bridog if you have max for live, I'm using my launchpad with Monomodular. You can run up to 16 apps at the same time. Pushing user1 and user2 at the same time puts your launchpad in monome mode. While your in monome mode just press the session button, and your back to full launchpad mode. You can switch back and forth freely.

  • @james
    all the tabs are recallable in your preset file. generally you'll make a file with a number of songs for a performance in one file and that will load your particular tab & mappings arrangement etc.

    however, if you want to change the default behaviour (ie. what happens everytime you load mlrv) you just need to save your preset file as "preset.json" inside the mlrv folder and overwrite the file there.

    this is because the default load state is just an mlrv preset file with a predetermined group of tabs loaded. personally i have a copy of mlrv which has my live set saved as 'preset.json' so all i have to do is open that copy of mlrv and my whole live set is ready to go (mappings and audio driver and monome auto-connect included).

  • thanks for the reply galapagoose, yeah I've overwritten the preset file to open exactly the way I like it, but for some reason the only thing that doesn't stick is mpattern.maxpat tab. That tab is always empty when it starts up.

  • ahh think you found a bug. can you tell me whether the 'clear' button or any other objects in the mpattern tab are saving? if the only thing not saving is the actual pattern buttons themselves then i have a solution.

  • no, nothing is saving, I need to remap the buttons, and the clear button each time.

  • i never thought of that preset.json trick, cheers.

  • Thanks for all the hard work galapagoose!!
    Got it working with pages, thanks phortran!
    ...not really a mlr guy but I had fun for the last two hours... ;-)

  • Tested a few hours now...Happy user!!!
    Great reverb, sample managment works great, ...
    I even thought it might be interresting to report these:

    - When mapping (i'm using my 128 with a nanocontrol), it always cancel the group 4 stop !?
    I have to remap it everytime...

    - Record automation only work with Monome mapped function...Is this supposed to work with every controller??

    - Experiencing some trouble with button presses;
    I was already experiencing this with mlrv 2.2...(had to push 2 or 3 times to make the button work...Always tghe same button...)
    I thought it was a hardware problem, but this behavior got really worse with the upgrade..
    I have sometimes to push 10 times on a pad to make it work...
    I searched for thread, but nothing (i think!)
    Someone know about this??

    Thanx again for this wonderfull patch! Every track played in it sounds better...The best pitchmodifier i found :-)

  • @reno Khart

    Are you absolutely sure it's not a hardware problem? I had the same issue and it turned out to be the silicon button pad. I replaced them and it's working fine now. Is that one button discolored at all?

  • 2012 walnut 128win 7 serial osc 1.2 monome works w pages and other max apps so appears to be a bug akin to @elquinto i copied serialosc.maxpat into mlrv 2.3 and i got my monome 128 to show up but when i load a sample and press the button to start it...it lights the first 16th but plays nothing and stays frozen there

  • @FLCON
    I'm not absolutly sure...I'll try a more scientific method tomorow :-)
    I know it's not the right thread, but did you buy the silicon pads directly at Monome?

  • 2008 64 OSX 10.6.8 serial 0sc 1.2 i have the same problem as @1nvisibleman, the first 8th is lit and responding with MLR2.3, but there is no output whatsoever despite having the correct driver selected and using the proper settings.

  • just wanted to say thanks for all the great work on this.

  • @james
    Thanks for the suggestion. I'll check out Monomodular. You're able to control mlrv with it? That's mainly the problem I'm having. I can't get mlrv and the emulators to talk to each other.

  • @1nvisibleman
    i got it to work,i forgot to place the xsample file into the msp-external folder. Works like a charm now, awesome work guys its everything i dreamt and more.

  • @Bridog
    yeah, I've got the same issue with nonome+mlrv. Can't get it working together.

    When I'm choosing launchpad in mlrv directly - it works just fine, but I prefer emulating monome64 with nonome, because I'm using launchpad in ableton and using user 1 page for playing live some keys.

  • working like a dream @slawww yes xsample was the culprit ...i hadnt copied the xsample object mapping and the help file, just the xsample.mxe...blown guys/gals with how great this works

  • Is there a way to have a signal from an ableton drum rack going into the sample input of mlrv.
    So I can drum a beat on my pads and then have it to my side on the monome for instant
    mash/rearrangement?

  • @pekopeko
    yes, using soundflower. however this is not possible when rewired.

  • @galapagoose

    in regards to the quantization of slices, what is it quantizing the release times by? (1/64, 1/32, ect) does it change depending on the global quant.?

    i know you say this is the final release and no feature requests, but i have an idea i want to throw out there, as hopeless as it may be. a pattern retrig button (mlr_cyst style) + standard on/off mlr pattern button behavior- press pattern retrig + a pattern button to retrigger it's last recorded pattern) i like the idea of pattern pause/resume, but i feel the tap+hold behavior is adverse to the "fast and syncopated" nature of mlr. anyone that prefers the current tap+hold method feel free to chime in...