mlrv 2.4

  • @elquinto
    i've been fixing up a few things with the recorders over the past weekend. have added classic pattern mode (ie. press to arm, records for set time, press to stop & clear) as an option in the setup page.

    also, added an arrangement whereby you can use the 'clear' function from the MPATTERN tab to clear and reset the built-in pattern recorders. that way you just use the 'clear' button as a shifter and press the pattern you want to clear. also, there is an undocumented feature of the 'clear' button that if you triple-tap it, all patterns are cleared.

    i've fixed the 'slices sounding different when playing back' issue (the releases were being quantized twice), but still having some problems with the unquantized standard pattern recorders which is why i haven't posted it yet. also, fixed the 'click' at the beginning of a new mpattern.

    should have it uploaded in the next 2 days.

    re: quantization of slices, the releases are quantized in the same manner (with the same tick) as presses. logically i don't understand how it would be possible to do it otherwise.

  • @galapagoose

    had sent you a message on another thread, but all up and running now mate, thanks for your input, great working with the new 2.3....it works a treat

  • @goose
    hey thats great you got those things fixed. i appreciate the added clear button and being able to use it with the fixed length recorders, it really helps a lot! just sayin' a pattern retrig button would make re-triggering patterns twice as fast and starting/stopping patterns would be a super quick on/off action. i know youre probably not going to be interested in implementing anything like this, since you said yourself you don't really use pattern recorders, but it would make a big difference for people that do use them, imo.

  • Hey guys,

    @galapagoose or whoever can answer it:
    What is the "'slices sounding different when playing back' issue"? Is it just what it sounds like?

  • @FLCON
    it is what is sounds like. samples when set to 'slice' mode, sound different when 'recording' pattern, as opposed to when that pattern is 'playing' back. anyway - i've fixed it. just need to test some final things.

    @elquinto
    this is why the software is available for free and provided open-source. i strongly encourage you to edit your own version and make that public. if it's a 30second job i will have a look, but don't count on it.

  • hey, no problem. just wanted to throw the idea out there in case you hadn't considered it.

  • just a quick point -- isn't the 'retrigger' the same as double-tapping the current 'normal' arrangement? as in, tap once to disarm, tap again to re-engage at the start?

    i guess that doesn't work with the 'classic' mode you were talking about??

  • no, pattern pause/resume doesn't work with the classic mod i did, because on the second tap it clears, as in mlr 2.x. by 'retrigger', i was referring to pattern re-engage(currently double tap) . using the clear button you added makes the need for the classic mod less necessary, but i was thinking why not have the re-trigger as a shift key instead of clear? (shift+a pattern button would re-engage it's last pattern) that way pattern recorders could go back to standard classic on/off. if you hold down shift, you could tap the hell out of a pattern button and it would re-trigger as fast as the quantization allows, which would be quicker than the double-tap. also, shift+group stop=group mute? sorry, i'll let u focus on priorities, but those were my thoughts.

  • currently pattern recorders have 4 functions- start, pause, re-engage, and clear. basically what i'm suggesting would work the same, but is just 3 functions- start, stop, re-engage(with shift+pattern recorder) variable length recorders have the extra press to set length, so currently theres 5 functions, with the shift+pattern recorder to re-engage it could be 4.

  • Has the documentation been updated? I'm trying to figure out recording audio to sample in real time, but there's not really any coverage on it in the doc.

  • Also, I cant get any playback. I'll paste the errors I'm getting in the max window:


    these all appear many times followed by a "binding to port..." message.

    xgroove~: xgroove~: No such object
    zl: fifo unknown mode
    bpatcher: bpatcher: error loading patcher EMPTY
    /o0: no such object

  • You maybe haven't installed the xsample into the correct folder as outlined in the help folder? Add the externals to their appropriate max folders. I am no expert in these things however :-)

  • I didn't have the .help file installed. so I tried it, but still had the problem. I also tried changing the name of the file to ".maxhelp" to match all the others, didn't work.
    I'm using max 6.1 and the new serial osc per the directions.
    I've restarted max everytime I've changed a file around.

  • my max 5 runtime program doesn't have a "map-help folder" Should I stop using 6.1 and find a full download of 5?

  • @yorke
    are you running in 64-bit mode? if so, xgroove will not work and hence the program won't work. otherwise, perhaps you have to copy your xsample.mxo file into the max6.1 folder?
    if you're not editing the patch, you don't need the help file.

  • @galapagoose
    I checked the bit mode, its not in 64. the xsample.mxo has been in the msp-externals of max 6.1
    any other suggestions?

  • I'm going to download max 5 and see if I can get that to work.

  • Has anyone else had any issues with Rewire tempo slave? As soon as I enable it, the BPM drops to 1 and the audio cuts out (Presumably because it's playing at 1 BPM).

    Changing the rewire master (Ableton) tempo does nothing. As soon as I disengage 'rewire tempo slave', the BPM jumps back to MLRV's native BPM and is fine.

    Specs:
    Windows 7
    Max 5.1.9 (32-bit)
    Ableton 8.3.4 (32-bit)
    Monome 128 Grayscale

    1113 x 377 - 138K
  • @makingthenoise
    I haven't had that specific issue, but I have experienced weird issues with rewire in general. At times mlrv won't play groups and other times the bpm jumps quickly between ableton's bpm and what I'm presuming is its own. This creates a weird reverb effect and the pattern recrders won't work. I assumed it was a midi piping thing, though.

  • @mtn
    sounds strange, i transitioned the rewire timing over to the [hostsync~] object per suggestions on the c74 forums. perhaps this isn't working properly on windows?? anyway you could test that object?

  • @makingthenoise ive had that problem a couple of times, restarting everything and rebooting seemed to fix it. I had abletons tempo mapped to a knob and in mlrv you could see the rewire tempo changing but as soon as you stopped turning the knob the tempo in mlrv would go back to zero.

  • "@yorke
    are you running in 64-bit mode? if so, xgroove will not work and hence the program won't work. otherwise, perhaps you have to copy your xsample.mxo file into the max6.1 folder?
    if you're not editing the patch, you don't need the help file."

    Browsing through this discussion, it seems MLRV 2.3 isn't supported in 64bit mode? I'm using memory heavy vst's in my live set and was really hoping to start using 64bit when I switched to live 9. There aren't any work arounds or patch files I can drop? It seems so close. Everything loads and recognizes... just no playback on the loops.

  • no, mlrv is not supported in 64-bit because it relies upon a 32-bit Max external for the sample playback. cycling '74 has yet to provide details on how to update old externals and until then it will not be possible unless you re-write the 'plx.maxpat' to run with the standard 'groove~' object in max (which was avoided because it occasionally caused max to crash).

  • i tried to rewire mlrv with ableton but there is no option to select max msp from the "audio from" drop down in ableton. has anyone experienced this already and can help??

    i have rewire mode set to on and the driver automatically changed to ad_rewire..

    osx 10.6.8
    mlrv 2.3
    max 5.1.9
    live 8.4

    thanks!

  • @galapagoose
    A while back you said youd fixed some stuff and should have it posted soon, just wondering if
    you managed to get it ironed out. just to check the current version is 2.3002 yeah?

    I hope you know how appreciative people are for the work thats gone into this, must be easy to forget with constant harassment from the likes of us, sorry bout that.

    cheers

  • being uploaded currently — just waiting on % (he's a busy professor!)

  • @makingthenoise The rewire tempo problem can be fixed by switching the yellow tempo slave button on and off. just worked it out

    If I can get pattern recorders working with rewire I`ll be all set.

  • @galapagoose
    i just tried 2.4, and i noticed the bug i sent u the video of is still there. one way to replicate- "record a pattern on a row (loop mode), stop the pattern, stop the group, then hit a pad in that same row. (pad lights up but doesn't move and no sound)" p quantize_queue? also when re-engaging a pattern (only tested in 16n loop mode) it seems to re-engage on the second press in the pattern, not the first.

    i really appreciate the added pattern re-engage button, but its not working with "old pattern mode". (there's no real point in using it with normal pattern mode) this is obviously my fault since i did the "old pattern" mod. i've been trying to figure out how to get it to work. no luck yet.

  • I'm having a really strange problem with my windows 7 computer when it comes to the pattern recorders. I've been trying to figure it out on my own but no luck. My XP computer runs the pattern recorders perfectly, just my windows 7 comp. is the problem.
    I arm a pattern to record 4 beats, start pressing, but it doesn't start to loop until the 5th or 6th beat, and even then it's looping at a faster tempo than the set.

    This only happens with mlrv pattern recorders, all other mlr's work perfectly, again my xp machine doesn't have this problem only my main win 7 machine.
    I've reinstalled max 5, reinstalled the xgroove stuff.

    Any hints would be greatly appreciated. If it wasn't for my stupid computer this app would be the height of fun for my music making needs, so thanks.

  • i will try to check to see if my windows 7 system has the same issue

    could it be a 32/64 problem?

    i'm quite new here, but its seems most of the nice people who make apps use Macs and so it is difficult for them to test on a PC

    i'm also trying to learn maxmsp, but even in my short experience it seems quite Mac focused as some of the externals/or patches users make don't have PC versions

  • Thanks, I'd love to know if any other win7 users have this problem. I've been using monome apps with win7 64 for over two years now, I've never had a single problem that wasn't solved with a little tinkering and a couple questions.

  • I'm also having problems with the pattern recorders
    In mlrv2 they were fine but I find now they are glitchy with lots of
    Clicks etc. the timing seems really unnatural are the presses being quantized?

  • Also can someone explain the mpattern tab. I feel retarded
    Couldn't get much to happen apart from feedback!

    From reading through the thread mr goose said that the pattern
    Behavior has been the same since 2.2, @elquinto
    Have you noticed what I've experienced?

    Thanks

  • Re pattern tab Worked it out sorry

  • in case anyone was wondering, I figured out my pattern recorder problem. Sample rate at 48k, pattern recorders get crazy, at 44.1, smooth as butter. (coulda sworn i tried that earlier, but today, i switched back and forth a few times and every time same result) Is this only a win7 problem?

  • i actually don't care if it's a win7 problem, as far as i'm concerned it's NOT a problem, cheers galapagoose, and everyone else involved in this last version of one of the coolest apps on the list.

  • this may be off topic, but is there any plan to include support for other grid controllers like the Quneo or Push?

  • @newmodernscience
    no, sorry. we're looking at this as the finalised version — no more feature additions.

  • @galapagoose & @pekopeko

    I confirmed that hostsync~ reports the bpm (in samples per beat) on Windows. I've tried clicking 'rewire tempo slave' off and on and I still have the issue where MLRV sticks to 1BPM.

    If it's working on Windows for pekopeko then I suppose it's something with my setup. Weird.

  • @makingthenoise sorry i should have said im on osx,
    I've resigned to sticking with2.19 release as I cant get my old set to play nice with 2.4.
    somethings just off, cant get the timing right. been driving me nuts over the last week.

    @galapagoose is there any major difference between the two versions that would cause this?
    im confused.

  • 2.4 fixed my problems~! but now I'm trying to record an audio clip, and when I press a button to play it back, I get
    xgroove~ - can't find buffer 0file
    Any ideas?

  • @pekopeko
    what kind of timing issues are you talking about? i have only changed a few small things in the press handling with the intention of making the pattern recorders more accurate... hope the normal use case hasn't been affected as a result :-((

    @yorke
    i haven't tested the audio recorder of late.. could well have broken something with the 'refer by filename' (so you can have multiple 808kick.wav files)... do pre-loaded samples work fine?

  • I got some crazy thing going on. When I drop a sample in the name changes but it plays the same one that was previously on that one? Anyone experienced this?

  • @fluxsta ive had that a couple times. I had some missing samples after moving the files that were referenced. Ive found for fixing small issues like rewire with the older release either a reload the set or click yellow buttons again sorts it out.

    @galapagoose i cant really describe easily but I could make a video with the same sample played through the two versions one after the other. but unless your the one doing the presses it might be hard to see the issue.

  • Have there been any reported issues w/ versions above 2.219 straight-up not working? mlrV doesn't even acknowledge my 64 (built March 2009 kit) after that update. I've tested all versions this afternoon, it's real weird.

    Also, just as a catch:
    The 2.4 download .zip off the parallelogram site contains 2.3004? Says 2.3 on the splash screen?

    But otherwise, my issue seems to be that there's a hardware communication misfire, somewhere, or something. Couldn't find a thread about the problem. Anyone?

    OS X 10.6.8
    Max/MSP 5.1.3

  • ^ This issue is addressed on page one. My apologies, stay tuned..

  • --I've been at this for more time than I care to admit, & WHERE I'm at is 'still where I was, earlier' (see above post), w/ the exception of having now installed serialosc 1.2, which is hilarious because the .zip actually contains 1.1--this whole process is giving me a headache..

    My monome works fine w/ mlrV 2.219 but I'm simply trying to get 2.4 (or 2.3004, of course) running. To do this I've got off MonomeSerial, installed serialosc 1.x, ran check-monome.command, trouble-shot & got my five 'Ok!'s, but the monome_test_3.maxpat test completely fails to even see my device. Nothing is listed. Incidentally, mlrV 2.4 (or 2.3004, of course) does not seem to see my device, either.

    I'm just frustrated.. might anyone have any suggestions where to go from here?

    Upgraded to Max/MSP 5.1.9

  • Try max 6 full install but only use the max 6 runtime that is included

  • @c4lc:
    your issue is not with mlrv it's with your installation of serialosc

    when you open the monome_test_3 does it look like the screenshot on it's applications page? http://monome.org/docs/app:monome_test > specifically, is there a grey rectangle up the top with a 'connect' button? if you don't see this box it means maxmsp can't find 'serialosc.maxpat' which probably means that you copied it to the wrong place.

    have you just installed max6.1? if so, you need to copy the maxpat into BOTH max6 and max6.1 folders

  • humdidum....trying out the new version....plus serialosc 1.2 on xp

    Loading a sample and then pressing any button makes the max window say:
    xgroove~ - can't find buffer 0file

    I've copied the xsample files to the correct folders..... Everything worked ONCE after a restart, now nothing???

    Pressing a button on any row lights up a button on the first row in the corresponding column, also the top right button lights up and stays lit

    Any ideas?