Problem with 0sx 10.8

  • Hi,

    I got a self-build arduinome. I've used it with no problem for about two years on windows 7.
    Now if I connect it to my mac, I read on the arduinome serial "No device available"

    I downloaded the Arduino software to see if it recognize the device, but I have the same problem.

    Anyone has an idea? Driver?

    I didn't find any discussion about this problem over the net.

    Thank you


  • did you follow the newest setup instructions? try 1.2a

  • As far as I can see this, this is due to the way, OSX 10.8 enumerate USB devices.

    On earlier versions of OSX, the arduinome devices where mounted as /dev/tty.usbmodemxxxx-xxxx (depending on the serial number you flashed onto the arduino board), but with 10.8.x, this is no longer the case. Devices are now mounted as something like /dev/tty.usbserial-00001234, with no obvious naming pattern.
    As libmonome looks for naming patterns (device names containing a40h), it just cannot find your device.
    (@tehn: correct me, if I'm wrong.)

    My arduinome is flashed correctly (UNO R3), but flashing different serial numbers has no effect on the way the device is mounted.

    I run my arduinome on OSX 10.8.5 without a problem, but I had to change some code in libmonome and recompile serialosc.
    (Details here:

    I can send both files over, if you like.

  • i believe there have been issues with the uno in the past, as the original arduinome was designed prior to this edition.

    glad you worked it out. if you'd like to submit a patch via github, i'm sure we can work it in.

  • Done (hope I did it right ... pull request submitted ... otherwise tell me)

    That's just a simple workaround in device.h, but works for me like a charm and as long as it does no harm or leads to overdetection of non-monome devices, it might be a solution to keep the arduinome alive.

  • overdetection is actually a big problem. it was causing cpu hits so we'll have to take a close look.