help setting up monome for the billionth time

  • I dunno, i can never get anything to work when it comes to my monomes.
    My ssd drive crashed and i'm trying to get things up and running again.
    I'm on 10.8.5
    Downloaded ftdi and installed, downloaded serialosc 1.2a (1.3 wouldn't install, but i'll try again),downloaded Max, put serialosc maxpatch in the patches folder.
    The test app can't find my gs64.

    Any suggestions?
    Once again, i'm ready to sell my stuff off for cheap. Why can't this just work?

  • I was able to install serialsoc 1.3, but the results are the same, the test app can't connect to my grid.

    Fuck. fuck, fuck, fuck.

    Any help would be greatly appreciated. Fuck.

  • hey blungo2, i will try to help you. can you direct me to the test app that you are using? let's try and figure this out.

  • assuming you are using this:
    http://monome.org/docs/_media/app:serialosc:monome_test_3.maxpat.zip

    open max/msp and go to 'Options' up top in the menu bar. next go to 'File Preferences...'
    is the folder that you placed serialosc.maxpat into contained within the search path?

    if it's not. add a path to the folder that contains the serialosc.maxpat that you placed.

    if it is. have you ran 'check-monome.command' from:
    http://monome.org/docs/setup:troubleshooting

    after running check-monome.command, can you paste or screenshot the report? that will further assist us in helping you.

  • Thanks karaokaze! I'll try everything tonight when i get home.

    Thanks again!

  • i'd definitely run the check-monome.command which spots any issues!

  • Had a similar problem some time ago. Reinstalled serialosc but that didn't help. What got things going again was opening the serialosc.maxpat in Max/patches/. My monomes showed up there. I connected and quit Max. After this I could connect again in other patches ...

  • I had to do the same as you ithkaa, but on a windows 7 elitebook.

  • Right now i'm just using max runtime, although max is installed. I don't see options or file/preferences.

    When i run monome commands it says serialosc.maxpatch NOT OK, so i guess that's the problem.

    I guess i need to start the 30 day version of max and do what was suggested...

  • Weird, i started Max and tried to add a path to serialosc.maxpatch, but it's greyed out and i can't click on it. I wonder if i'm somehow downloading a corrupted version of the file. Is there a trick to downloading it?

  • It worked! Thanks all for the help, it's greatly appreciated!

  • Is it weird that it worked even though i couldn't add the patch to my path in max?
    i think this is all alchemy...

  • I did add the path in Max, as you said, or at least i tried to.
    I did put the patch in the right place initially as well.

    I may have multiple instances of something though. When i go to connect to Party Van, it shows two grids and two arcs.

  • hi there, i have just got a monome again after about a 3 year hiatus and am having a similar problem to the OP..i followed the install procedure but my device doesn't show up in serialosc.maxpat or monome_test_3. i ran monome command and get OKs for the first four items but a 'no such file or directory' error on #5, when its looking for serialosc.maxpat in my Max/patches directory..but its there! this is really baffling to me..does anyone have any suggestions where to go from here?

    i should mention that i am on Mac 10.8.5 and also that i checked the path in Max's File Preferences as suggested above (its there) and also tried opening serialosc.maxpat directly but i get the same result - no device to select. i see the monome on my USB device list however in 'about this Mac'..

    thanks for any help!

  • i installed 1.3 first, then tried installing 1.2a though i don't know where it installs to so not sure which is running now ? 'monome commands' does say serialosc ok so i know one of them must be running.

    it sounds like the exact same problem blungo2 was having so i'm wondering if there was anything specific he did to get his monome to connect? kind of a bummer to have a nice monome here with no way to use it!

  • I did go back to 1.2a

    I think what made things work was attempting to add the path in Max (not runtime).

    "in any case, i'd also try what ithkaa suggested(open just the serialosc.maxpat, connect up to your monome and arc there, then close it out(quit out of Max and all), and then try other apps)."

    I did try that a couple times, but that was before i had attempted to add the path to serialosc.maxpat, i'll give it another shot.

    I'm just happy things are working!

  • @blungo2: glad to learn your issue has been resolved!

    @meatus: can you post the report from check-monome.command? as karaokaze said, you should be able to install seriaolosc1.2a over your previous installation, but i'm not entirely certain how that works. as for the 'no such file or directory' message, that's typically been a matter of sensitive typing for me. sometimes i forget that there's a space, or that the directory is called 'Max 6.1' or something along syntactic lines.

  • sure, in the attached screenshot you can see both the finder window showing that serialosc.maxpat is in the max 6.1/patches subdirectory and that monome commands says no such file or directory exists.

    i did try to put it in the cycling '74 directory but that didn't change anything. i also created a new path to the patches directory in Max but again that didn't help.

    thanks for the help, i hope i'm not missing something really obvious..

  • Did you restart after creating the path to serialosc.maxpat?

  • yeah i've restarted like 10 times

  • you're right, when i removed the space in 'Max 6.1' the error from monome.command went away so now i have 5 OKs and it says 'MAXPAT: installed 6.1' but its still the case that the monome is not seen by serialosc.maxpat. it doesn't show up in the monome test patch either. so i tried installing all the files to another computer (a macbook running 10.7) and there i was able to connect so i know the monome is good but i cannot get it to connect to my computer. i really don't know what to do next..

  • ok i ran the 1.2a installer again, monome.command gives me 5 oks but this is what i get when i try to run monome test (attached screenshot).

    is there a way to do a complete uninstall/re-install of serialosc? i really don't know what else to try..

    i really do appreciate the help in trying to get this sorted though! this is a great community here

  • seems time to figure out if the hardware is working!

    do you get a startup burst animation?

    open a terminal, type:

    ls -lrt /dev | grep tty

    what does it output? you should see something like tty.usbserial-m2039439

  • i tried just opening serialosc alone but the result is pretty much the same as with monome-test in the screenshot above (no device to connect to, error in the max window says 'bad argument for message set). the error only appeared when i clicked the 'connect' button to become 'change'.

    i do see a little lightburst on the monome when i furst plug in USB, i assume this is the animation? when i run 'ls -lrt /dev | grep tty' in terminal i get a whole list of messages that look like 'crw-rw-rw- 1 root wheel 4, 127 Oct 11 23:31 ttywf', maybe 40 or so,
    then a few Bluetooth devices and then
    crw-rw-rw- 1 root wheel 18, 16 Oct 12 14:22 tty.usbserial-m0000582

    that's the same identifier (m-0000582) that shows up as monome in the USB device list in 'about this mac' so the hardware seems to be ok (?)

  • @karaozoke: i really appreciate all the help..unfortunately my monome is still not recognized but i would've been completely lost without the suggestions in this thread. the next thing i think i should try is a complete unistall/reinstall of serialosc but when i tried running

    'rm /usr/local/bin/serialosc'

    i get a 'file or directory not found' message. do you know what directory i need to be in when i run this (or where is serialosc installed)? thanks

    @tehn: i ran the file you linked to, the max window just says:

    'udpreceiver: binding to port 12008'

  • open activity monitor. do you see serialosc in there?

  • its weird, i don't see serialosc in activity monitor but then when i open serialosc.maxpatch it shows up for about a half a second and then disappears again (almost like its quitting/crashing?). i tried to uninstall/reinstall serialosc1.2a it didn't seem to do anything.

    again just for the record i am on a late 2009 imac running 10.8.5 and the monome is a 128 from the latest batch. thanks in advance for any other suggestions as to how to get things working..

  • sorry to report I'm still stuck here... just cannot get the monome to show up as a device with serialosc. i've had the monome for a week now and have spent many hours reading through this forum, installing/unistalling/restarting etc and still..nothing. i'm trying to be patient and not get frustrated but i really don't know what i'm supposed to do now.

  • yeah i got in touch with brian via email and he's helping me to try and isolate the issue. i'll make sure to post what we discover to this thread as well.

  • 10.8.5 is messing up permissions that were ok in previous versions. still figuring this out...

  • I don't know if this helps, but the other day i was having trouble connecting to my arc. My grid was already plugged in and working. I ran monome test and it said "serialosc_maxpat not ok". I just re-plugged in the arc and everything was fine.

  • the solution i think was

    chmod 755 /usr/local/lib

    hopefully this won't be a thing for others. we likely need to find a solution to mac os's overruling desire for us to use the app-store, which we never plan on doing.

  • yes that did the trick, thanks for the help everyone. yeah i'm thinking my next computer will be a linux machine too!

  • hi everybody,
    i'm completely new in monome's world...
    i got my first one just 1 week ago, but i have the same problem of meatus...
    so, can you be so kind to explain the solution, if there was one!

  • thanks!...
    i sent my message and i tried that code...
    or i tried it before... anyway now my monome is working!
    thank you so much!

  • Can't download serialosc 1.2a osx on this page http://illest.net/~will/serialosc-1.2a.mpkg.tar.gz,
    any suggestion ?