obo "glitch problems"... when i try to change patterns...using ableton clips or knobs

  • when i run obo i have glitch problems...this glitches comes when i try to change patterns...using ableton clips or knobs... someone can help me?

  • I've encountered this and not only just in OBO. Does your CPU spike whenever you change the Pattern dial? I think it's some sort of bug with live.dial...I'll try to look into it tonight.

  • Yes..my cpu becomes crazy when i change patterns on fly... And this make obo not able to play in a live performance...thanks

  • I did edit it in a Way that this wOrks.
    When i am back Home ill Upload it.

  • many thanks :D and i have to play a little more with your kolorit :D i am just waiting a freetime to understand better how to use it :D

  • @emergencyofstate @novasnoa some news please... I really need it

  • i couldnt find my edit, but i think i remebered what i did, works this better?

    15K
  • it work better when i launch patterns using live clips.. no glitch only if i set 2 bar clip quantization...and i cant see the line sequence on the first row..is it normal?

  • i dont know obo very well, but if the patterns are saved with a pattrstorage object its probably the cause to the dropouts - can maybe solved with "defering" in the right place.

  • Iftah , what do u mean with defering in the right place? My obo pattern storage is on my mac harddisk on the same folder of my ableton project

  • what about this one?

    19K
  • ive been having serious performance issues when recalling presets which involves bigger data sets from a "pattrstorage" object in m4l, which could be solved using a "defer" object if timing is not the main issue in certain cases

  • its not saved in patternstorage but colls, the colls are loaded into the matrixcontrol, at one point there its just a bit to much...

  • Wow u made me super happy :) its super stable... the first row run in the right way and am able to change pattern on the fly using knobs or ableton midi clips without glitches or cpu problems .... Thanks a lot novasnoa :)

  • @novasnoa: can you describe the change you made? I can think of at least one other patch that suffers from the same issue and I'd like to try the fix.


  • This is how i changed it





    <<pre>
    ----------begin_max5_patcher----------
    1831.3oc2btsaiZDFG+ZuR66.B06pCZNen20dSeHpphv1SRXqM3B3rY2U8cu
    CfsAGSBSF7vPqhRHYrw7M+36v+4.4Ge9SKBWk8hpHL3WB9ifEK9gtkE0sU0x
    hSMrHbW7Kq2FWT+F0+QYdxKqKy2Ft73quNa6gco0uLjcpw8wkqeJI8w6yUqK
    atDTLNBrLffkUGfTX8AFOBD7msmVd7NUoJ+dUZ7psppyDb5ESOrKIcqpr4Rc
    p0rCk51J+1dUykIbaRQY3xiGa+nyy95qrQ8mWyIW2N5TyIap6oYq9xcxv519
    mO+opi5CKmBPgI+mCTB6AUp5q5OgyPpT8RMFByCt6t6pnnZ84W7grzxhjuW2
    AffHvvPDKqgHkWyPQWDdAk.uIk5PlpKepF6012ulmD2du8RDA6AQHxH7lVms
    amJs7ZJE+f1GnW9fHs7o5sq89xxa5SfHNAB4rk5eCJHXHo523Tlfg0T5R+rq
    HKDHAQRs2IW6ixi35Shq+UDGTCbxaxX3Glim6.Oj+3p5FZ6ScPK2Afck5grb
    0zRVD.UG3OKfJ0dntONU0d06oiR30cTA7bGEipCW09Vc6oEOE2DGhe+99azA
    6zaHiHStpnH9QUOYnTEG1orI4jf2jSGvpueyZRv+l2iQ1kbJ32x1t4ijgRfr
    mRqNTVlk9d2zERTDoIsATe+mp8tqctq94PN2W0wWEm9X3Em0fcN3suF0F01.
    pUN.sr.AvQHJAfD5n.7.koPlBjag2.vAwL6iOTXUHiDBOUzApwz47Fx4QriC
    btJCRBRrBUBxYTIDcRwVEy8NNWuczVRZsPwpC1Bs9TMBInaO1JFmtwNvCKIQ
    PjlcxkAL3.QlinN7EhDoNHnqPUF7SP6JTooAiRqTzfz3.f.RIa9D1gHjauGz
    9b0dU5lw58fjmC8n.S8dbMt.2dbUM7wGNj1UxmcDqqCFkZMwd0vYGO0XRGDS
    B5EVx2kUP.QCSDjAzDBhtJ0N8FFN96pT0ywejJfHmnuJ9aAnQ5WIaGlAg3NA
    Vej3PpChCWMRLoC4N6OgsN5qFSKsGWndwE1QyuT1pr6UaRJuWilRUd5XyfA5
    LrN+NaSL1LFYP.hcVWQWMpyCz4fYy7mC.i02BqkfVMLQrN9DXcZrgzv+g.k7
    1Cp0Ya2dxMqP82iEZLzYnw41KBaYmusfdj9nGuUQdQ7ypM2qaU2GtWGVkmr5
    PYyRyrnEfKBU6Vop+D.MsbD723a.GR0w0Z0DicrmLv43ZwPCehNzXOO8sk9u
    8eGvAkUN78DcOernqyLbPjiSxxx1iVxNburiLWDEypmKYIeVoFFwkyJ4vUEV
    kHDtZYHDyO8vDwLQObWNMiEDSvyZ0csLbFoH1ES1ntSGq0qXWsRBCGQAbBoZ
    B0zBhOGTJll4ZDCcGPHVADXsLAuvBG5bfsZ+KPkdiEX2wBqJdg0oOn5HEAzS
    .g3NfX0zxinD+BDp6.hUiS93NmvKrf4LVHsp5K8MBVvSDO3NiGBq3ArYKzf3
    QLNDRvSHJDNCEbqpu1rSSPRwj6UfbmWgUC1939BzKnvcdET6TZPhHDIBJ8DO
    jNiGD6Tav8kqAF3LTfsSmg7bsDu3Z3NcFVIDEAwdKqg6jYXkDTHye0Rbmbbf
    cJL7WsDWsApp3wFq1BLG2p8cl7elcv3cmy09ogCRedHce75+pZq389eYkiCB
    EgEHHGUsRU31cWEWX8zM1Yq5MYGrYF538831LqWyZDscksDQBo.vgyio1Tvm
    MKXMTWgTB3Z89ZlH4QD.fBmMqXsvEOBNayh2DbzwJParYAMO6WVrVVHZ8zXf
    fzN6HhlbA7o+I.QvlkKuO73iM.tsb6bao8+e3B62cQcfc1ZqyxU1mMmVW+KH
    G.MyWXewUC4p4CNbaR5UOrv081pW3UDsH6P95SFayyG5xfNcyMphxjz3xjrz
    NuI4kuomR1rQkdQ9pMIEUOrqchT58VrwlU0yjoAFlXxMrp0IYX6pZCrnSDNs
    VFoxzfCZZDxzCMhYTi4CGMfQlFg5ASiXloAldSiZF03DOXZXSLsWGGOerrqX
    6TXZLlYlF1Cllv7bGvI1zjlEE.mdp85qY+llOR3xMK9jflqlV0Cr7zaZDy0c
    LKMsomYvYaIJgYUOEdHDPXF0DdnFk.MWugZXc.OHTSXlkM82LMZXmro+NoQ3
    B4gajbiFOrGDAY3X6HSekIA0HMPySmLgOjlIMEXnI1GyLgYbeL+AFM7DgOl9
    .yfFY5mDMogoYQ9wxFdNzPD+XYngsLlerL7vVF0OVFYPKCC7ikQGlYR+XYrg
    sLOk0fOrkw8ikIF1OySLSNrk4IlAGtH.1SIzfCWE.6oLZvgKCf8TAJ3v0AvX
    OYZFTHvWBNFtR.dbye1wkJNd+9mU4EG+rarpvcweo4+RpM+aENbWRZye2r2L
    ByUOmb5TZV46v370OkTpVWdHuYwreoYKoTeA0+3eA8Vry1C
    -----------end_max5_patcher-----------



    The problem was that loading the coll into matrixctr 1 with the uzi and then at the same time from matrixctrl 1 into matrixctrl 2 produced the glitch.
    so first i made the loading process a bit more simple and then added a 5ms delay between each step of the uzi.

    This change doesnt affect the playback of the pattern, only the update of the leds.

    hope this helps

  • Sorry to ask, but HOW DO YOU CHANGE PATETRNS IN OBO?
    With a knob?

  • Midi learn on obo pattern play ..we are talking about obo m4l version

  • @novasnoa Thanks for sharing that. Stretta's mono sequencer suffers from the same sort of choking when switching between presets. I found a [delay 10] associated with populating a live.step object with coll data and increased that delay to 100 and things behave fine now.

  • maybe you could send those two fixes to stretta so he can upload them to the m4l package in the docs page...