Gets Unresponsive, Lights still runnging

  • Hi,
    I cannot get rid of the issue with my monome. It sometimes justs works fine and sometimes it has this hickup in which the Buttons get unresponsive, lights are still running.

    Reinstalled SerialOSC and FTDI etc several times and a few times I thought it would run now but the problem always comes back in a show -.-

    Happens to me with Pages, MLRV, Live Clip Chopper, which are the apps I use mostly.

    Help please!

    Windows 7 here and yes it also happend with firewalls turned off.

    Cheers.

  • Does the issue only occur when running in pages? Have you tried running the applications in standalone mode (not through pages)... If that works without a problem, perhaps there's an issue with your Java installation?

  • It can happen everywhere: Java, maxRT or m4l doesnt matter.

  • in that case it sounds like a problem with serialosc. seems very strange that the button presses get unresponsive but lights stay the same.

    which monome are you using?

  • hey it is a grayscale128 m128-475
    is there an easy way how to monitor what is happening with serialosc?

  • an easy way is to use the 'M' button inside the serialosc patcher in any patch. it will print all the output to the Max window.

    another option is to use the normal serialosc.maxpat (non zeroconf) and see if the problem is associated with the zeroconf / bonjour setup?

  • okey there is nothing special happening in the max window.
    today i went through my system and switched of all kind of spyware protection software or printer clients or anything that could interfere in a way.
    Nothing changed. It also hangs up with the monometest patch today.
    It simply stops sending. In the meantime I wonder if it can be a hardware problem?

    I also noticed the the serialoscd.exe process is listed twice in the task manager. but guess thats normal? because if I kill the first, both are gone and if i close down the second the first stays but it doesnt work anymore..

    When it stops sending it needs to be reconnected physically to work again. It doesnt help to just reconnect the application.

    I more and more think I observe something interesting:
    The problem happens more likely if I am not pushing buttons for a while and if other applications are in the foreground.
    If I keep continously pushing, it does not happen as likely as in the above scenario.

    I was using the non zeroconf version before because I thought serialosc.exe is just buggy because I had the above problems already a while ago. I can give it another try for the comparison.





  • Guys can you please help me? I tried with my second notebook. Same problem.
    What is going on here?
    Galapagoose what do you mean with testing without zeroconf..
    Simply removing zeroconf files from maxfolder or did I oversee something?

    Can this problem be related to a hardware issues?

    Can you point out links of what exactely you mean please.

    I have a couple of versions and nothing works.

    Monome stops sending after a few seconds/minutes.

    monome-commands troubleswhooting is only for mac right?

  • right now i always have serialosc1.2a or an older version as the underlying serial to osc concersion... what i need now is a patch that runs without the serialosc. eg translates the serial to osc withing max or pd or vvvv i dont care. this way i can at least see what is happening and dont rely on the background service that is maybe bugged if not my monome has an hardware issue...

  • hm am i the only one experiencing such problems?

    okey summery:

    no matter if i use max5RT or max6RT with both the serialosc.maxpat with zeroconf or without: After some time the Monome stops sending button pushes.

    What actually work is Monomebridge.maxpat and Monomeserial.maxpat found in the max5-serialosc-osx-examples and max6-serialosc-osx-examples. I can use it to connect other apps.

    I am getting closer to the problem. I found out that sometimes a second before it stops working with all the other apps like monome_test_3.maxpat Buttons light up that are actually not pressed while others are pressed which do not light up at all. So probably a part of the software, either the serialosc process or the serialosc.maxpat starts messing up the Rows (not columns).

    So i press and press with the monome_test_3.maxpat app and it works but suddenly it light up the wrong button and then stops taking and sending the button presses.

    I had one moment when i had this bug 'locked' in a stable state for some strange reason. It happend when i used Monomeserial.maxpat with my own vvvv based tester app that simply forwards the incoming /press to /led, so basically just lighting up what is pressed.

    It looks like its the trace I was looking for. As you see in the video, if the bug happens it takes either no presses or it takes the presses right sometimes but sometimes it jumps in the row!

    Now I just have to find out if it is a problem of max or the serialosc process. Or if it is a strange Hardware problem that I cannot really explain. The fact that the 'hang' does only stop by reconnecting the device could indicate that it is more likely a serialosc or hardware problem (which i still don't want to believe) then something with the max patches.
    But I am pretty sure that I reinstalled everything often enough and tried all kind of possible combinations. I even made sure that there is no strange usb power management or port blocking involved or any other devices interfering.

    This is the video:



  • This won't be of any help... But for what it's worth, I have a similar problem (still unresolved) with my grayscale 128, only my issue seems to show up just with Pages. After a short time the buttons become unresponsive while the LEDs continue unaffected. I spent two months troubleshooting to no avail. I know that's not very encouraging, but I do hope you're able to find a solution. At least then I'd have more light shed on my own problem!

  • thanks this helps i would say because now i am not the only one with this :)

    i think its a bug in serialosc. it looks like the rows are drifting away with their indices to higher values that doesnt exist. it typically happens in programming if a recursive loop just keeps adding the values. just an assumption and i dont have time to get in the code (or say i looked in the code but its a lot of code). a statement from the developers would be nice.

  • firstly, which OS are you running? i'm no windows expert but if we know specifically which version then it's possible to get more directed advice.

    there is a way to speak to the older monomes (like the greyscale) directly through the serial port, but i just tried and was unable to get it to work.

    i'm a little confused about exactly how you currently have your system setup to deal with the problem. i think we can safely say that it's not caused by an error in the monome-test-3 max patch as that has been working without fault for quite a while now and there's been no reports of it doing what you are experiencing.

    secondly - i would suggest that you use the standard serialosc.maxpat (the one that does NOT use zeroconf). this is because it is 1 less part of the process that could be going wrong. go to the setup page here (http://monome.org/docs/setup:win) and download the max patch from point 5. install that in the designated place.

    re-start your computer and open monome_test_3.maxpat -- try and make the error occur in this patch. if you can make it happen in the test app through repeated pressing then it narrows the search for what could be wrong (something wrong with the serialosc server, UDP communication inside your computer, or your device). i imagine the device has recently been purchased second-hand — did you buy it from a user on the forum? have you confirmed with them that it was fully functional when it was shipped?

    i'm sorry if this feels like you're re-treading your steps, but it's quite difficult to follow exactly the process you've tried and what things you've changed at each step. if you do the above and can reproduce the problem it will have radically narrowed the scope of what could be going wrong.

  • hey galapagoose. Just wanted to tell the end of the story here. Thanks for your nice help.

    However in the end I could not make it run with serialosc, no matter what. It always stopped working after a couple of minutes. I went back to the old MonomeSerial which worked very relyable and never had this issue. Since then I am happy with that grayscale and built my own application around it so all fine here. Now with another monome I am rewinding this serialosc thing and then it will turn out if it had something to do with the application, Windows 7 or the hardware.

    Any ideas still welcome

  • Sorry this may be off topic but i have similar issue with my monome64 .
    When i run it with my 256 on mlr2.6.1_aux ,my 64 gets unresponsive for 40sec to 1 min.
    (I can't control anything while this issue happening...)
    this happens many times .
    when i use 64 alone there is no problem.
    I use mac 10.10 with serialosc and i don't use USB hub either..

  • @tekcor
    i'd say u might have a hardware issue. its strange that it works fine with monomeserial though.

    @hiko
    try clicking the m button in the serialosc connect box next time you're using mlr aux. then look at the max window for errors when u have the issues. this would help to figure out what's going on.

  • @elquinto
    Thank you.
    I saw there were tons of information scrolling from 64 on max window but It froze when that issue happens.

  • post a screen shot!

  • so, from my perspective, i'm not sure where the bug would be here, and without a reproducible test case it's tough to say.

    there are definitely cases where bombarding serialosc with OSC messages will cause LED updates to back up, slow down, and ultimately get lost, but the other direction (button presses becoming unresponsive) is almost certainly not the same root cause.

  • @then
    @elquinto

    I made video about my issue.
    Lot of times my 64 freezes longer than this video...

    https://www.dropbox.com/sh/hsyaal8hblhca7v/AADvwE9sURGL5OGMO0KLBso2a?dl=0