Max4Live help - Max editor won't open

  • All of a sudden I can't open the editor from a device in Live. Status reads "starting max editor" but max never opens. I tried repairing permissions and deleting max preference file and the problem persists. Any advice?

  • ...and now it is opening. ok, hopefully i don't have that problem again.

  • That's been a re-occurring bug for me since M4L came out. The only solution is to re-start Live.

  • The problem has returned. Now my monome grid won't show up in this particular device and the editor won't start. Editor will start from other devices though. I can't figure out what to try next, the patch worked fine then without any changes to it just started doing this.

  • are you running 64bit live? it won't open the editor if max (32bit) is opened before ableton's 64bit hook into max.. i would work around it by opening live, getting it to launch max and then opening whatever patch i was working on.

    hope that helps.

  • No, not 64 bit. I don't have full Max, just Max4Live so I need to do the same type of opening scheme you describe. I managed to get it open to edit a problem with my application, but this problem keeps coming up so I'm still trying to find the cause.

  • Sorry I don't think this is the same issue as I experience. The bug I was referring to looks like this: You click the little 'edit' icon in the maxforlive patch and it turns yellow as though Max is going to open for editing, but the icon goes back to grey and Max never opens. The only solution is to restart Live.

  • Yeah, that happens to me sometimes. Every once in a while repair permissions fixes that, but not always. I can't figure out what causes it.