serialosc for pd on app: wiki

  • i uploaded
    http://monome.org/docs/app:serialosc_pd
    just now. this is surely a duplicate of something else, but i thought a more robust connector object for pd would be useful.

    only one grid is supported. i can add multiple device support if someone can show me how pd gets messages for multiple serialosc gizmos (what is received: several three-part symbols, one really long list...?). i only have one gizmo to test with.

  • same thing happened to me i think using the 256...not sure what to do next have you managed to make any progress?

  • the patch works for me, though if there's a bug preventing your grid from connecting, run me through what you see in your pd window and i can try to identify the problem.

    it's my first patch so there are sure to be issues.

  • then this is what I have for the patch you've shown me ...

  • Right Ignore these last comments a they were enquiring your help to make a connection but one has been made! sorry for the mess of comments :) what would be best way to receive the binary information however, i've been trying to set up receive objects in response to what i can see in the serial_pd patch but I havent yet got pd picking up info from the monome?

    thanks you

  • The lowest level you can get are the decimal values of the OSC packet that pd gets from the grid. If you open up the patch, there are some checkboxes on a gray "debug" canvas so you can see that data printed to the screen if you really want it.

    However, the only useful data you will get from the grid (tilt and button presses) already comes out of the outlets as float lists once you click connect.

  • sorry thats what I meant the, data from the grid and tilt....when I toggle the lights on screen they're responding but I couldn't see a response if i send info with button presses or tilt on the abstraction of the "serial_connection pd" object I was wondering if I needed to create a receive objects or are there simply outlets I've just ignored ? :)

  • Hi,

    MacPro 2014, Puredata extended, Monome 256, Mavericks

    I have tried various ways to connect but repeatedly just get the following:

    udpsend connect: Can't assign requested address (49)
    udpsend: not connected
    udpsend: not connected
    udpsend: not connected
    udpsend: not connected
    udpsend: connecting to port 12002
    udpsend: connecting to port 12002
    udpsend: not connected
    udpsend: not connected
    udpsend: connecting to port 12002

  • we have a pd tutorial coming up by the end of the week...

  • very cool!

  • btw, I believe pd vanilla has osc support now, no need for separate externals