problems upgrading bees

  • So i downloaded bees 0.0.0, put it in the app folder on the SD card (actually i made the mistake to erase the former one and replace it). Powered up aleph while holding the MODE key. i only got APPLICATIONS on the screen with WRITE on KEY0, and i can scroll to another screen displaying MODULES with LOAD on KEY0, but that's all? Anything else is unresponsive.
    Any ideas ?

  • sounds like the aleph can't find the hex file.
    on your SD card make sure you've got the bees hexfile in /app/bees.hex (or bees.0.2.0.hex etc). you might find you need to hit 'empty trash' before ejecting in order for the OS to clean up the card properly > i've been emptying the trash before i eject the card each time to make sure there's no osx rubbish lying around.

  • No way...
    Something's weird. i wanted to post the contents of my SD card here so someone could check, but my computer won't finish creating the .zip file.
    Something must be corrupted.
    Any idea on how i could have a 100% fresh SD card ?

  • I think you can use Disk Utility to format it maybe?

  • I am at my 6th formatting on 2 different SD cards...

  • btw does it matter in which format i format the SD card ?

  • what os are you on? do you have ny other machine that can format cards? (even a digital camera or something?)

    and are you formatting as FAT32 ? i think disk utility chooses something else by default

  • for some reason my macbook pro (OS 10.6.2) won't let me copy anything to the card when i use FAT to format...
    i bought this afternoon a card reader but it just seems to be buggy as hell so im using the macbookpro instead.

  • the card needs to be FAT. i'm uploading a .zip with the latest full disk image, will post link in a moment.

  • .zip file at the top of http://monome.org/docs/aleph

    note that the THIS scene seems to have a bug with monome support.

  • thank you. Trying ASAP.

  • Well i managed to format my SD card to FAT. Loaded it with the last .zip. Same thing :
    bootloader doesn't give me any choice, every control unresponsive except ENC1 which alternates between apps and modules. Powering it up gives me a still two-tone drone (a fifth, something like Ab-Eb), every control unresponsive.

  • i can verify the same problem. i tried copying the contents of aleph140115.zip to a Panasonic 2GB SD card (class 4), insert into the aleph, hold down the EDIT button while powering on, the APPLICATION list is empty.

    the card is formatted as FAT32.

  • tried the same with a SanDisk Ultra 32GB microSD (in an adapter) also FAT32. this time the APPLICATIONS screen wouldn't even come up.

  • That's really annoying... hopefully it will get sorted soon...
    Gonna be away for 2 weeks to work on music, but i think i'll take my aleph with me.

  • i'm about to test the new build which perhaps broke something (?) but in the interim, here's a zip of my current card which i made the tutorials with.

    let me know if this solves the problems you're experiencing and we'll figure out what's happened in the build.

    348K
  • nothing in the build could have affected the bootloader.

  • @kotdotnot , really, bootloader won't come up? are you able to use the unit yet or is it bricked?

  • @chapelier , when you say "all controls unresponsive" , you mean you can't use the MODE button to get into edit mode either?

  • @zebra , totally. only ENC1 works and toggles between APPLICATIONS and MODULES.

  • ok, you're talking about the bootloader, i was referring to when you boot into bees and hear the tone; you said it was "totally unresponsive" and i'm wondering after more details on that.

    if, in the bootloader, you can't see any .hex files (the APPLICATIONS list is empty) then there is some hardware problem with the card or the reader, i guess. i would try a different card at this point.

  • will try asap... but already tried 2 cards and different formatings.

  • am i correct that currently the available modules and scenes will only work with the shipped version of bees rather than the latest? that's what the various threads appear to suggest. i can see that all the versions of the released code are available at git. is it worth indicating on the docs page the bees compatibility for the available modules?

  • for now i think we have to assume a very 'alpha' scenario where compatibility will break quite often. i'll note this whenever i know it to happen in the releases tags. it hasn't happened since the first public release (0.0.0) but it will have to happen again soon.

    there are two kinds of compatibility breakage:
    A) between running versions of bees and modules
    B) between subsequent versions of bees/modules, for loading scenes.

    A) might happen a lot, but it doesn't imply B), which we will try to avoid.

    for scenes, it is entirely feasible to write a backwards-compatibility util for any given commit, that will rewrite your scene files appropriately...

  • but sorry to answer the question directly:

    - the scene that shipped on sdcards will only work with shipped version of bees.
    - the scenes shared on wiki should work with latest version of bees.

  • additionally:

    - very rapid improvement and many bugfixes coming in so its best to get the latest version of everything and start making scenes from scratch..

    - unless otherwise noted on release page, your scenes will still work with the latest version.

    i am going to break scene compat. again very shortly so for now i would keep them simple.

  • @zebra - thanks - and i guess that provided we have a compatible bees/module pairing then we should be able to create our own scenes to control the modules. is there a plan, provided this isn't already a reality, to be able to write scenes in an editor and compile them on a pc, rather than from within the edit mode of alpha. i can see the benefits of having both as available options.

    what's the currently recommended bees/lines pairing? [edit] i think you just answered this - thanks

    as you say, it's early days so these kind of issues can be expected - seems like there is a lot of scope for organising the docs pages, threads and developer effort to maximise the efficiency of conceiving and creating a library of bees operators, modules and scenes...exciting times!

  • somewhere, there is work underway on a serial-based "live editor."

    a think a utility that parses the scene binaries into JSON, is also necessary.

    and so, here are some new issues!

    https://github.com/tehn/aleph/issues/159
    https://github.com/tehn/aleph/issues/160

  • JSON versions of the scenes is a good idea. late here in the uk - will try out some scene creation over the weekend and begin to look through the source code in git.

  • ack

    now that i did a search i'm realizing this must be the same issue

    about to try the zip posted above...

  • i now realize that in my haste i downloaded and unzipped the files directly on my card without removing the folder "aleph140115"

    (so the internal structure of the card wasnt being recognized)