aleph: debugging

  • hello! aleph arrived today, very intriguing box. i've got the toolchain installed and have successfully built bees, and i'd like to be able to see the "print_dbg" messages. i copied the aleph-bees-0.2.0-dbg.hex over /app/aleph-bees.hex but i'm not sure how to connect to it and see the debug messages. any insight would be appreciated!

  • got it.. for anyone else on ubuntu

    sudo apt-get install minicom

    sudo minicom -b 500000 -D /dev/ttyACM0

  • i'm trying to do this via xubuntu inside vmware player on windows 7. when i plug in the aleph, windows does not find a driver automagically -- should have expected that. what are my options? ftdi usb-to-serial driver?

  • its not FTDI. windowsa will likely think its some sort of USB modem...?? not sure how it works in vmware, does /dev/ get populated in the client?

  • hi, I've been trying to connect using minicom on mac os 10.8.5. The command given doesn't work for me, but running sudo minicom and connecting to /dev/tty.usbmodem1421 sort of works, but the output all looks like this:

    // this line repeated lots of times
    net_activate, input idx: FFFFFFFF , value: 00000015 , op index: 786464 , input idx: 0000016 , op index: 786464 , input idx: 0

    // then if i spin an encoder, lots of garbled text like this:
    0JC??jŒ?B?J?B?)?!?J?B??B?jŒ?c?J?B?J?!9)JC??B
    )
    ?
    ?)
    B??hD??)
    B?
    ???(%?(?b??

    ?Z?%?B
    ?JB!?jJ?JC??B
    ?(?????%?c?%?jŒ?c?J?B?J?!?J?B?B?J?j?J?B

    Theres a settings page, does anybody know if these should be set to something different?


    +-----------[Comm Parameters]------------+
    | |
    | Current: 115200 8N1 |
    | |
    | Speed Parity Data |
    | |
    | A: 300 L: None S: 5 |
    | B: 1200 M: Even T: 6 |
    | C: 2400 N: Odd U: 7 |
    | D: 4800 O: Mark V: 8 |
    | E: 9600 P: Space |
    | F: 19200 Stopbits |
    | G: 38400 W: 1 |
    | H: 57600 X: 2 |
    | I: 115200 Q: 8-N-1 |
    | J: 230400 R: 7-E-1 |
    | |
    | |
    | Choice, or to exit? |
    +----------------------------------------+

    Thanks!

  • baud needs to be 500000-- you can set this with the command line.

    however, i've had some trouble with minicom on the mac. i've written a python script for communicating with the aleph but i'm not sure the debug builds have the correct framing right now-- i'll check it out.

  • try

    sudo minicom -b 500000 -D /dev/tty.usbmodem1421

  • Hi, I did try that, but it just responds with

    type minicom --help

    or something like that. I get the impression that I might be able to set the baud rate in the config file. I also might try using screen.

  • yeah i tried to setup minicom on osx too but found it faster to just download and run ubuntu. seems like overkill for a serial monitor but i just couldn't get anywhere with osx.

  • baud changed?! using bees 0.5.5, osx, 'screen'-terminal and it only works with 57600(!)

  • really?? it was changed to 115200 in 0.5 but i didn't realise it'd changed again. will test this today along with a bunch of other things.

  • brian changed this for some reason that i don't remember possibly to do with testing serial communication from the chrome API. didn't realize it had snuck into releases....