i think something's wrong with my aleph

  • Ok, so passed a few days and sd nightmare headaches, i start thinking something's wrong with my device.

    WITHOUT any SD card, what is supposed to happen ?
    What happens here is : every time i power up, i got something unpredictable : sometimes a still fifth, some times a very high-pitched noise, sometimes a low pitch and a very high pitch, sometimes nothing, with ALL buttons and encs unresponsive. 1 time out of 20, i got what seems to be waves running, with PLAY enabled, everything seems normal and all buttons responsive, incliding the mode button (except that it's quite in a low pitch area, but i might have changed this on the very beginning).

    More generally :
    Putting a sd card seems to not change anything.
    Holding MODE when powering up launches the bootloader. But won't display any APPLICATION or MODULE. Nothing responsive except ENC1 which toggles from APPLICATIONS to MODULES.
    Holding MODE when powering up gives me a message saying the unit resets because of the lack of SD card.

    Thanks for the help.

  • Edit : with a SD card loaded, i 'seem' to only encounter the 'still fifth' scenario described above.
    Edit : the low pitch when it's working was indeed linked to the mapping of ENC3.

  • for now, you should not powerup without an sdcard. inserting the sdcard after powerup is not good either. sorry!

  • without the sdcard you will get totally random stuff. if the docs are wrong they need to be fixed asap.

  • will fix the internal flash storage of .ldr files after some storage-optimization tasks are complete, which is very soon

  • @chapelier fou
    i guess contact someone directly,
    help@monome.org
    or IRC #monome-aleph on freenode.net

  • also please try the most recent bees hexfiles in github master
    https://github.com/tehn/aleph/tree/master/apps/bees

  • I'm stuck at Reading Default Scene, tried two different SDCards. I grabbed the zip from the SD Card Format thread. I just hear a tone. No buttons respond to any presses. Took me three computers and 24 hrs to realize my SDcard reader isn't able to read these cards. :\

  • OK I read in another thread hold Key2 on boot for blank scene. That got me through this hurdle. on to tutorials.

  • how can you tell c1t1zen? they appear to be recognized by my mac and i can replace, delete, and copy files no problem, but have a similar issue with aleph.
    "No buttons respond to any presses"
    thanks.

  • Setting up the github is huge help.

  • thanks, will do.

  • if you want to try the demo scene, this seems to work for everyone:

    - use the scene file called THIS from the aleph140115.zip on front of aleph docs page. do *not* use the scene file that shipped on your sdcard.

    - use bees 0.2.3 from the repo: https://github.com/tehn/aleph/tree/master/release

    - use waves 0.0.0 ; the file *must* be named "aleph-waves-0.0.0.ldr" in sdcard:/mod/ for this particular scene to find it.

    if you're not interested in the demo scene, and are starting from scratch, i recommend using the most recent versions of everything from the github.

    you can use git to track changes if you want.
    on linux or mac, with git installed:

    git clone https://github.com/tehn/aleph.git aleph_clone
    cd aleph_clone/release
    git pull
    ls

    "git pull" will get the latest build files and sources. you don't need to compile anything.

  • yeaaaahhhhh!!! it's working! still need to figure out how to install Git, but at least a small victory for me. thanks.

  • (yeah same thing here, i feel dumb but can't figure out how to download bees on github)

  • hah, definitely not feeling very bright trying to get up to speed in all this. funny, makes troubleshooting a monome set up seem like a walk in the park.

  • if you've got osx10.7 or above you can download the github app which feels a whole lot more obvious due to having a GUI (even though the terminal is simpler??).

  • to download via the github website:

    - visit https://github.com/tehn/aleph/tree/master/release
    - click on a file (e.g. "aleph-bees-0.3.2.hex")
    - click on the button labeled "raw"

    depending on your browser and the file type, you will now be prompted to download, or (for e.g. .hex file on most browsers) it will display the raw text content of the file and you can save this to your computer.

  • and yeah, its definitely more convenient to install git.
    mac : http://code.google.com/p/git-osx-installer

  • have git installed on windows - have cloned the repository, which has created the empty directory structure - how do i pull the files? - can't see a control to do this...

    can't see the scalers data files in the repository?

    once i've got the latest versions of bees and the modules and put them in the correct folder structure for writing to aleph - do i preserve the file names including the latest version number? some people seem to be renaming the files....

  • "git clone" shouldn't produce an empty directory structure by default. not sure what is going on with your configuration...

    "git pull" is the usual way to get stuff from the remote.

    param scaler data is here: aleph/utils/param_scaling/*.dat

  • no renaming necessary. people were only doing that to force the 'THIS' scene to load. we'll rebuild that scene so it doesn't need any filename changes.

    bees: you can use either the version with the number of without. the un-versioned file is identical to the most recent update. (i think this is the non-debug version?)

    modules: USE THE UN-VERSIONED .ldr file. for the moment bees looks for the filename of the module directly so if you use the non-versioned file you can update your module.ldr without breaking your scenes. ezra's working on a fix, but at the moment it's useful to be able to specify different versions to check for bugs.

  • @zebra, @galapagoose

    thanks - folders have now got the latest files in them - not sure what i did to get them there...presuming the best way to pull is by opening a command prompt in the directory of choice and typing 'git pull'. was trying to achieve this through the git app and the repository web page previously.

    found dat files just before you posted

    will use unversioned bees and module ldrs

    getting there...i'm sure it'll be second nature after a few iterations...

  • @knecht - is there some way you can send me the folder you have on your sd card? i followed all the steps numerous times as outlined above by zebra but am having no luck. found all the files, structure/naming seems to be correct but unit still hands on "reading default scene"…

  • hi jay! you know i have also been having trouble with default scenes on the most recent build. try holding down KEY2 (the third key from left) - this will go into a boring empty state and then you can try loading the scene from the menu.

    i'll be working on this today.

    also note that the posted THIS scene is still not compatible with newest BEES, only with 0.2.x

  • @zebra - zup! thanks for writing me here!!! i tried to get all the compatible files together and load them as described above by you but no luck so far. as well, when booting with KEY2 held down i can get to the empty state, but then find nothing to load in the scene menu. i've attached a photo of my screen as i have no idea what its normally supposed to look like if the THIS scene is there or not?

    3264 x 2448 - 2M