new zip: aleph140122

  • edit: update jan22
    - includes bees 0.3.5 (you'll need to re-flash)
    - fixes scene loading issues
    - includes dubs, 8step & bells
    http://monome.org/docs/_media/aleph:aleph140122.zip


    **
    in an effort to update this zip much more regularly here is the current zip of the most recent versions of bees, waves & lines. it doesn't come with 'this' but it does have a fun little 8step sequencer to play with. ezra's working on a converter for older scenes so we should be able to fix compatibility with older scenes without having to rebuild them by hand. i'll add 'dubs' and 'bells', plus a few new things very soon.

    if you could update your version of bees it would be a great help in making sure we're tracking the right bugs and improving the software as best directed at you, the community, as possible. please keep the bug reports coming in this thread: http://monome.org/community/discussion/17234/aleph-bug-reports. we're doing our very best to help the early adopters make useful things, while focussing on developing aleph itself as fast as possible.

    it's still early days, ezra is slaving away working through all the bugs & feature requests, and brian will be back in the states very soon to aid in these efforts.

  • Checking it out now. Thanks for the updates. Keep on rockin.

  • when i power up holding down the SW2, i arrive to a state that says PLAY. i press the mode button which brings me to INPUTS, i can use encoder2 to scroll through OPERATORS, INPUTS, OUTPUTS, PRESETS, SCENES, and DSP. however, when i am on the DSP or SCENES page i simply have a grey line going horizontally across the screen and no options to select. am i missing something?

  • also, with this newest zip, should i have to power up holding the SW2?? if i don't the machine hangs on "reading default scene" and nothing happens…

  • is it wiser to run the dbg file?

    just curious about what works best

  • @jay - that seems strange to me. you should be seeing 'default.scn' and '8step.scn' in the SCENES list, and MODULES page should show lines & waves. i'll get onto you directly and see if we can figure out what's going on - then can report back here.

    @gli:
    the only point to running the debug file is if you have your computer attached displaying the serial output. essentially it's just so you can print debug info for bug reports. for most users this will not be necessary or really recommended (i'm having a hard time figuring out how to get it working - damn those e&b geniuses).

  • @galapagoose - thanks, i emailed you...

  • unfortunately this dont work

    it loads but controls are unresponsive...i'll reformat and attempt once more

  • do you mean bees itself, or the 8step scene?
    has the module loaded properly (are there PARAMs in the input list)?
    have the operators & routings loaded properly (see OPS screen)?

  • @galapagoose

    1. i assume 8step is the problem
    2. yes the module appears to load properly, yes there are PARAMs under INPUT
    3. OPS have loaded, not sure about routing (cant remember how to check them without changing the settings)

    also, i deleted the dbg file & default scene off the card because i assume they arent needed

    gonna dive back in and mess with the routing values to see if that helps

    ps :: is 8step default set to "waves" or external synths? wondering if i need to disconnect the scene from the module or something

  • @gli: are you getting an audio. if you are, try pressing SW0 to start the clock.
    i think it should have pitches already running but you might need to turn up the values with the encoders for some reason.

    the 'default.scn' is where the current scene is written when the aleph is powered down. if you delete it you'll have to do a first-run (hold SW2 on load). deleting the debug file is fine but unnecessary (you'll never see it except when running the bootloader which you shouldn't need to do again til the next bees update).

    it is configured to work with both CV out & aleph-waves outs simultaneously.

    if you go to the OUTPUTS page do you see routing destinations for the ENC/VAL and SW/VAL outputs?

  • tried SW0 (and the other switches)

    i'll try turning all the encoders up further to see if that changes anything

    also...no routing shows up :(

  • ok - weird question: have you gone to the SCENES page and pressed 'RECALL' (SW1) on the '8step' scene?

    it's definitely not loading correctly, as only the default operators are appearing. when you press 'recall' on the scene, does it very quickly say "done loading" or does it show a few lines of code like "loading DSP" etc?

  • tried recall and it very quickly shows "done loading"

  • ok - i think you're suffering from the issue I was having last night with the other scenes not loading. it should be a simple-ish fix so hopefully ezra will get to it tonight, or tomorrow.

    is '8step' the only scene listed in the SCENES page? if not, can you post your list in order?

  • yeah only 8step right now...figured the other scenes werent functional w/ this version of bees

    i'll wait for the update then

  • just as a test, can you try re-adding the 'default.scn' and see if that fixes anything? you can also try loading the 'default' if 8step doesn't work as i believe it is a copy of the same scene.

  • Loaded this version up now. I get the hum for default.scn but no sequencing or anything like THIS did. Also no connections in the Operators or Outuputs page after the scene is loaded. Don't have access to CV gear to test those apps out yet.

  • @galapagoose default.scn doesnt help

    cant select it in order to load it (enc toggles between 8step and the blank space above it)

    tried loading the blank space and subsequently re-loading 8step...and got a crazy message


    my aleph thinks 8step should be linked w/ LINES not WAVES

    but i guess the new .scn's load the corresponding module for you which is actually pretty rad

  • i've attached a new zip bundle up top of this thread.
    you'll need to reflash to bees 0.3.5
    scenes should now load properly & there are 3 included that you should be able to swap between.

    @gli: yes - the scene display has an issue where the list appearance is off by the number of scenes down in the list you've loaded. will be fixed soon!

  • all good

    will test these

  • I'll test this new version now.
    With Bees 0.3.4...I should add I also was seeing weird stuff in SCENES page. I could scroll down all the way but going through the pages and then coming back to SCENES I had a bunch of scene names replaced with names further above. scroll pages and back and different names moved about.

  • Loaded fine and got the Default rocking. What are the controls for this Default.scn?
    Still getting weirdness in SCENE directory.

  • it works!

    running 8tep into a tetsuji synth right now
    excellent stuff

    might tweak it tomorrow so CV controls tempo

  • @c1t1zen:
    i believe the default.scn is a copy of 8step. you probably don't need any default.scn on the card as bees will create one after flashing i think.

    yes, the scenes display is still off, but it should be functional regardless.

  • bells is such a sleeper

  • Wait do any of these Scenes in this Zip make noise? Or is it just delay and CV?

    I do need to go back to the tutorials on the latest Bees.

  • 8step and bells both make tones w/ aleph-waves

    indeed i should probably call bells 'probabilistic drunken melody wanderer'...

  • its even more fun for aleatoric rtms

    made a pretty interesting drum seq earlier with bells running a simmons drum brain