bees 0.4.0 preview

  • i'm calling this a "preview" because there are no scenes included-- this version breaks all previous scenes. ezra is at work on a scene migration utility and it's very close, but i feel that shouldn't stop the more ambitious users from checking out all the new ops etc.

    attached. this hasn't been pushed to master yet. that will happen soon.

    see http://monome.org/docs/aleph:bees:ops for the updated list of ops.

    https://github.com/tehn/aleph/blob/dev/CHANGELOG

    !! THIS VERSION WON'T LOAD OLD SCENES !! again, migration util coming soon.

  • cool - will give it a try over the weekend

  • Thanks! this is cool.

  • new tutorial up for the folks who are trying this out: http://monome.org/docs/aleph:bees:tutorial4

  • tutorial looks great - can't wait to try this out - love the hand drawn networks

  • this one is huge. the whole concept of "level shifting" is what I need to get quicker and more comfortable thinking about. (Also glad I managed to make the random block on my own before reading this--and apparently I did it right. :))

  • drawing things out on a piece of paper is a must - glad there are some pics in the new tutorial - should make it a lot easier to figure out what's going on...

  • Yes more tutorials. Thanks Goose.

  • scene: dronelife

    needs a monome grid presently. working on a screen-interactive version!

    sw0: step sim
    sw1: start/stop sim
    sw2: rules: nodeath
    sw3: rules: nobirth
    enc0: sim speed
    enc2: filter
    enc3: filter

    this uses the preset system to set different tone intervals. when the population of the board crosses a threshold (currently set to 10, you can tweak this with IS/B) it randomly chooses a new combination of tones (by preset).

    some smoothy modulation happening in there according to population. you can "play" the rules keys for interesting results.

    set for a 16x16 grid by default. change life/xsize and life/ysize in the inputs list to change.


    ps. had to add 0.4.1 because i found a bug in IS while working on this. EDGE wasn't working. fixed.

  • be sure to put the .scn in the right folder!

  • hmmm… not working for me here- a few issues:

    - i still have to reload bees 0.4.1 (and also 0.4.0 if i want) each time i remove the sd card and reinsert it into the unit. otherwise, if i don't, the scenes and dsp pages are blank

    - tehn's dronelife shows up as an option to choose on the scene page but the graphics are totally jacked on the screen, looks exactly the same as the pixelated greyscale processing graphic when loading bees. though i can pick and select the scene and it loads (i guess, hard to tell because i get some functionality but perhaps not all, not sure what is supposed to happen totally).

    - the loaded scene shows again some jacked up pixelated lines across the screen, but life plays on the grid seemingly fine. however there is no change in sound. i get the default (as far as i can tell) drone that automatically turns on when the unit is switched on (again- ??). so there is a drone, but no change in sound from running life on the grid. am i missing some sort of other updated files? i did a pull from the github, couldn't find anything that was from an earlier build on my card.

    - keep in mind i have no idea what i'm doing… mostly because things happen and i'm trying to figure out what is the expected/desired behavior. so i have trouble deciding what is a mistake on my end vs. what bugs the machine is exhibiting vs. what is the function i'm trying to achieve in the first place…

  • ack! i'm sorry to hear this. i'll assemble a proper sdcard image. and post a little vid about what's supposed to happen.

  • @tehn - somehow i got it working now! instagram video evidence abounds. not sure how i got to this place now where its working, but happy to be here!

  • do you have any ideas about the somehow? for a brief moment yesterday i had the pixelated filename problem as well, but it vanished before i could explore it further.

  • whoa, i can't tell from your video if the tones are changing from time to time? want to make sure the network fully loaded.

  • the pixelated file name is still there even when it loads and runs. as far as i can tell tones change from time to time… in the video i don't mess with the encoders at all but they do make noticeable changes in real life, though not sure if its the kind of changes you're talking about!

    i just kept repeating what i was trying before and suddenly it was working. the steps were:

    - reformat sd card
    - load card with bees 0.4.1 in the appropriate place
    - load card with dronelife in appropriate place
    - empty trash if possible before ejecting
    - eject card
    - insert card in aleph and boot up holding the mode button down
    - reload 0.4.1
    - press mode button to get out of play mode
    - select pixelated file name and load
    - watch screen to make sure its loaded
    - press mode again to play
    - not only do encoders work now to change the drone, keys also start/stop animation on the grid

    not sure why the tones change now and not before. could have been when the scene loaded it was corrupt somehow and didn't load waves or whatever correctly or at all. but i haven't pulled the sd card and repeated to bug test again now that i have it successfully going for now!!

  • yeah the filename is also pixelated/garbled here too but the scene works fine

  • I too noticed the garbled scene filename but was still able to load. I was also able to load my scene in 0.4.1 that was created in 0.4.0. I'll give tehn's scene a shot this morning. Here's a tiny snippet of the demo I tried to get last night. http://instagram.com/p/j4pTqzoA6A/#

    I have a fill vid but vimeo's site seems to be broken from a DDoS attack.

  • crud i will check the file

  • wow, it's fried here now too. i'm trying to pinpoint the issue, but duplicating the file on the card and renaming the dupe other.scn or something works?

    will hope to have a better answer in a bit.

  • wow jay you really should not have to reflash the application.
    seriously everyone, that should not really be a troubleshooting step.

    if you are having trouble booting bees, an earlier step is to try clean-booting with SW2.

    clean-booting skips the attempt to load "default.scn" from the sdcard. it will try to load "aleph-waves.ldr" and to initialize param scalers, but it will not crash on failure (e.g. no sdcard present.)

    on scene compatibility:
    0.4.x can read each other's scenes,
    0.3.x can read each other's scenes,
    etc.


  • trying to replicate garbly filenames with brians scene file now

  • You can try with mine too if you'd like. Just saved this scene in 0.4.1. http://monome.org/community/discussion/comment/201517#Comment_201517.

    Updated Life/Waves patch. Added SWButton controls plus 4 CVin modulation destinations.

  • @zebra - i forgot to mention that i tried to boot with SW2… resulted in empty scenes and dsp page options… i never had to reflash until i got on 0.4.0 and higher…

    i'm going to load emergency's new life scene on the sd card now, so we'll see if i have to reflash again…

  • @zebra - same result… booting with SW2 held down and also just simply turning the unit on with the sd card reinserted results in empty page options. i'm guessing this means that for whatever reason the machine is not reading the card? so strange because when i leave the card in, and boot with mode held down, i can select which bees to load and it loads just fine. then i have normal operation after that (seemingly until i remove the sd card again). and to be overly clear, removing/inserting sd card with great care… i.e. after power down completely, etc. etc.

  • garbly filenames looks to have been a rendering glitch only, and not particularly related to the specific scene files. fix added to 0.4.2.

    @jay, this seems really weird, i'd like to talk through it with you in email/irc. having a really hard time imagining any possible reason for re-flashing the app to have any effect on sdcard functionality whatsoever.

  • @jay are you using the supplied sdcard? i should start a new thread asking if others are doing this...

  • @tehn - i never got the supplied card in the end (not your fault). i've been private messaging zebra about the current situation… which just seems to keep getting worse and worse. but don't worry, i'm not stressed. if this continues in the next couple of weeks as new BEES and scenes are added then i'll start to sweat…

  • @jay no sweating necessary we'll keep you taken care of!

  • @zebra - i can confirm that any bees over 0.3.5 will load once powered on while holding down the mod button and "reflashing" but once the power is turned back off and on again all scenes are empty and the bees version needs to be loaded again.

    seems with 0.3.5 and below i can turn the unit on and off and still have the unit read scenes from the sd card...

  • i had a weirdly similar issue yesterday.
    could you try re-formatting the SD card and copying the .zip image onto the card again? make sure you've got the correct file structure which should simply have 'app' 'data' and 'mod' on the root of the card.

  • it sounds very much to me like there is something pathological going on with jay's hardware regarding internal flash. we'll sort it out offline, i will try rolling some test code for this particular problem to pinpoint it.

  • @galapagoose - more testing today. i've reformatted, switched cards, back and forth many times. same results. i have the same file structure on the card when it works with bees 0.3.5 and lower. this might seem crazy, but do you mind sending me a copy of the content on your sd card via email? i have no idea how i could be screwing up the contents, but i don't know what else is left! i can't imagine the hardware or the machine itself is behaving so strangely since i got it working more or less fine before trying out bees 0.4.0. it must be something i'm doing myself.

    instantjuggler (at) gmail (dot) com