monome_sum v1.1

  • hello!

    we've spent the last week making a bunch of updates to monome_sum, attempting to address many of the issues & suggestions from the other threads. there's a few notable exceptions that we're still working out solutions for, but on the whole we're pretty happy with where this thing is at.

    as always we appreciate your feedback, and we'll be looking at another update in around a months time before the new 128s ship. in the meantime there are many new ideas to explore & share with you.

    see the wiki for the newest download link & updated documentation: http://monome.org/docs/app:sum

  • as before, the leds only work for step and gome with my mk kit. all the apps are accepting presses and making sound, but only gome appears fully functional. for step the lights work for the steps but the tracking bar does not appear.

    anyone else seeing this? or am i the only kit user left on the planet?

  • this sounds like the app is detecting your device as a variable brightness model, and so sending a bunch of data that your device doesn't understand. what is the device id (like: mk0001, m64-0001)?

  • This is great. Thank you guys.

  • the most recent mk is a m0001000 pattern. i either need to tweak serialosc or release a firmware fix for the mk. thanks for the heads up, a firmware update should be pretty easy.

  • yeah my serial is m0000011 , i think i had to give it that pattern (instead of mk...) a while back to get serialosc to work.

    lemme know what/when to reflash! i wanna play too!

  • ahh yup that'd do it -> the method i use to detect for variable brightness lumps anything with an m**** serial into the 'mext' protocol, which i thought was equivocal to 'variable brightness compatible'. obviously we haven't been testing with kits.

    you could try and pirate rename the id, but i'm guessing the reason you had to change is because some kit firmware upgrade changed the protocol it speaks to the computer. i'll have to defer to @tehn here i'm afraid...

    of course we could add a 'varibright' toggle switch, but i was really trying to avoid that kind of thing if we can automate it.

  • renaming the id would break the protocol. i simply need to release a new firmware that has proper handling for the vari messages. shouldn't be hard. this is an important fix in general as we're going to be posting more vari apps.

  • been playing with the updated version this morning and it is really amazing the number of different things you can come up with! could someone please give a general overview of how you save presets and what they actually save? thanks for the update!

  • Question: Is there a way to allow this MLR to play both samples on top of each other (as through they were assigned to a different group)?

  • great work!!
    just a thing: in 1.1 version mlr doesn't work on my setup.
    when i press a button on the first column, samples doesn't play and led acts in a way similar to the original mlr when there is no samples added.
    in 1.0 version, with the same setup mlr is fully working

  • @entwhistle are you on windows or mac?
    @emergencyofstate this super basic mlr lets you play 2 samples at once. the left sample is on the top half of the grid, right sample is bottom half.

  • i'm on a mac 10.6.8 with max 6.1

  • @galpagoose

    I'm on a mac osx 10.5.8

    ver 1.1 opens, but the program screen does not appear. I tried what was suggested in the 1.0 version, that is, double clicking "open" after it is already open and there were no results. Any suggestions? thanks man!

  • that happened to me as well. make sure you delete monome_sum (the first version) from your desktop before downloading the new version. restart your computer, then download the new version. that seemed to work for me. i'm on osx 10.9.2

  • @entwhistle
    i just tested here and mlr works fine for me (osx 10.7.5 max 6.1.6).

    a few questions:
    * you're sure you have audio settings on?
    * is flin and gome working for you?
    * if it's still an issue, could you hit cmd+m after starting sum - press some mlr rows and tell me if there's anything colored red showing up in the max window?

  • ok
    finally i downloaded .zip file and mlr works fine.
    (in the past days the link was broken, so i worked on the source code)
    also clock midi output works fine.

    some obervations:
    - rewire with live9 seems not working, but i think is a problem of my live9. someone tried this?
    -when i try to add some external app in monome_sum (parc or poligome of mabahlabla), the app opens up correctly, and i can navigate in the pages of monome_sum and parc, but parc doesn't play any sound. It seems that transport function doesn't start, but in monome_sum i can see that it works fine.
    - i run independently monome_sum and electric dharma wheel. it seems that they can't stay side by side. someone tried this?

  • is there any possibly that the "step" function will eventually be expanded into "parc"? i think my head would explode.

  • i'm updating parc, though it won't be inside sum. the smallbatch router will be a general use tool that can swap various applications, so you should be able to achieve what you're looking to do within a few weeks.

  • hi tehn,
    i'm strong user of parc, which i consider the most insipiring app for composing with monome.
    have you ever considered to assign a grid button to switch between global/notes pages?
    personally i think spacebar is a bit unconfortable beacuse sometimes i lose focus on parc, especially live. i think using a dedicated button on the grid would be great,
    something like smallbatch, a "master" button directly on the grid.
    thanks


  • @entwhistle

    rewire is not supported in monome sum. midi clock out is the best it can do at this point towards syncing with other things.

    regarding the parc button to switch modes: i could do that for you in a few minutes.
    where do you want it ?

  • just chiming in here, i'm having the same problem as raw ray on the mk and LEDs only working on step and gome. overall, this is super fun and a great little tool to get me back into the world of monome. i'm also excited to see what you have planned for pard, @tehn!

  • thanks @s!
    i modified parc to set a switch button in position (14,0) or in (14,7) and in both cases it interferes with the other functions. You need to find the optimal position on the grid.

  • I'm confused about how sum is routing (or not routing) to Live 9 on my setup. In sum's Audio Settings I changed my device from Built-In Output to my Avid 002 Rack, which is my hardware interface for Live. Left and Right are set to Outputs 1 and 2, respectively.

    The good news is I can hear sum coming through my 002 Rack, whether Live is running or not. But I don't see signals coming in on any tracks in Live. I would think sum's audio would show up in Live's Inputs 1 and 2. Where is the signal going, and how can I route it to my Inputs in Live? Does this require Rewire, which I see @s says is not supported in sum? Will it be supported at some point?

    Super cool app, btw.

    Thanks!
    ty

  • @square_wave - I don't know anything about the avid rack, but if it's just a normal sound card, I think you need to use either rewire, jack, or soundflower to route between applications. I've had good success with soundflower on my mac, although with some latency; rewire is best for apps that support that.

  • Are there instructions somewhere on how to open the full version of an ap like MLR in sums?

    Or is a live recording feature for the built in MLR planned?

    Thanks!

  • Hey everyone.

    I have 2 monome 128s (m0000133 and m128-***). When connecting both to small batch they both work but the lights don't work on the m128. Any ideas? The buttons work, but not the lights. Would greatly appreciate any help.

  • @bc3

    yes, deleting the old one worked, everything is good now:) Thanks bud!

  • Does anyone know if sum works with a 256?

  • In corners, is it possible to get the persistent movement back after the top left 'brake' button has been pushed??

  • In the Audio Drivers section (preferences), there is a 'Live' setting. How does Live see this?

    Trying to get audio into Live and sync it

  • Also how can you load your own drum sounds and samples

  • figured drum sounds

  • @s, thanks!

  • I'm running OSX 10.7.5, just downloaded sum 1.1 and when I open it nothing pops up... the program opens because the menu bar changes to monome_sum but nothing else.

    Any ideas? My monome is connected... serialosc up and running...

  • is there OSC Prefix for monome sum in Pages? If you see a recent string of pages threads, those are likely me. ^_^ sorry

  • i don't believe sum will broadcast itself to be available in pages (sorry!). in many ways the 'smallbatch' (router / upper window) in sum is a sort of simplified replacement for pages, rather than an adjunct to it.

    if you could outline what you're trying to achieve as a whole system we can better point you in the right direction. are you hoping to add the ableton specifics of pages, or is there some other feature set you're after?

  • Well I guess I misunderstood, or maybe havent used sum enough to realize it works as an alternative pages. I figured it had all the functions laid out all on a singular 8x8, or by default an 6x8, so I wanted to keep it at 6x8, or maybe even 7x8 and then keep the final row empty to free up the bottom right corner, so that I could keep evrything with ableton thats been working prime, and jump to sum with the clock slaved, then jump back. mostly because im not a huge fan upon my first impression of the way MLR's gui looks, with my very limited use thus far.

  • @square_wave
    The previous comment is correct, if Sum audio is being sent to the outputs 1-2 of your avid rack, Live won't see this as an input.

    I find the easiest workaround for sending audio between applications is to use an ADAT loopback. For example on my Focusrite 18i20 I just have an adat cable plugged from the ADAT output to the ADAT input. Now anything I send out ADAT 1-2 shows up as an input on ADAT 1-2.

    This would also work with the 002 rack, you'd just have to monitor the audio from sum in Live so you could hear it.

    I've never found soundflower or anything like that reliable enough to depend on and this is a simple work around that does the job for me.

  • For my part, i've found wavtap (https://github.com/pje/wavtap) really easy to use to send Monome_sum audio outs to my Daw (Usine Hollyhock)

    Question: what is the best way to save monome_sum presets with personal sounds?
    (for info, i use the .mxf, not the .app )

  • have something gone wrong with the app page? looks like this for me with no info or download link

  • this has been happening lately with the wiki pages. the only thing that can fix it is tehn or someone clearing cache or something like that.

    http://monome.org/docs/begin

  • Cheers G-man

  • i've tried to do my research ahead of time before asking this question. hopefully this hasn't already been addressed elsewhere in the forum. if so, please pardon my ignorance.

    i'm attempting to use monome_sum with my 64 button monome kit. everything appears to function properly except monome_sum seems to be treating my 64 as though its a 128. is it designed to only work with 128s? i've seen only one video of it being used on a 64.

  • sum should auto-detect you're using a 64. in the smallbatch window, immediately to the right of the serialosc 'connect' button do you see a small square or rectangle lit up? it should light the top-left corner only.

    what makes it seem like it's working as a 128?

  • what version of mlr is sum using? is there a very very simple (like as easy to use as the mlr in sum) standalone version? i ask because i couldn't get the 'normal' mlr from the app page version to output sound. maybe (likely) something stupid in terms of user error.

    i ask because i have been getting these amazing results out of the mlrs in sum by loading very long samples. the same on each side of sum. each gets chopped into these super amazing pieces and i can go on forever rearranging then pattern recording when i find the nicest results. for simplicities sake i was thinking it'd be easier to just be using mlr, but then i guess if i am enjoying the results i am getting immensely, i should just stick with what i have been doing. maybe something better though for my application?

    hats off to the makers and augmenters of the extremely powerful and fun mlr!!!