uninstall serialosc?

  • So I've been trying to uninstall serialOSC for a bit now, but I can't figure out how. I did some googling and came up with this: http://monome.org/community/discussion/11344/serial-osc-uninstall-help/p1, which says to run serialosc-uninstall.command... but I can't find the command anywhere. I'm running OS X Mavericks and serialOSC 1.2a, and I've tried the 1.2a download package as well as the cmds package... It's got to be somewhere obvious right?
    I'm not a big fan of these hidden background clients

  • wait, there isn't one? isn't that kind of important? You’d think that with the time it took to release the next version (the broken 1.3) that an uninstall script could have been written.
    I checked the uninstall command from 0.9 (the only one I could find) and it is LITERALLY three lines long. Unfortunately it does not work on 1.2a

    serialosc can't even find my Max folder, or quit with the start/stop commands. And is there supposed to be three serialoscd's running at the same time? to think a simple max patch works so much better

  • haha I like transparency! yeah I tried searching but there are sooo many of those threads I gave up

    but none of those commands are working for me.
    here's what comes up when I try 'off-serialosc.command' -
    /Users/---/Downloads/monome-commands/off-serialosc.command ; exit;
    launchctl: Couldn't stat("/Library/LaunchAgents/org.monome.serialosc.plist"): No such file or directory
    nothing found to unload
    logout

    [Process completed]

    and the uninstall -
    sudo rm /usr/local/bin/serialosc
    Password:
    rm: /usr/local/bin/serialosc: No such file or directory

  • oh wait! I manually went to the /usr/local/bin folder and found serialoscd - with a d
    so the command: 'sudo rm /usr/local/bin/serialoscd' would work
    thanks!




    also it seems there's a typo in the 'check-monome.command' code:

    elif [ `ls /Applications/Max6.1/patches/serialosc.maxpat` != "" ]; then
    echo "MAXPAT installed: ok (max 6.1)"

    as my max folder is "Max 6.1" with a space (so /Applications/Max 6.1/pat...)

  • In form ;)

  • nice! So I found a few more files:
    'sudo rm /usr/local/lib/monome/*'
    'sudo rm /usr/local/lib/libmonome*'
    to add to the removal list... there's probably a couple more floating around too. how annoying.

  • also if people are searching for this I wrote a .command based on the 0.9 uninstaller, but for some reason "Uploaded file type is not allowed", which I guess makes sense. Anyways, here it is as a .zip

    NOTE: Use with caution! I am not responsible if this somehow breaks your computer (it won't) or leaves behind unknown serialosc files
    This should work for all editions up to 1.2a. Crazy how easy this was...

  • yeah was about to just write a quick shell script. just wrote one for defaults in Yosemite. I <3 them.