Aleph output levels

  • Hello everybody,

    I have been doing my first live performance with the Aleph and had a blast! It was filmed, so I am hoping to send some stuff as soon as possible here. Then again I ran into a serious problem, and can't get out of it right now: the outputs are incredibly low!

    Whatever I do with Waves my line outputs can't get above -25 dBFS when I put it into a sound card, or a mixer (forget about the FS then). I have sent the signal out using osc0_dac0 and osc1_dac1 (to get the two oscillators on each side separately), pushed the fwet0 and fwet1 to 0.00000 (dry signal to -inf to get the full filter effect) and amp0 and amp1 to 0.0000 as well. I am entering an RME Fireface 400 right now and measured it precisely at the analog input from the internal mixer.

    When I played live I had to go in the analog preamps of the mixing console and pushed them really hard, which in return brought me some noise but that was the only way to go as I was playing in a duo with another sound artist. It worked fine in the end because it was noise oriented, but still... I'll add that I didn't notice it before, as I was mostly playing with headphones on. No problem there.

    So my question is: was it done by design from the start, if so why, can I do something about it or is my Aleph eventually having a problem?
    Thanks in advance for your answers!

  • I should add: I tried both output 3-4 and outputs 1-2. With the latter, even when pushing the output level knob to the max (which gives me blinking white light all over) I am still below -25 dBFS. Finally I am using self-made high quality balanced TRS jacks. No mistake from me, unless I totally missed something.

  • this is really strange

  • this is probably a code thing in waves as i know ezra had brought down the levels to a slightly less obtrusive level – i'm not sure about that though. i've misplaced my power supply at the moment, but i have a ff400 too so will do some benchmarking and get you a more proper response tomorrow hopefully!

  • thank you very much galapagoose, that'll help a lot already

  • so did you try it - or anybody else?

  • i hate to suggest this, but have you tried unbalanced cables?

  • tried what exactly? i use waves at home a lot and have now deployed it in gigs several times. maxed, it outputs a pretty standard line level of ~2.0 v peak-peak, ~1.4 RMS.

    if you are using an older version of waves with the full filter-mode-blending, you could check that the lowpass or whatever mode is actually turned up.

  • and to add to tehn's suggestion: the aleph outputs are not really balanced. ring and sleeve are both ground. so maybe something is up with the wiring. (hard to imagine what, though.)

  • Ah so the outputs ARE unbalanced! It says the exact contrary on the main documentation, which is a bit confusing and might explain my problems. Maybe you should rectify this then! Anyway I have a show in two days in a planetarium in Copenhagen using it, so I will try using unbalanced cables tomorrow and will of course report on this issue. Thanks for the reply.

  • hopefully that fixes things & the show goes well

    (if you have audio or video recordings of these concerts share the link with us!)

  • [redacted]

    shoot, sorry about that, i was looking at the schematic wrong. it is the inputs that are truly unbalanced. the outputs are doing something that i frankly don't understand, but certainly won't result in a balanced signal with the ring and tip reversed in polarity.

    [edit] okay, i looked better. the ring is connected to ground with some resistance (can't figure out value from schem+BOM.) so everything i said applies; ring is "zero"; you should see a -6db level drop, but with hopefully better protection from ground loops and noise than if they were tied together and directly to ground.

  • Actually you're right, the change shouldn't come from the cables, but from the F400 trying to receive a balanced signal when it is unbalanced - until now I set it to +4dBu like the rest of my gear, and will change it. Still that's a lot of difference. Now I think you want to change this then: On the main page (http://monome.org/aleph/) it simply says

    audio

    4 input, 4 output.
    balanced, up to 192k 24bit.

    Oh and by the way, all my scenes got erased from my SD Card yesterday somehow. I hadn't removed it one second from the Aleph, just plugged it and it was blank (only the scenes, not the rest). I don't even know how to do it from the Aleph itself aand only used it in performance mode the day before, so I don't know how it happened but I had backups so it's ok. Anybody got the same issue, or is there a shortcut for this that I accidentally hit?

  • yes, i will update the main page. though this is a trickier issue than we give credit:

    http://www.uneeda-audio.com/zbal.htm

    the ring is in fact not driven to ground in the schematic. it's connected to ground with matched impedance, as mackie mixers are, as stated in the "balanced impedance" section at the bottom of the link above.

    so, the aleph outputs should provide better noise immunity using balanced cables.

    sorry for the confusion.

  • oh shoot, you're right, i was looking at the inputs / going on memory. it is the inputs that are exactly what is meant by "unbalanced," which is also the opposite of what the main description page implies.

    okay, i looked better. for the outputs, the ring is connected to ground with some resistance; can't figure out value from schem+BOM, but assume it is equal to the output R for matched impedance. i guess mackie calls this "impedance balancing" as i learned from the article above.

    so everything i said still applies; ring is "zero"; you should see a -6db level drop, but with hopefully better protection from ground loops and noise than if they were tied together (and the cold wire didn't have matched impedance with the hot wire.) this is still not a balanced signal; it is exactly 1/2 of a balanced signal.

    i still don't see why it would mess with your gear, even if you're giving it gain.

  • @i_snor are you sure the card was seated properly? if the connection pin makes contact but others don't, it will still come up and boot succesfully, but be unable to access stuff. the scene files didn't "come back" by chance?

    if the answer is no, then this could be a great insight on potential corruption problems if you can repeat it. (or if i can repeat it, but no luck so far.) for example, i can make the thing wait longer after write-default and before power-down. AFAIK, there is no way to really be sure that the dumb firmware in the sdcard itself is finished with a write, before killing power to it. i guess this is why a lot of devices use simple custom card formats that are more predictable in data layout and less fragile than FAT and so on.

    but i'm also suspicious of mechanical issues.

    can you look at the card's contents on a computer and verify that the directory structure, etc is ok, other files are present, but .scn files are missing? if i'm understanding it correctly. that's a really specific problem that i can look for, helpful in the treacherous process of debugging FAT file nodes by hand.

  • Hi again. The card was blank in my computer, nut only for the scenes and apart from a default file. I haven't done anything special before it happened though, it just suddenly was blank. Hopefully I had a backup. I will try and reproduce it but really I don't know how: I have powered the Aleph like 100 times on and off, and it only happened once. Then I will look into the balanced/unbalanced issue more precisely, I couldn't because of my gig as I had set all the levels properly in the end. By the way the show was really something, with live paintings on a 1000 m2 screen! I will send some pictures and a movie sometime soon, long live the Aleph!

  • I meant only for the scenes were gone, sorry.

  • ok so for more infos: by switching the Fireface 400 to unbalanced input (-10 dBV) I gained a bit, and there is no change between balanced and unbalanced cable then (which is normal). Still after cranking up everything to the max and trying hell of a lot of noisy combinations I could never reach -16 dBFS in the Fireface mixer when getting into regular line inputs, and it is NOT coming from the Fireface: I have tried other pieces of equipment, plus the Aleph has behaved the same with a mixing console for instance... So my question is still valid: is it just my unit, or is it like that for everybody?

    Also about the SD card: still haven't been able to reproduce the problem, but again all the scenes (and only the scenes) have disappeared once at power up, without me doing anything special about that.

  • i'm sorry, all i can report is that i get normal line level output, per design, numbers reported above.

    re:sdcards, i've spent a bit more time diving in the rabbit hole of filesystem debugging. trying to figure out a more deterministic way of resolving write actions before poweroff, instead of just an arbitrary wait time (unprovably sufficient.) email monome about hardware issues.

  • ok so I tested my soundcard's output at 0 dBFS for a 1 kHz sinewave, and got about 2 V AC. When I did the same with the Aleph with the output cranked to the max (and of course no filtering) I got 0.05 V AC although the white LED was on full-time. In my Fireface 400 that corresponded to about -28 dBFS in a regular input set to -10 dBV.

    Now just for the sake of experimentation I tried to boost the signal in all possible ways, with distortion and all, and got up to 0.6 V AC. That is with 100 Hz and full distortion, waveshape at 0.25 where it is the hottest, filtering around 100 Hz with max resonance, which brought the Fireface line input to peak at about -7 dBFS...

    Anyway I totally overloaded the output of the Aleph (the sound became rather unbearable there) and still could never get the line input from my soundcard to clip, far from it. Is that clearer?

  • yes that's much clearer thanks. this seems very much like a hardware problem. the output level is way, way too low.