err, what happened to STEP operator? seems busted

  • just been trying to rebuild some previous scenes in bees 0.5.4 but the STEP operator is spitting out very strange values
    the bitwise switches now give me 0,15,30,45 etc etc, it maxes at 120 and if i try to go higher than what would have previously been 8 (e.g. bottom button lit plus any other ones) i get minus values?

    anyone else had this issue?

  • I gave up. The whole bitwise layout is not fun and I never got a response to how it's implemented.

  • oh, the previous version worked ok.. i wrote a description of how it works on the operators page (if you're using an earlier version of bees) - message me if you're still having trouble, i also put a little explanation in this video (from about 3'20s onwards)

  • Step operator is a known bug in 0.5.4... Brian has worked on it. He provided me a prerelease of 0.5.5 with the fix, but I couldn't get that version of bees to boot on my hardware. We should have an official release with fixes and updates soon.

  • ah ok, thanks for the update!

  • it is busted in the download, i've fixed it already and am waiting for final edits prior to the next rev.

    @mrdave1981 it didn't boot on your hardware?? e-mail me details.

  • great news! thanks @tehn
    (any chance the BIGNUM initialisation bug is fixed in the next revision too? :) )

  • Thanks Duncan, I'll check out the video. BIGNUM initilization was another issues I noticed as well.

  • will check out the bignum init. i think graphic initializers in general need consideration. have you guys checked out BARS?

  • step isn't working - is that right? when i add a step operator and plug in my monome i don't get the sequence length bars (rows 1 & 3) under the play head rows and some weirdness is happening with the play head moving down every row - is that how the bug manifests itself? in fact the behaviour is so odd i'd find it difficult describing it...

  • ok so if i set the step size to 8 then the sequence length bar gets enabled but i'm now getting a lock up in bees edit mode if i start with the drum test scene, add step and metro operators, wire the metro tick to step step, then when i scroll through the inputs to enable the metro the scroll sticks every time when i reach cv-in/mode every time and the aleph has to be rebooted....i'm very confused.

    being dumb - didn't reset aleph properly - though i am fairly sure that when following above tutorial bignum is not changing as the playhead passes over sequence positions with a value set.....