Mesh+The Party Van setup q's/compatibility???

  • is there a way to get this set up happy on a vb128? as in one app on one half and the other on the other. i'm not having luck but also JUST got this 128 and don't know what the fuck i am doing. do i need a third app or can mesh "learn" to be wherever i want to put it? can anyone try out these two apps together and see what comes out?

    success?

    failure?

    thoughts?

  • Hey man. Got your message on muffs. My 128 arrived this morn so will mess about with it and let you know

  • Isn't mesh for the recording and recalling of gestural stuff? I think pages is what you might be after..(I don't know yet..am I right?)

  • mesh is what i was hoping to have on 1/2 of a 128 grid in order to incorporate further gestural memory information to control/interact with tpv. i don't know how to get pages working, tried very little late last night. i may need pages or quadrants or smallbatch or some other program (all of those seem like they could/should be able to do what i want??? but none of them appear to let me do it (probably because of my idiocy)). it seems mesh + tpv could be the simplest way to do it? maybe i need another grid or an arc...an arc is supposed to arrive today. i am just not sure i understand what the specifics are in terms of setup/install/order of operations or really actual function of each of these apps. just hoping for some simple guidance i guess, or a confirmation that what i am even trying to do could technically be done.

  • and maybe i am not being clear enough, likely i misunderstand some of the native mesh functionality d/t not being able to get it to recognize tpv. it's point though is to control another app right? i can get tpv rocking perfectly but when i load mesh, i can get no acknowledgement of tpv's existence. so while both load, they load on the same part of the grid (regardless of mesh 'mode' settings). so i might be able to technically get them to work together, i would have to literally switch the setup 'connect' button in each app preferences at each change/recording... and irritatingly stare at a blank left side of a 128 grid despite knowing it could happily contain one 64 app on one side and another on the other.

  • tried loading again to be sure i was doing it right. only other thing i can notice update in terms of what is going on is that in tpv (and this is probably unrelated) if i press any of the top right 8 buttons, the led feedback goes blank like it is switching the page but to a blank page, this happens whether i load tpv by itself or with other apps.

    can tpv be recognized by other apps? should there be an issue getting tpv to load in the dropdown menu for client app in mesh?

  • hi dude,

    not sure exactly how to help right now (don't have a grid handy), but i can hopefully clear a couple things up for you.

    firstly it's probably good to know that all of smallbatch, mesh, quadrants and pages are all in the same kind of role – they are 'master' patches that can connect to 'client' apps (pretty much every other app). they work by connecting to your physical device and creating virtual devices that your other apps connect to.

    as such you can only run one of them at a time. (no quadrants and mesh together)

    if you're not seeing tpv in the dropdown of mesh it sounds like tpv is not broadcasting it's presence, probably because of an outdated serialosc.maxpat patch. check the tpv folder and delete any 'serialosc.maxpat' file you find. then follow the instructions for installing the global serialosc max patch from here: http://monome.org/docs/customize#max_msp

    also to be clear, are you running mesh as a standalone app, or the max patch version? in general i've found the standalone to be more responsive.

    if the above helps and you can see tpv in the dropdown in mesh then just make sure you select 'split' mode in mesh and you should be in business. if memory serves, mesh is on the left, tpv will be on the right half.

    let us know how you go and i'll try and help further

  • i believe i have followed exact instructions. i am using the mesh standalone. most recent most stable tpv running in runtime. when i try to load/set up the monome port connection in tpv in split mode it overtakes mesh on the leftmost 64grid. i can then toggle back and forth and make one of the apps 'active' (only in the left 64) by reconnecting the active monome port connection in an app. i can tell both apps are ok they just aren't talking. i'll attach a screenshot of the setup screens just in case that could help. and maybe i can try to delete everything and reinstall? or maybe trying to clear some cache/cookies/files/prefs???

    thank you so much for your dedication, hard work, genius and helpfulness. it is superduper appreciated!

  • i think you've almost got it! confusingly it looks like tpv's name in mesh is actually "/monome" so you've got it selected.

    then hit connect on the top serialosc in mesh. it will go yellow. tpv will probably go grey (but that's fine!). then reselect "/monome" in the dropdown, and click 'split' again in mesh. i have a feeling there's a bug where you have to reselect things in mesh.

    try pressing a bunch of buttons on the right of the 128 and see if anything happens. perhaps there will be no lights, but at least some function in tpv?

  • Hmm, I thought I had the latest version of serialosc.maxpat in tpv.

    Also, I might have missed it somewhere, but is there something specific I'm supposed to do in tpv so that it 'broadcasts' the appropriate app name?

  • the name is just the prefix, and by the looks of things that's the newest serialosc up there. i'm willing to bet it's a bug in the much less road tested mesh than tpv!

  • Ah right. I thought it was best practice to just go with /monome for all apps. I can change that back though, if it works better for these meta-apps.

  • ok, i did finally get it going! mesh on left, tpv on right. everything seems to work. getting them both 'active' appears to require a lot of duplicate selections, but if you keep at it it does work and i may be able to narrow down the unnecessary presses or 'correct' order of operations in my setup.

    the other thing i wanted to mention, if it wasn't clear for anybody is that mesh's memory is always focused on the active page (at least with tpv). that was likely obvious to all but myself (having never used it until now). so if you store some presses to a node, those presses will be applied to whatever active page of tpv is selected. it would be amazing to somehow incorporate a kind of page memory to have that node info play back only on the original page it was applied to...but it is also kind of cool to have the current functionality in order kind of micro focus/memorize per page.

    all of this is likely mostly only applicable to the tpv/mesh combo so ymmv grain of salty.

    i want to say the biggest thanks to @galapagoose and @Rodrigo.
    you two are so amazing. i hope i can get a lil smarter with this stuff so i can stop bothering you and you can get back to your lives being amazing! :)

  • well i did have success that one time. can't repeat it though. everything seems like it should work but then i get stuck lights on the grid nuthin. i suppose i will admit defeat on this one. too frustrating and tpv certainly has enough power on its own. it was worth a shot.

  • "appears to require a lot of duplicate selections, but if you keep at it it does work and i may be able to narrow down the unnecessary presses or 'correct' order of operations in my setup."

    this was not my experience. just to make sure i can assist you properly lets go over a few details

    monome 128
    mesh
    the party van
    what are you trying to control with the other "half" of the 128?

  • exactly correct. mesh on left tpv on right. simple as that. no other apps involved. mesh simply to add gestural control to tpv was the goal.

  • hmm, the problem may be trying to control the tpv with two different apps at the same time(normal 64 grid control with the addition of mesh). like @galapagoose said you cant run quadrants and mesh at the same time(or at least this was my experience as well)i will try and set it up this weekend and see if i can get a working array of apps and report back.

  • im not using quadrants. just mesh and tpv

  • ok cool. try this.

    restart your computer
    open mesh and connect 128
    open tpv
    return to mesh and select "/monome"
    then select split mode

    this worked for me on newest mavericks os running on 13" macbook pro and entry level mac mini

  • just did your exact walkthrough. all the lights on the monome started flickering for about 30 seconds and then all the lights went out. hope i didn't just break anything.!

  • ok definitely nothing broken. just had to restart everything. tried the process again, this time just no lights on anything, no control. if it helps i am on macosx10.6.8 tpv is newest with stable dual (not octal) choc grinders. newest serialosc maxforlive. everything installed afaik the way i have been instructed to. i will try mesh with other apps and see if that gets anywhere.

  • well tried mesh with good old mlr in split mode on the 128 and it works like a fucking champ (as i guess you would expect). so if i had to guess i would say the trouble may be coming more on the side of tpv. but i want to give up trying to troubleshoot this concept and explore what i HAVE gotten to work a lot more than what i have not gotten to work. at this point i have a lot of cool ideas and apps to explore them with.