updating the white whale

  • i'm one of the few mk kit users on the white whale. of course, i seem to be having troubles.

    i've gone through the steps and a few potential problems come into focus. first, when i power up my modular while holding the button on the ww, instead of having trig 2, 4 and clock lights illuminated, i get just the clock at about 30% brightness.

    in terminal i have installed homebrew seemingly successfully, as well as the dfu-programmer. when i connect everything and execute the flash command, this is what i get:

    Christopher-Gilroys-MacBook-Pro:~ christophergilroy$ /Users/christophergilroy/Desktop/whitewhale-1/flash.sh
    dfu-programmer: no device present.
    dfu-programmer: no device present.
    dfu-programmer: no device present.
    Christopher-Gilroys-MacBook-Pro:~ christophergilroy$

    any ideas? thanks!!

  • the LED illumination will be undefined on bootloader start, so don't worry about that.

    just to be sure, you have 5v on your rail? and you're using a (somewhat non-standard) usb A-A cable?

    looks like dfu is correctly installed.

  • when you re-power-cycle your modular, does whale start up normally when the button is not held?

  • the first time i was trying it nothing was happening but the "no device present" thing. I went out and got a new usb a-a cable to try that. this time, i got this:


    Christopher-Gilroys-MacBook-Pro:~ christophergilroy$ /Users/christophergilroy/Desktop/whitewhale-1/flash.sh
    Error opening the file.
    Something went wrong with creating the memory image.

    LEDs on trig out 2, 3, 4, are all now full on. when i tried to run flash again, i got the same error of no device present.

    no, turning off the device seems to short power? most of the LEDs on the whole modular stay lit until i disconnect the USB cable. crazy! and now when i turn on the rack again those same trig out LEDs are illuminated.

    for a power supply, i'm using the Pittsburgh MOVE104 PSU, not the cleanest in the world, but has a 5v rail.

  • oh and clock is no longer working on the ww. =o(

  • try first cd-ing into the directory:
    cd /Users/christophergilroy/Desktop/whitewhale-1

    then type:
    ./flash.sh

    make sure to include the "./" at the front. don't ask me what it does but b was insisting it was necessary to open the shell script in the right way??

    also - i remember needing to physically unplug the A-A cable before the +5v rail would reinitialise properly.

  • oh shit, crazy b is right! thanks!

    the upper left 4 buttons no longer flash to indicate trigger output status, correct?

  • not in non-vari mode, it'd be completely confusing regarding mode indication.

  • so you got it to flash? what changed? how can the docs be fixed?

  • it seems to be all set now. i think the first major roadblock i came into is the USB cable i was using was a transfer USB. it was stupid expensive, so i got a cheap one and it started finding the device fine.

    my other problem was based on my misunderstanding of terminal. i was under the impression you can drag and drop a file like flash.sh into terminal and hit enter to execute, which i guess now is not entirely accurate?

  • i have never heard of this "transfer" cable until now. yikes, and thanks for the heads up. i'll post a link to a cheapo cable.

    i'm going to make a clickable .command so terminal won't be involved also.

    thanks for testing!