walnut 64 not recognised by monome_sum.

  • Hi there esteemed monome forum dwellers,

    I have owned my walnut 64 for a couple of years now and whenever I have been in trouble I have always found with a bit of searching the forum always contains the answers.

    However I have come upon a problem that just won't budge.

    I have no trouble with the device appearing for any of my other monome apps that use Max (running Max 5 for what it's worth).

    But the device will not show for monome_sum no matter what.
    Run the monome check command - 5 ok's.

    I suspect that serialoscd may be the issue. I check my activity monitor and it uses 99% CPU.

    Any suggestions most welcome.

    Thanks

    Macbook Pro 10.6.8

  • to confirm, you're using the monome_sum standalone application? in that case this is super surprising as everything is included, and if max5 is working it should be fine.

    if you're opening the patch though you'll need at least max 6.

  • Yes, using the monome_sum standalone. Deleted it several times with a fresh install using the package here: https://github.com/monome/install/releases/tag/v1.1.

    It worked perfectly some time ago but after not using it for a few months now it won't see it.

    As I said, serialoscd is also behaving strangely - uses a lot of CPU and impossible to kill using activity monitor. Could this be related?


  • do you have another ftdi device plugged in? have you done a major os update?

    try manually deleting serialosc by opening a terminal:

    sudo rm /usr/local/bin.serialosc*

    and then reinstalling.

    once reinstalling, open a terminal, type:

    ls -lrt /dev

    and look for your monome device string at the bottom "m64-00023" etc

  • thankyou both for your help with this, much appreciated.

    no other ftdi device as far as I am aware (no other usb device sending messages other than a midi keyboard controller)..

    no os update.

    tried the manual delete, but it says no such file or directory. is there somewhere else it could be located?

    when i input the second line, there are no monome messages at the bottom.

  • "tried the manual delete"

    try it spelled more explicitly than tehn wrote, somethin more like this:
    sudo rm /usr/local/bin/serialoscd
    (or sudo rm /usr/local/bin.serialoscd )

  • deleted serialosc, reinstalled, typed the test string command.

    Seeing my monome on this.

    But still no joy with monome_sum.

    As I said, monome works absolutely fine with other max applications...

  • yes, tried using the package and serial osc on it's own.

  • I have also been searching online on the serialosc running 100% cpu and not quitting unless you fully uninstall as I thought perhaps that was the problem.

    Although there are plenty of threads on this it doesn't seem like there was a resolution - still happens with the latest release. Is there a workaround? Very annoying to have to uninstall every time you want to stop using it.

  • do you have other ftdi devices plugged in? which edition 64 is this?

  • tehn - thanks again for your help. sorry for the newb question - what classes as an ftdi device? i have a powered usb hub connected, a midi controller... drives...

    my monome is from the early 2011 batch with tilt.

    i have also tested it on a 2014 iMac - downloaded the monome device installer and connected it, and no problems at all.

  • Have you tried without the USB hub? My GS64 and my cheapo usb hub don't seem to play nice together.

  • the usb hub doesn't make any difference whether it's plugged in or monome straight to computer usb port.

    pretty sure it's the serialosc issue that is causing the problem. tried with two other computers and neither have the serialosc running at 100% cpu problem once installed (either through the package installer or just installing it on it's own).

    could there be another reason why my computer isn't using serialosc correctly?