Arduinome not registering button presses in monome_test_5.maxpat

  • I can connect the arduinome to the monome_test patch, and I can control the leds.

    It does not register any keypresses.

    I tried to just connect one button so I could test it isolated.

    I changed the firmware so I could get some output from Serial monitor, and I could see it was registering the buttonpresses.
    I had to use Serial.print to get any readable data, am I supposed to be able to read the data going to the computer via Serial.write?

    First I tried using a china copy of Arduino Uno, it registered in ArduinomeSerial but not in serialosc on my mac and I could not see it in monome_test. In /dev/tty.usb* it is listed as /dev/tty.usbmodema40h-001
    Then I tried using Sparkfuns board RedBoard, it did not register on my mac in serialosc. (if I check the /dev/tty.usb* list it is listed as /dev/tty.usbserial-00001014)

    Then I tried my Windows-computer, installed everything according to http://monome.org/docs/setup:win , there I was able to connect it to the monome_test_5.maxpat, but no button-presses are registered...

    The RedBoard uses FTDI-chip, while the UNO R3-clone uses atmega16u2

    I was kinda confused about wiring, since I tried to use both
    http://store.curiousinventor.com/media/images/kits/arduinome/arduinome_wiring_diagram.gif
    and
    http://petermarks.files.wordpress.com/2009/01/sykesdiagram1.jpg?w=640

    The way I figured out the wiring was to just connect one button, and testing until the serial monitor-data was correct ...

    So my questions:
    Is there a problem using RedBoard or china copies of Uno R3?
    Is there any way of seeing what data is transferred to ArduinoSerial or serialosc?

    Any help on this would be very much appreciated..